Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Photoshop Suddenly my Brushes and Eraser are not working properly

  • Suddenly my Brushes and Eraser are not working properly

     Ashii Kumar updated 5 years, 2 months ago 23 Members · 25 Posts
  • David Strelitz

    January 9, 2008 at 8:13 am

    Pulling hair out – CS2.
    Some of the default brushes and the simple Eraser are not working. I seem to remember this happening before but for the life of me cannot remember what causes it.

    Simple test

    New Canvas- fill with colour no problem but using a simple brush or simple eraser does not work. If I use the pattern type brushes no problem. Opacity etc set to 100%
    CLUE Eraser only works if set to Block NOT Brush or Pencil

    Help please

    David

  • Vincent Rosati

    January 9, 2008 at 4:00 pm

    Try: Reset All Tools, there is a triangle drop-down menu next to the active tool’s icon – not on the tool box, but on the main menu. Just under the File & Edit menus.
    Then click the next triangle drop-down, Reset All Tools will be there.

    Also, check to make sure the Brush Tool is set to Brush Tool, and not Pencil Tool or Color Replacement Tool.

    Just a couple thoughts

    Vince

  • David Strelitz

    January 9, 2008 at 5:12 pm

    Thank You for your response. I had tried resetting the brushes but to no avail. What I have found out is that if I select Basic Brushes, then everything works but many from the other brush sets simply do not work either in Brush mode or Eraser.

  • Vincent Rosati

    January 10, 2008 at 12:46 am

    I’m at a loss.

    Reset All Tools and Reset Brushes are two different functions, on two different lists. Try doing both. It sounds like you tried Reset Brushes.

    When the brush is selected in the tool box, try setting the brush Mode to Normal.

    If it still doesn’t work, maybe start a thread in the PS & AI forum. There’s usually more eyes on that forum.

    If you do solve the issue, don’t forget to post your solution. 🙂

    Vince

  • Andrea Brown

    January 19, 2009 at 3:18 am

    Hi Guys,

    Just wondering if anyone managed to figure out this problem. I seem to be having the exact same problem with my photoshop cs3 software. My erasers do not work other than with the pattern and block brushes.

    Looking forward to figuring this out somehow.
    Thanks in advance

    Andrea

  • Matthew Clift

    January 22, 2009 at 12:08 am

    You may be in quickmask mode. At the bottom of your tools palette there is a circle in a square. Just make sure this is off. The shortcut key is ‘Q’ so if you accidently hit this you will be in quickmask mode.

  • Shane Senior

    January 24, 2009 at 4:27 pm

    Ok – pulled my hair out on this too. I have a bamboo pen tablet installed. Using the bamboo mouse (not the pen) – all brushes wouldn’t work. I almost uninstalled and reinstalled the program. I then used the eraser on my pen and – viola – it worked. I started to use my regular mouse, and it also worked. Brush works with the regular mouse too.

  • Sarah Nikolic

    April 22, 2009 at 12:06 am

    Same hear…for the last week or so I haven’t been able to use the eraser when it’s in brush mode…the block worked fine. I also have a bamboo mouse and pen (not sure if that has anything to do with it) but I followed Shane’s advice and used my bamboo pen to erase in brush mode. It worked!….my mouse still doesn’t work but at least I can use the brush eraser with my pen. Adobe both sucks and rocks…lol

  • Regina Pally

    May 1, 2009 at 3:46 am

    My erase tool does not work when I am using layer adjustments>levels. It works if I paint some color on a photo, but when I try and erase part of the levels adjustments the erasing does not occur, even though I have opacity up to %100. I tried all the suggestions from the other posts but still am having a problem

  • Holly Marotta

    July 23, 2009 at 10:24 pm

    I was having the same problem; clone stamp, eraser and all brushes would not work. I saw this post and stopped using my wacom tablet mouse –pen worked fine.

    THANK YOU!!

Viewing 1 - 10 of 25 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy