Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums VEGAS Pro My GTX 1070 Ti GPU is not detected by Vegas Pro16.

  • My GTX 1070 Ti GPU is not detected by Vegas Pro16.

    Posted by Bruce Quayle on January 18, 2019 at 8:22 pm

    I have spent the last couple of days trying to sort this out. I now NEED this forum’s experience and knowledge please.

    Vegas sees the card in “Preferences” where I can add the card to my video processing. I tick the “Legacy GPU” box in “General”. However, when I go to render, and look for the GPU in the “System” tab of “Customize” (using Sony AVC/MVC), no GPU is detected.

    One of the support guys at Magix suggested I use the Magix NVENC codecs, and although I do see some action by the GPU, it is only operating at 8%, while my CPU is chugging along at 80%++.

    I’m sure I’m missing something quite simple, but I’m at a loss after spending money on a card that does little to nothing.

    My system is: Home built Desktop
    MSI Z170A
    CPU: Intel(R) Core(TM) i7-6700k
    16 GB RAM – G-Skill Ripjaw V series
    GPU: Nvidia GeForce GTX 1070 Ti
    16GB DDR3 System Memory
    Samsung SSD 850 EVO 250GB (system drive)
    WD HDD Blue 7200 1TB
    2 x 500MB WD HDD (from laptop)
    LG BR writer (16x)
    Vantek Internal card reader
    Dell 2715H 27″ Monitor

    I would appreciate help from anyone who can point me in the right direction.
    Many thanks.

    Cheers,
    Bruce

    David Bagatelle replied 4 years, 7 months ago 5 Members · 13 Replies
  • 13 Replies
  • Graham Bernard

    January 19, 2019 at 6:30 am

    [Bruce Quayle] “Vegas sees the card in “Preferences” where I can add the card to my video processing. I tick the “Legacy GPU” box in “General”.”

    Bruce? Are you attempting to get your GPU recognised within a Render Template? I’m confused……Can you walk me through the EXACT steps you’re using to get VP to recognise your GPU? For GPU acceleration I set mine through Options > Preferences and then Video. My thoughts are that you’ve not done this and as such you’re attempting to select GPU in the Render Menu of a Render Template. The other thing is to ensure your GPU Drivers are up to date.

    * Grazie

    Video Content Creator and Potter
    PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
    Cameras: Canon XF300 + PowerShot SX60HS Bridge

  • Bruce Quayle

    January 19, 2019 at 12:05 pm

    Thank you for your reply Graham.

    Firstly, I have only recently installed the graphics card, and yes, I have installed the latest drivers.

    The first thing I did was got to >Options, >Preferences, >Video, where I selected the graphics card listed (GeForce GTX 1070 Ti) in the “GPU acceleration” box.
    Next, while still in “Preferences”, I went to the “General” tab and selected “Allow GPU legacy rendering”.
    Applied these changes.
    Then I selected the video I required to be rendered, >Render as, > Sony AVC/MVC >Internet 1280×720-30p.
    Then click on Customize template >Video >Encode mode >Render using GPU if available.
    Then I click on the System tab >Check GPU.
    Alas Vegas then tells me “No GPU available”.

    And that’s where I am at present. I’m wondering if there is something I’m not doing in Windows? I am running Windows 10 (64). It is regularly updated.

    Thank you again for your response.

    Cheers,
    Bruce

  • John Norton

    January 19, 2019 at 5:24 pm

    Hi Bruce, no need to select Legacy gpu, yours isn’t. The render assisted Nvenc templates to use are “MAGIX AVC/AAC MP4 & Hevc template, they have preset nvenc settings.

    If you just use Mainconcept AVC as “encode mode” instead of Nvenc, you will still get the benefit of your gpu for render times, to see try disabling it in preferences.

    The Sony Avc doesn’t have the Nvenc options only the Magix.

  • Graham Bernard

    January 19, 2019 at 6:02 pm

    [John Norton] “The Sony Avc doesn’t have the Nvenc options only the Magix.”

    Thanks John.

    * Grazie

    Video Content Creator and Potter
    PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
    Cameras: Canon XF300 + PowerShot SX60HS Bridge

  • John Norton

    January 19, 2019 at 11:24 pm

    ????

  • Bruce Quayle

    January 20, 2019 at 11:31 am

    Hi John, and thank you for your input.

    I did get this suggestion from a Magix support chap and tried out the Nvenc templates with limited success. I found that (at last) my GPU was beginning to work, but at only 8% activity. The rest of the work (60% activity) was being done by my CPU.

    I tried again after your suggestion with the same result. Then I attempted using the Mainconcept AVC as encode mode, but saw zero activity from my GPU.

    I have read posts from other folks who are seeing fantastic render assistance from their GPUs, so I still believe I am missing something very basic. Could I have installed the card incorrectly? Perhaps I need to change something in my Windows 10 settings? Do I need to somehow point my GPU to Vegas…or vica versa?

    Another concern I have is that some people are experiencing noise being brought into their renders via the Nvenc templates, particularly in dark areas of their videos. This would be as problem for me. But this is less of a problem than getting this expensive piece of kit to function 100% with Vegas!

    Further advice would be GREATLY appreciated.

    Cheers,
    Bruce

  • Graham Bernard

    January 20, 2019 at 11:55 am

    [Bruce Quayle] “Could I have installed the card incorrectly? “

    This is way beyond my pay-grade, but we need to establish that the GPU is functioning correctly. Could you run diagnostic tests on your GPU? Would you remove and reseat it? Would you completely remove/delete your GPU Drivers and install afresh?

    I’m trying here…..????

    * Grazie

    Video Content Creator and Potter
    PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
    Cameras: Canon XF300 + PowerShot SX60HS Bridge

  • John Norton

    January 20, 2019 at 12:06 pm

    Hi Bruce, its easy to confirm if you are getting the benefit of your Nvenc gpu rendering, it should be several times faster to render.

    If it is rendering a lot faster using Nvenc for similar data rates vs Mainconcept without Nvenc then no issue. You can compare the quality to see if it’s acceptable.

    Nvenc rendering uses a purpose built chip called an asic on your gpu to do Nvenc, because the grunt work is offloaded to this chip your overall gpu usage may look quite low, also the gpu and cpu temps will be lower.

  • Bruce Quayle

    January 20, 2019 at 1:56 pm

    Thanks to both Graham and John for your valuable advice.

    Okay…so I re-installed my card, as suggested. Latest drivers all round and latest iteration from Vegas (16.0.0.361) also installed.

    Teasted card via windows and all appears to be functioning fine.

    I’ve just completed a test on a 1 minute section of video containing some colour correction and dissolves and although the GPU only displayed 8 to 16% activity, the clip rendered more than 50% quicker using the Nvenc template.

    So clearly, your comment on the asic chip is 100% John! I have yet to do a test to check on the comment I read about added noise in dark areas, so I cannot comment on that point.

    Thank you so much for the time you have both taken to address my issue. I really do appreciate it.

    Cheers,
    Bruce

  • Graham Bernard

    January 20, 2019 at 6:26 pm

    [Bruce Quayle] “Thanks to both Graham and John for your valuable advice.”

    You’re welcome ????. What you get from me, hopefully, is patient persistence, served up with a splash of levity thrown in. Oh yeah, I’ll say when it’s beyond my knowledge.

    * Grazie

    Video Content Creator and Potter
    PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
    Cameras: Canon XF300 + PowerShot SX60HS Bridge

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy