Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Storage & Archiving LTO cartridge taking long time to erase new/old media

  • LTO cartridge taking long time to erase new/old media

  • Hari Krishna Pune

    January 18, 2021 at 2:38 pm

    Hi everyone,

    right now I am using a HP storeever LTO 6 tape drive along with the hpe graphical interface, it is been fine since saturday. And today while I am trying to format a new tape it is taking 4-6min and cartridge is keep ejecting & loading automatically 3-4times. Also while writing the data to the cartridge for each 10min the cartridge is ejecting & loading automatically which results taking longer time to finish the backups.

    Drive type: HP storeever 6250 HH SAS

    system: mac pro, os: 10.11.6

    atto r680 with latest firmware

    ltfs 3.2.0 also checked with 3.4.2

    any suggestions?

    thanks in advance.

  • Tim Jones

    January 18, 2021 at 3:46 pm

    There are two erase modes for tapes – a quick erase and a full erase. The full erase (what you’re probably running) will take the full time to erase the tape that it takes to fill the tape with data. For an LTO-6 tape, this is a bit over 4 hours, LTO-7 is 6+ hours and LTO-8 is up to 10 hours.

    On the other hand, the short erase only clobbers the beginning of the tape and the ability to retrieve data from the rest of the tape by creating a new EOD (end of data) marker in the first block.

    LTFS tapes take this one step further since you either need to know how to change partitions before running the erase steps, or use a tool that allows you to delete the LTFS partitioning (effectively performing a short erase) and then recreate the LTFS format.

    This last method is probably your best option since you’re using LTFS. With the HPE LTFS tools, use the mkltfs command:

    mkltfs -w

    or

    mkltfs –wipe

    And then reformat for you normal use.

  • Hari Krishna Pune

    January 18, 2021 at 4:23 pm

    Hi Tim,

    thank you for your quick reply. All I am doing is giving format command from hpe graphic user interface. There isn’t two option like you said quick or full tape erase. And it is not taking like 4 hours to fomat just a few minutes than regular.

    I even tried with command line using terminal with mkltfs -d 0 result is the same. As you said I tried wipe the tape and reformat still didn’t help.

  • Hari Krishna Pune

    January 18, 2021 at 4:25 pm

    Another point is while formatting the cartridge it is saying “changing the drive setting to write anywhere mode” which actually prevents the tape ejecting. But still why is the tape getting ejected while formatting or running the backup?

  • Hari Krishna Pune

    January 18, 2021 at 5:58 pm

    While I tried to mount tape through terminal I am getting some errors which I have never seen. Please check the attachment if there’s anyone seen them before please suggest me a solution. Thank you.

  • Martin Greenwood

    January 19, 2021 at 8:17 am

    LTO drives do this process of tape ejection and reload sometimes, it’s a re-chuck function performed automatically by the drive when it detects certain errors.

    It is not common, when it occurs it’s either a drive or tape issue. Have you tried other tapes ? You may find loading the cleaning tape resolves it. If it’s doing it all the time with multiple tapes then the drive will need a service.

    Martin

    CTO

    YoYotta.com

  • Hari Krishna Pune

    January 20, 2021 at 1:45 am

    Dear Martin,

    I did tried with multiple tapes new and old. Tried with cleaning cartridge as well. It’s a rental drive and the provider is insisting drive is in perfect condition and the problem must be with the mac environment where he has no idea.

    So I have connected the same drive to a Windows workstation with a different sas card cable also returned with the same issue. I have also tried using different downgrade versions of ltfs. But result is same.

    Another main issue that I am facing is while I am trying to backup data, for 2.31gb file it is occupying the space on tape is 4.4gb. I have given the remote control to the provider and he finally comes to an conclusion that it is the issue with the tape media. But I have even tried with the old tapes as well which already partially backed up also resulting the same. Couldn’t find a solution.

    15 days of arri raw, red raw are waiting to be backed up.

    Actually this is the 3rd drive provider changed in the same month. Earlier sent hp drive is copying data around 50gb and suddenly turning on all the lights of the front panel and the copying is stopping with an error of copyright and the tape is going to inconsistent state. So I returned it, but provider said it is perfectly working there after they received it.

    That it the reason they were insisting the problem must be from my side.

  • Martin Greenwood

    January 20, 2021 at 9:26 am

    Hi Hari,

    There is no software command to perform this “re-chuck” function. It’s a function performed by the drive.

    Also LTO drives are designed to automatically mark and skip over tape when they detect write problems. This allows them to cope with occasional tape issues. However in your case the drive is doing this all the time, which is why after writing, a lot more space has been used compared to the size of the files written. So the tape capacity is reduced. This together with the fact that multiple tapes behave the same way suggests that it may be a drive issue.

    We are seeing older LTO-5 and LTO-6 drives in use that have 6+ years of heavy usage behaving this way. Whilst it’s good that the drives carry on working, they are really at end of life.

    I think it’s worth installing our YoYotta LTFS software as it reads diagnostic usage, error and health information from LTO drives and tapes. I’m not suggesting running archive jobs as I’m sure this will have the same issues, however the health information will be useful.

    If you want to do this please download the demo using this link.

    https://yoyotta.com/help/demo.html

    Then mount and eject each tape in turn.

    https://yoyotta.com/help/mountLTFS.html

    Then save a copy of the log + debug as described here…

    https://yoyotta.com/help/logging.html

    Then send this for analysis to my email which is shown below.

    Martin Greenwood

    CTO

    YoYotta.com

    [email protected]

  • Tim Jones

    January 20, 2021 at 5:00 pm

    Another main issue that I am facing is while I am trying to backup data, for 2.31gb file it is occupying the space on tape is 4.4gb. I have given the remote control to the provider and he finally comes to an conclusion that it is the issue with the tape media. But I have even tried with the old tapes as well which already partially backed up also resulting the same. Couldn’t find a solution.

    In light of the numbers above, when you “overwrite” an LTFS volume, you’re losing the capacity of the data that you’re overwriting because, unlike a disc, LTFS doesn’t replace files that were already written, it just marks them as not existing in the LTFS index, resulting in the loss of the originally used space on the tape. If you tried writing that file to the tape again, you would discovered that you have lost another 2.31GB.

    As for formatting, I go back to my original recommendation. In a Terminal (not the HPE UI), execute that command with the tape inserted in the drive but NOT mounted:

    mkltfs --wipe

    That will properly remove the LTFS formatting and effectively “erase” that tape. You would then reformat that tape to start fresh.

    As for the other issues, what is your environment like – temperature, humidity, dust? All of these things can negatively affect the operation of a tape drive.

    Tim

    Tim Jones

    Chief Solutions Architect
    Other World Computing, Inc.

  • Neil Sadwelkar

    January 20, 2021 at 5:52 pm

    Hari,

    Unless its a typo, I noticed that you’ve written you are using an Atto R680 card and not an Atto H680. The R680 is a RAID card as far as I remember, and (hope Martin doesn’t mind) I’m reproducing this from Yoyotta’s support page…

    “ATTO ThunderLink SH1068, SH2068 TB-SAS, ThunderStream SC4808 adaptors, R680 or R644 PCIe RAID SAS cards do not support TLR which is a required protocol. So they are not compatible with LTFS running on any operating system.”

    So, maybe that’s the problem in your installation. The SAS card you’re using R680 doesn’t support TLR, hence LTFS.

    Have you tried, or can you try with this drive and connecting via a H680 or H1280, and see if that makes a difference.

Viewing 1 - 10 of 22 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy