Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro X Yikes, what’s happening with transitions!!!????

  • Yikes, what’s happening with transitions!!!????

    Posted by Simon Ubsdell on June 24, 2011 at 3:08 pm

    I can’t believe I haven’t noticed this before but it’s because I hadn’t got round to seriously exploring transitions.

    Adding a transition between two clips on the primary storyline (the only place you can actually do it!) results in the sequence rippling!!!!!!!!!!

    Please say I’m doing something wrong!!!

    Simon Ubsdell
    Director/Editor/Writer
    http://www.tokyo-uk.com

    Mike Jeffs replied 12 years, 9 months ago 8 Members · 14 Replies
  • 14 Replies
  • Simon Ubsdell

    June 24, 2011 at 3:20 pm

    OK, it doesn’t work that way if you can be bothered to drag a transition out of the Transitions menu – but seriously!!!!!!

    Cmd/T on a transition will absolutely, definitely ripple your timeline for you and that cannot be right. Surely!? Who thought anyone would want it to behave like this? It’s madness!

    Simon Ubsdell
    Director/Editor/Writer
    http://www.tokyo-uk.com

  • David Burch

    June 24, 2011 at 3:25 pm

    Madness?! THIS. IS. X!!!.

    Seriously, though, there may be a hidden setting for this. It does seem a bit ludicrous if there isn’t a way to turn that off.

  • Simon Ubsdell

    June 24, 2011 at 3:30 pm

    If anybody finds David’s secret key, please shout out!

    But seriously, I can’t imagine anybody at any time editing any kind of project on any galaxy know or unknown would ever in a million light years want this behaviour with transitions.

    Simon Ubsdell
    Director/Editor/Writer
    http://www.tokyo-uk.com

  • Dave Jenkins

    June 24, 2011 at 3:31 pm

    Buy Ripple Trainings FCP X series. It explains alot of this things that are odd. It is a simple change in the Preferences. Apply transition using Available media works like FCP 7

    Dajen Productions, Santa Barbara, CA
    MacPro Two 2.8GHz Quad Core – AJA Kona LHe
    FCS 3 OS X 10.6 QT 10

  • Simon Ubsdell

    June 24, 2011 at 3:34 pm

    Thanks, Dave – there was a magic key after all.

    But I doubt there’s an answer to my question of why anyone would want that as a default (!) behaviour!!!!!!! (Except of course someone who knows nothing about non-linear editing and wouldn’t understand handles.)

    Simon Ubsdell
    Director/Editor/Writer
    http://www.tokyo-uk.com

  • Geoff Dills

    June 24, 2011 at 3:34 pm

    Look under settings…you can choose how you want transitions to behave. Either works like you have it now where it adds the length of the transition so all the existing footage is outside the transition or switch it to have the transition use the current footage without lengthening your timeline. I am not near FCPX so not sure exactly the exact wording.

    Best,
    Geoff

  • Richard Truchanowicz

    June 24, 2011 at 3:35 pm

    In the preferences, try changing “Apply Transitions Using” from “Full Overlap” to “Available Media”. That should solve your ripple problem. The default way builds transitions using only the footage that is explicitly put on the time line. The other option uses the unseen handles to prevent the sequence from rippling. It seems like there should be an easier way to set this on a per transition basis, but I haven’t found it yet.

    You can apply transitions to clips outside the main storyline by encapsulating them in a secondary storyline, however it doesn’t seem like you can use them to transition between the primary and secondary storylines. When I apply a transition to a single secondary clips it transitions between the clip and black rather than the underlying primary storyline. You can keyframe opacity to ‘manually’ fade between the two if all you’re looking for is a simple dissolve.

    At least, that’s what I’ve figured out so far. I think it’s ‘mostly’ right…

    -Richard Truchanowicz

  • Simon Ubsdell

    June 24, 2011 at 3:37 pm

    Interestingly if you deselect the full overlap option and then try to add a transition without having sufficient handles you only get the option to cancel or use full overlap. You don’t get the option to shorten the transition – which is the behaviour we have come to expect from our NLE’s.

    But I should have read the manual before posting … 🙁

    Simon Ubsdell
    Director/Editor/Writer
    http://www.tokyo-uk.com

  • Dave Jenkins

    June 24, 2011 at 3:41 pm

    I think there will be a lot of these discoveries. Didn’t know about the (without having sufficient handles you only get the option to cancel or use full overlap) BUMMER!

    Thanks for letting us know.

    Dajen Productions, Santa Barbara, CA
    MacPro Two 2.8GHz Quad Core – AJA Kona LHe
    FCS 3 OS X 10.6 QT 10

  • Stephen Bakopanos

    June 24, 2011 at 3:45 pm

    [Simon Ubsdell] “But I should have read the manual before posting … 🙁

    Nah dude, it’s ok. We’re all a bit frazzled by this release. I too was tearing my hair out trying to solve this – I was at the point of deleting FCPX and tossing my MacBook in the bin, but thankfully I checked here first…

    Going to spend the weekend with Ripple and see how I feel on Monday.

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy