Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Blackmagic Design Ultrastudio Mini Monitor NOT WORKING…not even aa light + CAT PIC

  • Ultrastudio Mini Monitor NOT WORKING…not even aa light + CAT PIC

     Greg Janza updated 7 months, 1 week ago 2 Members · 4 Posts
  • Patrick Clement

    December 24, 2013 at 5:14 am

    I sent off an email to BM Support, but I figure maybe there were some holiday lookie loos that might be able to help me out. Take a break from the family and drown yourself in my problems!

    GOAL: Monitor Video on my NEC Monitor via Blackmagic Ultrastudio Mini Monitor for color grading in Davinci Resolve/Premiere Pro CS6.

    PROBLEM: Mini Monitor not functioning correctly. Possibly hardware compatibility issues/user error.

    Intel Core i7-3770k Processor
    Windows 7 SP1
    Gigabyte GA-Z77X-UP5 TH Motherboard (Dual Thunderbolt Ports)
    2x GeForce GTX 670 GPU’s (Not SLI’ed)

    2x LG EW224 (GUIs)
    NEC PA271w

    1. Installed updated Drivers and Desktop Video from BM.
    2. Installed Legacy Drivers.
    3. Rebooted computer 1,000,000 times.
    4. Displayport from GTX670—>Mini Monitor —> HDMI OUT —> DVI INPUT on NEC
    5. Displayport from other GTX670 —>Mini Monitor —> HDMI OUT —> DVI INPUT on NEC
    6. Thunderbolt output from MOBO —>Mini Monitor —> HDMI OUT —> DVI INPUT on NEC
    7. Switched every cable with different cable.
    8. Displayport from GTX670 —>Mini Monitor —> HDMI OUT —> HDTV
    9. Displayport from other GTX670 —>Mini Monitor —> HDMI OUT —> HDTV
    10. Thunderbolt output from MOBO —>Mini Monitor —> HDMI OUT —> HDTV
    11. Praying to God. (it was worth a shot)
    12. Yelling.
    13. Sending back that Mini Monitor and buying a new Mini Monitor.
    14. Repeat 1-12 with new Mini Monitor.

    No matter what I try:
    1. Light never comes on.
    2. Black Magic Control Panel never recognizes Mini Monitor (menus are locked).
    3. Neither Premiere nor Resolve recognize Mini Monitor.
    4. Screen on NEC always says “No Input”

    1. I can plug the monitor directly into the Displayport of either GTX670 GPU’s and the monitor recognizes the signal. I can use as a third desktop monitor or monitor in Premiere.
    2. The NEC doesn’t receive a signal when I connect a Thunderbolt cable from the MOBO’s Thunderbolt to the NEC’s Displayport.

    Please, let this be a small stupid problem I’ve overlooked.
    Anybody and everybody’s help would be appreciated.

    – Patrick

  • Patrick Clement

    December 27, 2013 at 1:40 am

    Re: Mini-Monitor NOT working…not even a light

    PostTue Dec 24, 2013 3:48 am
    What slots do you have your graphics cards plugged in to?
    The bottom socket on the board will be sharing with the TB sockets as will any of the 1x sockets so try not to use those.
    You could also try going into the BIOS and upping the bandwidth setting for the TB sockets.
    Another thing to check is if the Mini Monitor shows up in Device manager

    Re: Mini-Monitor NOT working…not even a light

    Thanks for the reply.
    Both of my GTX670’s are in the first and second slot respectively. I believe this was the suggested configuration by the mobo manufacturer.

    The order of my cards are:
    Recon sound card
    Wi-Fi network adapter

    The Mini. Monitor does not show up in the device manager

    I forgot to mention that I did access my bios and changed the TB bandwidth to 512k and it did not appear to make any difference.

    Re: Mini-Monitor NOT working…not even a light

    If it were me I’d try removing all other cards and external device. Just leave 1 GPU in there and take out all the other cards as well as unplugging any external device except monitors, keyboard and mouse and then check to see if you have the latest TB driver, update if you don’t and then uninstall and re-install the BM software (as sometimes it needs to be re-intalled to kick things back in).
    If it still doesn’t show up in device manager under ‘Sound, Video & Game controllers’ after that then I’d suspect you have either a faulty cable of a faulty Mini Monitor.
    BTW I have used one of these motherboards, but with the TB Shuttle and the Ultrastudio 4K and had no issues, but I only had 1 GPU installed


    Posts: 5
    Joined: Mon Dec 23, 2013 10:43 pm

    Re: Mini-Monitor NOT working…not even a light

    Thanks for the reply.
    This is exactly what I am going to try next.

    From what I’ve read Thunderbolt for PCs has been unreliable and require some workarounds with my mobo.

    But that doesn’t really explain why I wasn’t able to output from the displayport of my GTX670. Perhaps there are compatibility issues there. But I wouldn’t think I have an “unusual” setup for PC grading so I wonder if anyone else has encountered this issue.

    Re: Mini-Monitor NOT working…not even a light

    Not sure what you mean by outputting from the Display port of your GPU. The Display ports on graphics cards are not Thunderbolt sockets so if you are trying to connect the Mini Monitor to that socket it won’t work.
    As to your NEC monitor not working when connected direct to the TB socket you may need to enable the onboard GPU and increase the memory bandwidth, as well as making sure you’ve installed the Intel graphics driver


    Posts: 5
    Joined: Mon Dec 23, 2013 10:43 pm

    Re: Mini-Monitor NOT working…not even a light

    Thanks for the reply.

    Yes, I’ve figured out that the displayport from my GPX670 isn’t actually a “thunderbolt,” although I think that is understandable, since the technology is so similar.

    So that won’t work.

    I’ve updated my Intel Graphics Drivers and I’ve done the following:

    1. Took out all of my PCI cards except one GPX670.
    2. Moved it to every available slot.
    3. Removed the GPX670 and connected on board DVI output.
    3. Accessed BIOS and alotted 39k bandwidth and 256k Memory to Thunderbolt ports.
    4. Yelled some more.

    NONE of these appeared to activate the Thunderbolt ports which did not activate the Mini-Monitor.
    I also installed and reinstalled BM Desktop Video a number of times and rebooted a million times.

    5. Also tried to connect Thunderbolt to Displayport on NEC, didn’t work.

    I’m convinced this is probably my MOBO/Thunderbolt port.

    There are only two other possibilities:

    1. I purchased “Thunderbolt compatible” cables instead of OEM Apple Thunderbolt Cables. Will go to Apple Store tomarrow and buy OEM cable, to see if that might do it.

    2. My Thunderbolts just arent working. Return Ultrastudio and purchase Decklink Monitor PCI.

    I’m willing to try anything that might get this working.
    I can’t be the only person in the world that has expereinced these issues, someone wave a magic wand and make this all better 🙂

  • Greg Janza

    January 4, 2022 at 3:30 pm

    I don’t think it’s your computer. I have a Mini monitor 4k card that was working flawlessly but I upgraded to a new PC with a different Mobo over the holiday and now I have the exact same problem. I’m on Windows 11 and my new system doesn’t see the mini-monitor card in Device Manager or even in the Bios. I’ve done a half million restarts and re-loads of Desktop Video but nothing works. I believe this is a fail of BM.

    My system:
    Processor AMD Ryzen 9 3950X 16-Core Processor, 3501 Mhz, 16 Core(s), 32 Logical Processor(s)
    Mobo- MPG B550 GAMING EDGE WIFI (MS-7C91)

    RTX 2060 Super
    64 gigs RAM
    Windows 11 Home Version 10.0.22000 Build 22000

  • Greg Janza

    January 5, 2022 at 5:21 pm

    I’ve spoken with BM tech support and they have no idea why this is happening. The one suggestion they had is to roll back to Desktop Video 11.5 to see if the software is more compatible in earlier versions.

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy