Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums DaVinci Resolve Suddenly version 17.0 & 17.1 are not compatible with Mojave?

  • Suddenly version 17.0 & 17.1 are not compatible with Mojave?

     Neil Sadwelkar updated 2 weeks, 4 days ago 6 Members · 12 Posts
  • Chris Morris

    August 3, 2021 at 2:27 pm

    My old install of DaVinci wont open on my cheese-grater 5,1 with Mojave, but I just did a fresh install of Resolve 17 and it worked. It was the non-studio version though.

  • Neil Sadwelkar

    August 29, 2021 at 12:47 pm

    I think the incompatibility has something to do with your hardware along with MacOS.

    I am typing this on a 15″ Late 2016 MacBook Pro running MacOS 10.14.6. And there’s Resolve 17.3 installed and running on this system. I also have Resolve Studio App Store version 17.3 and it runs fine on this system.

    Before 17.3, this MacBook Pro had Resolve 17.2.2, and before that 17.1.x.

    I have a feeling that if you’ve installed Resolve 17.0.x beta, then you may have to uninstall it and then install the shipping version. Bear in mind that uninstalling Resolve also uninstalls the database. So please backup database before uninstalling.

Viewing 11 - 12 of 12 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy