Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D rig Joints unable to be animated

  • rig Joints unable to be animated

    Posted by Jess Tan on March 7, 2019 at 5:49 pm

    Hi C4D gods, this is a cry for help :’)

    The backstory: I have a character model, found mixamo and thought wow cool! ez quick rig. so I used mixamo to get a rig for it, exported the t-pose and all is great. The joints move as they should, and are weighted correctly. I thought that I just saved heaps of time thanks to mixamo! but……

    The problem: Now, when I am trying to manually keyframe a walk cycle for my character, it seems ONLY the Root joint (at the hip) is able to be keyframed. No matter what I’ve tried, the hands, legs, every other joint other than the root hip joint fails to able to be keyframed.

    What I’ve tried, but to no avail (works for root hip joint and every other object except the other joints):
    – Turning on parameters, position, scale etc beside the timeline for recording.
    – Changed Model mode to Object mode.
    – Tried both Record Active Objects button and Autokey button, does not work
    – Tried Ctrl+click on each changing parameter, it doesn’t respond (stays grey instead of turning red)
    – Thought maybe other joints were locked or something, so I selected all joints, went to Attributes > Coord. > Freeze Transformation > clicked Unfreeze All. nope. still not keyframing.

    – In Animation layout, I realised only the Hip joint is in the Dope Sheet with Position and Rotation Property Tracks. Hence, I tried to manually drag and drop the other joints into Dope Sheet from Objects Window. nope. not keyframingggggg
    – Thought maybe I have to manually add the Property Tracks to each joint in the dope sheet, so I right click the joint in the dope sheet > Add Property Tracks > Position > All, the property track appears in the Hip joint instead of my targeted joint.. These joints just won’t respond to me!!!!!!!

    What I’ve noticed:
    – In the Dope Sheet, it seems the joints that I am unable to animate are missing an Animation icon that the Hip joint has. see here —->

    author’s note:
    It might be possible that since it is a mixamo rig, the other joints are just locked out and can’t be animated?
    maybe it is known that mixamo’s rigs aren’t good to work with in the first place?
    Should I just consider manually rigging my character? :c

    any help is appreciateddd.

    Matthias Stoll replied 2 years, 4 months ago 2 Members · 2 Replies
  • 2 Replies
  • Jess Tan

    March 8, 2019 at 3:26 am

    ok problem solved, turns out I missed out checking Takes. As the T-pose rig was taken from mixamo, the Take was set to “”, hence locking many functions for the rig, such as keyframing them.

    To anyone who had the same frustration as me, make sure to go to Animation Layout, Takes tab and select ‘Main’ take. Problem solved!

  • Matthias Stoll

    November 12, 2021 at 3:35 pm

    Hi everybody!

    I just had a related problem. In my case the controllers became invisible because the geometry “ate” them. I needed to solo them in the “Layers” tab to be able to control them.

    There doesn’t seem to be a way to just scale up the controllers (R21). My problem is, that the rig I feeded into mixamo already was scaled to fit the scene proportions. No big deal, but it took me quite some time to figure this out.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy