Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects RAM Previews Not Real-Time on 4K Monitor (Windows)

  • RAM Previews Not Real-Time on 4K Monitor (Windows)

  • Jeff Klein

    January 5, 2017 at 5:19 pm

    Hello. I recently upgraded to a 4k (UHD) monitor and my RAM previews will almost never play back in real-time (at least not for the duration of the preview). I’ve read some threads where people were having the problems (although the 4k monitor is rarely mentioned) and some workarounds include dragging panels above/below the timeline (to make the timeline smaller) and only doing previews full screen. Both these things may have helped but definitely didn’t solve the problem. I’m 99 percent sure the new 4K monitor setup is causing the problem because 1) I wasn’t having this problem before 2) if I drag After Effects onto my secondary monitor (1080p) the problem seems to go away (I’m not OK with working this way since it’s defeats the purpose of the new monitor)

    I DO have “cache before playback” checked in the preview window (I feel this checkbox alone should accomplish what I’m trying to do, but it doesn’t). In the past (I’ve never used a 4K monitor before) any time frames were cached (the area was green above the timeline) then the preview always played back in real time. All I want is for things to behave this way, I don’t care if I have to wait a little longer for previews to start.

    Since starting to write this post I’ve discovered a workaround that “solved” this problem . If I make the After Effects window smaller (so it’s not taking up the full 4K screen, instead just a portion of it) previews seem to play fine. This could be a solution for time time being but it would suck if I had to work this way permanently (again, because it would kind of defeat the purpose of having the 4k screen. ) 4K monitors have become fairly common now, I can’t imagine the After Effects interface can’t “handle” them (I don’t know why that would affect RAM preview playback anyway).

    Anyways, moral of the story is I want to be able to have After Effects open full screen on my 4K monitor and have RAM previews always play back in real-time. Any help would be appreciated. Thanks!

    Tech specs just in case:
    – I have the newest CC 2017 version After Effects on a Windows 7 machine
    – Quadro K620 video card with the latest drivers
    – Xeon W365 CPU
    – 24 gigs RAM
    – OS on an SSD with footage is on a RAID 0

  • Jeff Klein

    January 5, 2017 at 6:15 pm

    Hey Dave, thanks for the response. But just to be clear. I’m only working on a 1080p project so even at full-resolution the previews will at most be 1080p (I’d even be cool if they worked at half-resolution). The issue has nothing to do with the size of the preview themselves, it is related to the size of the After Effects software (user interface). If I have After Effects open full-screen on the 4K monitor the RAM previews will not play in real time now matter what size or resolution they are. If I shrink After Effects down so it’s only taking up a smaller portion of the 4K screen, or if I move After Effects onto my secondary 1080p monitor, the same exact RAM previews play fine.

  • Stefan venbroek

    January 21, 2017 at 10:27 am

    Hello Jeff,

    I was reading your post about the realtime preview problems on a 4K monitor in After Effects.
    I have the same problem. I was working on a quit powerful Macbook Pro with an normal HD monitor. Not problems
    with the previews in After Effects. Now I recently bought an Widescreen monitor and the Ram Previews in After Effects
    (newest version 14.0.1) are not always in realtime. The sound has an delay and sometimes it switches back to 22 frames a sec.
    instead of 25. So it’s not cool. Even if I small down the After Effects window it doesn’t change the not realtime preview. When I take the whole After Effects window to my Macbook Pro it plays the Ram Preview perfectly.

    I was wondering if you found an solution for this annoying problem.

    All the best,

  • Jeff Klein

    January 21, 2017 at 7:55 pm

    Hey Stefan, sounds like we have the exact same problem and no I have no found a (good) solution. I was hoping the most recent AFX update would solve it, but it did not. Like I said, if I make the “main” After Effects window smaller (I’ve found if it only takes up about 70 percent of the width of the 4k monitor) the RAM previews seem to play back in real-time. So, my workaround was to make the main After Effects window this size, and then to dock some of my most-used panels outside the main window (see attachment), this way I’m at least not wasting as much screen real estate. I’m pretty sure that the timeline window is the main culprit (this is the only panel that really needs to be shrunk down) but I’m not positive about that.

    If you said that shrinking down After Effects doesn’t work for you (which I’m surprised by) then this workaround probably won’t help you, but maybe it will help someone else. This is such a strange bug to me, hopefully it will get fixed soon. It really killed the excitement of getting a 4k monitor. I’m surprised way more people aren’t having this problem since 4k has become fairly common, especially among people who used programs like After Effects.

    Good luck, definitely update this thread if anything is figured out.


  • Stefan venbroek

    January 29, 2017 at 10:29 am

    Hi Jeff,

    Just wanted to let you know that my problem with RAM Previews is solved after installing After Effects 14.1 latest update ☺

    good luck!



  • stephane Auge

    December 14, 2017 at 9:27 am

    Hi Jeff,

    I’ve got the exact same bug as you. AE most of the time loose real time playback. I’m on Windows 10 too. I’ve tried every versions of AE but since CC2015 the bug is still present (I don’t have any trouble with CC 2014).
    My monitor is a BenQ BL2711U, what is yours ? Did you find a solution to solve the problem ?


  • Michael Szalapski

    December 15, 2017 at 2:53 pm

    There were some Dell monitors that would have an issue playing back in real time until you turned off the MultiStream Transport (MST) option. You might look to see if that works on this screen too.

    – The Great Szalam
    (The \’Great\’ stands for \’Not So Great, in fact, Extremely Humble\’)

    No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.

  • stephane Auge

    December 15, 2017 at 10:38 pm

    Hi Mickael,

    Thanks for your reply.
    Could you tell me witch Dell monitor it is please ? Yourself, do you use AE with a 4k monitor ? Do you have this bug too ?

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy