Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe After Effects Puppet Pin Preventing Preview

  • Puppet Pin Preventing Preview

    Posted by Claire Presnall on March 15, 2023 at 7:49 pm

    So I haven’t done a lot of Puppet Pinning in my 15 years of AE work, but the last 2 days, I’ve used it on 2 projects, and have had the same issue each time. At some point, it gets tired of me making adjustments to the key frames or to other layers (I haven’t found a rhyme or reason yet), it prevents AE from previewing the first frame of a pinned layer or beyond.

    Basically, I hit 0, and I get to watch right up to the first frame of that layer, then we go to the beginning of the comp and watch it again to that point (as if I’ve set the end point to the frame before the pinned layer).

    I can frame by frame through that section, but I see none of the animation. I can try to force it by setting the beginning point at the beginning of the layer, and I get that message about “AE needs more than 1 frame blah blah blah,” so it’s just refusing to render.

    I’ve tried restarting, clearing cache, just letting it sit there and think about things for a while, none of it fixes my issue.

    My solution. Throw out my pinning and redo it. Works great (until it doesn’t again). Luckily I’m only doing a little pin work, so I’m not murdered by the redo, but it’s irritating. And it’s happened on both animations, so this doesn’t seem to be a one time thing.

    Thanks!

    Running a MacPro 2019

    3.3 GHz 12-Core Intel Xeon W

    256G of ram

    AMD Radeon Pro Vega II 32 GB

    AE 23.0.0 (build 59)

    Claire Presnall replied 1 year, 2 months ago 2 Members · 2 Replies
  • 2 Replies
  • Boston Cainfra

    March 19, 2023 at 3:50 pm

    Hello Claire

    It looks like you are having trouble previewing the first frame of a pinned layer or beyond in After Effects due to issues with puppet pinning, where changes to keyframes or other layers prevent AE from previewing AE. You may have tried several options, including restarting, emptying the cache, and letting it sit for a while, but none of them have been successful. Throwing out the pinning and redoing it has been your solution; however, while this first resolves the problem, it inevitably recurs. It would be worthwhile to seek out more assistance or support to troubleshoot the issue as you have tried a number of alternatives without success after trying these steps below

    1. Update to the latest version of After Effects. Check if there are any available updates for After Effects and install them. This may fix the issue you are experiencing.

    2. Check your computer’s performance. Make sure your computer meets the system requirements for After Effects. It is also recommended that you close other programs to free up memory and processing power.

    3. Clear the cache. Clearing the cache may help resolve issues with playback or rendering. Go to Edit > Purge > All Memory & Disk Cache.

    4. Disable multiprocessing. In After Effects, go to Preferences > Memory & Multiprocessing, and uncheck “Render Multiple Frames Simultaneously.”

    5. Simplify the project. Try simplifying the project by removing any unnecessary layers or effects. This can help reduce the workload on After Effects and improve performance.

    6. Try using the Pin Depth option. This can help resolve issues with Puppet Pin not rendering. Select the Puppet Pin layer, go to the Effect Controls panel, and select Pin Depth. Change the value to something other than 0.

    7. Try using the Collapse Transformations option. This can help resolve issues with Puppet Pin not rendering.

    8. Contact Adobe Support. If none of the above steps works

    Kindly let me know if it helps

    Thanks

  • Claire Presnall

    March 21, 2023 at 6:24 pm

    Thanks Boston,
    We had a different project on a different MacPro (2019) (16-core with 196G of RAM) that worked just fine until we shut down and restarted the next day to find the same “won’t render” issue.
    It’s not a versioning issue or a computer system issue, and these projects have all been on the simpler side in terms of layer count and effects. Cleared the cache (which is saved to its own drive, despite Adobe periodically resetting it back to my system drive. That isn’t the issue in the case. Cache is on the proper drive). I did all the usual restarting and cache clearing and making sure it wasn’t putting anything on the system drive, running nothing but AE, but still no rendering, which was why I was so baffled.

    I went to the Adobe forum first to discover this is a continuing issue that Adobe has said “dang. That sure is rough for you folks.” and provided no suggestions for fixes from Adobe.

    However, I discovered what may be my issue. Changing the size of a puppet layer can break the pin and force you to delete the pinning and redo from scratch. I had continuous rasterization turned on, which made Puppet Pin think I was changing the layer size.

    So the fix:

    For an Animation using a camera and 3d layers:
    Precomp the layer. Scale the comp & layer to the largest size you’ll need (we were doing a camera zoom in 3D space, so we scaled to 800%). Turn on Continuous Rasterization in that Precomp.
    Go up a Comp where your 800% scaled Precomp is now 100%. Do your pinning here. Make sure Continuous Rasterization is off in this Precomp
    Go up a Comp to your main working comp where all the other bits and pieces and your camera are. Set your scale to 1/8 size so it fits back in to the little puzzle of layers.
    Now you can do your zoom and everything works because the pinning is in a comp with no scaling. Yay!

    This also works if you’re doing something without a zoom and your pinned layer will stay the same size but the designer sent you a 150×150 file for a 1080×1080 final output so you’ve scaled up the vector layers and want to make them crisp with continuous rasterization.

    At this point, my 1st step in pinning will be to replace the pinned layer with a PreComp of that layer and do all pinning on that PreComp.

    I think one of my issues was I had to go back into the original AI file to adjust the color on a totally separate object, but when I saved that file, the pin freaked out about the layer (that had no changes in AI, mind you), and I had to throw out the pinning and start over. By doing the pinning on a PreComp, Puppet Pin was none-the-wiser about any changes to the original illustrator file.

    I haven’t tried your suggestions 6 or 7 yet, but I’ll keep those in mind as I
    work today if we continue to have issues, but so far, my solution seems
    to be working.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy