Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple OS X Privileges, new question

  • Privileges, new question

     Gunleik Groven updated 15 years, 2 months ago 2 Members · 3 Posts
  • Gunleik Groven

    December 5, 2005 at 8:57 am

    “You donot have privileges to access…” whatever

    I have had a lot of small bugs with apps after the Tiger update.

    I basically want to do whatever I can (including messing up… -;)) to my system.

    How do I do that?


  • Curtis Thompson

    December 5, 2005 at 2:28 pm


    [Gunleik Groven] “I basically want to do whatever I can (including messing up… -;)) to my system.”

    trust me – you don’t. 🙂

    by that i just mean that you really don’t want to open the system up to that level for a variety of reasons, but one is basically your own protection. even a veteran unix sysad will tell you (or at least they should anyway) that running under root (the uber account) is not a Good Thing(tm) to do. you really risk doing very undoable damage to your box, and it’s just not worth it in the long run.

    luckily, however, os x makes it pretty hard to get that kind of access. you can enable root via netinfo, but again – that will only help you in shells and it’s not a good idea unless you know what you’re doing.

    otherwise, in the gui, your best bet is to run one account and make it an admin account. then you’ll have full access to all areas of the interface (apps, control panel, etc.) without needing to enter a password every time. however, if you have other accounts on the box, they still won’t be able to access each other’s files via the interface, but that’s the way the cookie crumbles, unfortunately…

    what’s your current account setup and where do you keep running into permission woes? the latter really shouldn’t be happening too often in most typical usage models…


  • Gunleik Groven

    December 7, 2005 at 11:53 pm

    Thanks a lot Curtis!

    I’m definitely not a UNIX head, but Tiger has been a Rocky road. Even though I did the Archive and install.

    The current frust?
    It was a Tiger problem with an outdated installer that told me that I didn’t have permissions to create a folder in the app folder.Messing a lot with what I could see, didn’t make things better (or worse for that sake.)

    I must say I’ve been considering to “Pantherize” myself again since I upgraded to Tiger.

    Panther was a dream when it came, and I never had any serious issues with it, neither with the system, nor with making apps work as they’re supposed to.

    With Tiger:
    1. Networking problems (that partly sort of just “went away at some point”.
    2. Printer problems (related to the above. Not solved- doing the USB thingy at
    the moment.)
    3. Spotlight the resource-hogger. I think the good old “Find” function is what
    I miss the most about Panther. Except for the general: It just works
    4. Permissions seems to rotten and have to be rebuilt much more frequently.

    Basically I sorta feel a step backwards to the 6-7-8-9 days when daily system maintainance was part of the job. Guess I’ve been spoiled for some years now.

    I was on the verge of going back when I asked this question, but since then I’ve sort of managed to make more crucial things work, than the crucial things that don’t. And I’d hate to rebuild my system once again. So I’ll stay Tigered.


    Dual 2gig 1st gen G5
    6 Gb RAM
    OSX 10.4.3
    Final Cut Studio
    Cubase SX3
    HaLion 2 (still not up)
    23″ studio display
    19″ CRT
    GeForce 6800 GT/256 Mb RAM
    2x 320 SATA internal – RAID 0
    8x 400 SATA external – Rocket RAID 1820A – RAID0
    MOTU 896
    Yamaha 03d
    Genelec 1030 monitors

    Waiting for:
    HVX 200 +p2
    (march around here…)
    Decklink studio extreme
    (Supposedly out today…)

Viewing 1 - 3 of 3 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy