Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Oh dear. Yosemite whinging at FCP 7.0.3 please offer advice

  • Oh dear. Yosemite whinging at FCP 7.0.3 please offer advice

  • Dom London

    September 30, 2015 at 8:44 pm

    Hi guys

    Can anyone help with FCP 7.0.3 and Yosemite 10.10.5

    Ive just updated and (of course) FCP7 hangs on loading, heres the splash screen

    0_fcp-hangs.png

    Can anyone please offer any steps to AVOID me spending hours re-installing from all the DVD disks? thanks

    Dom

  • Shane Ross

    September 30, 2015 at 9:30 pm

    Not really. FCP 7 support stopped at 10.7. Apple stopped taking FCP Classic into consideration when it furthered development of the OS. Typically the apps are patched to work with the new OS.

    It wasn’t supported under 10.8, but it did work.

    It wasn’t supported under 10.9…but it did work. Compressor and Motion stopped working for many many people, and not all functionality in FCP 7 worked (people reported various issues)…but it worked.

    It isn’t supported under 10.10. Some people report success, others, not so much. And again for others it works, but not all features…things like Log and Transfer not working like it did, or smoothcam not working at all.

    If you rely on software to make money…it’s best to keep it on a computer with an OS that supports it…and to not upgrade that OS. Know that if you do update the OS, you take the risk of things not working. This is one reason why it’s always advisable to CLONE your working OS before you do any upgrading. With something like Carbon Copy Cloner. So if things don’t work, all you need to do is boot from the clone and erase the HD and clone back. Guessing that you didn’t do that.

    You can try removing and installing FCP 7…but you wanted to avoid that. My best advice is to back up the computer and go back to an OS that supports FCP 7.

    Of course wait for others to chime in. I’m just the harbinger of doom!

    🙂

    Shane
    Little Frog Post
    Read my blog, Little Frog in High Def

  • Dom London

    September 30, 2015 at 9:48 pm

    Yes, I’m sorry, I should’ve said in my original post that I didn’t want to get into the whole Final Cut Pro/iMovie pro debate.

    For what it’s worth, I’ve just been working with the BBC channel 4 and Sky TV over here and out of the biggest three National broadcaaters the reality isi that none of them use Final Cut 10, quite a few of them are still happily using Final Cut seven and with just one motion picture under its belt (Focus) I think it’s difficult to argue for the moment that it is the way to go often Final Cut seven

    NOW… That being said, if I could get back to the original query, can anyone offered Advice [without preferably involving hours reinstalling DVDs as mentioned in my original post] to help me get this working, I’d be very grateful

    Dom

  • Shane Ross

    September 30, 2015 at 10:15 pm

    I made no mention of FCX.

    Shane
    Little Frog Post
    Read my blog, Little Frog in High Def

  • Dom London

    September 30, 2015 at 10:18 pm

    Yes I’m not interested in fcpx or “keeping up with the latest software” that isn’t fit for (my and others ) purpose. Instead I’m grateful for any solutions with the fcp 7 hang I’m getting

  • Nick Meyers

    September 30, 2015 at 10:48 pm

    FCP has worked OK for me under Yosemite, bar one problem.

    if your launch is hanging on loading that specific effect,
    the first thing to try would b e to REMOVE that effect

    go to you System Drive / Library / Application Support / Final Cut Pro System Support / Plugins
    you can create a new folder within Final Cut Pro System Support for your removed plugins.
    move the troublesome ones into it.

    the problem i mentioned?
    the new OS must have some slightly different way of using eye-dropped colour pickers
    so colour picking, based on existing eye dropper icons in FCP doesn’t work.
    in MOST cases you can click on the colour swatch, and open the colour picker window, and use it’s eye dropper,
    BUT colour matching in the colour correction tools doesn’t work.
    if you do a lot of Colour Correction in FCP you should consider reverting to your previous OS

    one you’ve figured out which of your plugins work and which don’t,
    it would be helpful to post a list back here.

    nick

  • Nick Meyers

    September 30, 2015 at 11:09 pm

    hang on… that’s a standard FCP effect, isn’t it? not a 3rd party one.
    well that;s weird,
    as i say FCP is working for me with all it’s native effects.
    i dont even know where they live.

    re-installing FCP wont take hours.
    just re-intall the app, NOT all the extra media, etc. that’s on the other disks.

    nick

  • Dom London

    September 30, 2015 at 11:22 pm

    A lot of great suggestions and ideas to follow up there

    Thanks. Will investigate

    D

  • Steve Rieck

    October 1, 2015 at 1:14 am

    hi Dom, sorry I don’t have an immediate fix but I did want to report that I have three computers running OS 10.10.5 and Final Cut Pro 7 without issues… in fact I’ve been editing on one of them for three weeks straight with no problems at all. One thing you might want to try is creating a new user in the user and groups section of the system preferences. You could login as the new user and that might fix the problem? sometimes that sort of thing works for me.

  • Roger Poole

    October 1, 2015 at 1:19 am

    Well…The major broadcasters in the UK use Media composer, Premiere Pro and FCPX, dependent on intention and/or use. FCP7 was dropped by the broadcasters after Apple dropped them.
    Bottom line. You can’t go back to a working system after updating to a later operating system from an earlier one. You will have to start from scratch and re-install everything from the ground up, using a qualified O/S as the starting point. As a seasoned professional like yourself I can’t imagine what you thought an upgrade to Yosemite was going to give you over what you had. Working at the BBC we don’t have admin privileges, so we can’t update anything, for this very reason.

Viewing 1 - 10 of 16 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can. Our Privacy policy | GDPR Policy