Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer MC 2021.12 SYS-ERROR crash on startup, seems to be Mac account related

  • MC 2021.12 SYS-ERROR crash on startup, seems to be Mac account related

  • Kevin Greutert

    December 28, 2021 at 3:15 am

    I just got a Macbook Pro M1 and installed the latest Media Composer. It was working fine, then I messed things up by trying to change the name of my user settings. Now whenever I launch the app, I get a Sys-error message before reaching the project selection window, and there’s no way to get past it.

    I’ve searched the net and found others with this issue. Turns out I can still get into MC by clicking on the .avp file of a given project. But when I relaunch after that, I’m back to the same error.

    It was suggested that I log into Mac with a new administrator account. I did this, and Avid did indeed launch correctly. I tried renaming my account and Users folder of the original account, and when I logged back in to the original account, Avid launched correctly, but I did a restart and was back to the same error message.

    I’m starting to lose my mind on this. I’ve got the workaround of starting from the project file, but it’s not good enough, I start a new gig tomorrow and am really frustrated. I also tried deleting all the user settings to force a rebuild, as well as the project settings, but no dice.

    Thoughts?

  • Chris Bové

    December 28, 2021 at 4:18 am

    Hi Kevin. Yes indeed, and this should be a quick, easy fix.

    1) Launch Media Composer in any way you can.
    2) Once launched, click on File / Settings.
    3) When the Settings window opens, click on the User tab at the top.
    4) Very close to the top left corner, do you see the field called “User Profile”? Click on it.
    5) In the pull-down that comes up, scroll down to the bottom of any list there, and click on “Reveal User Profile”. This will take you to the OS level where the user settig itself lives.
    6) The user setting file itself is a .xml file. MAKE SURE that it is named whatever you wish, but that it has the “.xml” at the end of the name.
    7) If no such file exists there, then go back to step 4, and then instead of clicking on “Reveal User Profile”, you’ll need to click “New User Profile”.

    Report back if either of those works.

  • Kevin Greutert

    December 28, 2021 at 6:37 am

    Thanks, Chris. I tried this, and was brought to my profile. There are three files: MCState, the user settings with the correct .xml suffix, and the user name with .ave suffix. So unfortunately I don’t think this is the answer. Let me know if you have other ideas please.

  • Glenn Sakatch

    January 1, 2022 at 5:31 pm

    uninstall Avid, trash your settings files, and start again.

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy