Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple OS X Locked drives – big problem

  • Locked drives – big problem

     Luke Woodward updated 9 years, 4 months ago 4 Members · 9 Posts
  • Mendy Grauman

    May 11, 2011 at 1:38 pm

    Hi

    I am hoping someone can help me.

    I am running a Mac Pro running 10.6.7

    Earlier today, i was trying to share some folders with other people on my network. i did something that was pretty stupid. i just gave them permissions to my entire system drive and then applied the permissions to the enclosed items. i just figured i would remove them later and then reapply the changes.

    but now i can not access the other 2 drives in my machine. it keeps telling me that i dont have permission to view those drives. when i get the info for those drives, my username and the admin and system permission are set to custom. if i try change them, it just changes back to custom again.

    i have removed the person i allowed onto my systems drive but i stil cant access my other drives..

    i am trying to verify and repair permissions for my system drive.. it is taking hours. and i dont even know if it will fix the problem…

    does anyone know how i can fix this? i have tons of information on those drives that i really need.

    Please help

  • Curtis Thompson

    May 11, 2011 at 3:12 pm

    hello…

    you can probably fix it via enabling root:

    https://support.apple.com/kb/ht1528

    and fixing permissions via the shell (aka terminal) – it is how permissions are actually stored and managed in the unix system underneath. here’s some tutorials:

    https://www.perlfect.com/articles/chmod.shtml
    https://www.computerhope.com/unix/uchmod.htm

    your main commands will be chgrp, chmod and chown (all with a recursive “-R” flag to get all contents). of course not knowing what your original setup was i can’t advise on that, but you should be able to at least get them readable again…

    sitruc

  • Mendy Grauman

    May 11, 2011 at 3:38 pm

    Thanks.

    I did a reinstall….
    once that was done i still had the same problems, but then i tried again to change the privileges from custom to read and write
    ]
    it seems to have worked…. im running a permissions repair again. but for now most of it seems to be sorted out.

    thanks for your response…
    if it gives me any more hassles i will try enabling root

    Much appreciated!

  • Jerry Jorgenson

    May 12, 2011 at 12:57 pm

    Note that you don’t need to “enable root”, you just need to become root.

    sudo su –

    It will then ask for your password and you are root. (Don’t forget the dash, and don’t forget to exit when finished.

  • Curtis Thompson

    May 12, 2011 at 3:36 pm

    unless os x security models have changed, i believe that they still do not allow root access by default and it must be turned on before doing what jerry says, which indeed will get you to root once you can do so…

  • Mendy Grauman

    May 13, 2011 at 7:24 am

    Thanks guys
    Much appreciated

    I have had no problems accessing those other drives since i reinstalled the OS..
    but i didnt do a fresh install.
    and i am still getting lots of weird glitches on my system drive.

    when i try verify my permissions it comes up with pages of errors, and then i repair them. but when i try verify again those errors are all still there. and there are programs that arent working right..

    is there any way to restore things to how they should be? or is it just safer to format the systems drive and do a fresh install. i would rather try avoid doing that because of all the stuff i would need to spend time reinstalling and updating

  • Luke Woodward

    May 24, 2011 at 12:15 am

    There are many messages in a permissions repair which come up, but can be safely ignored. You can find a list of such errors at https://support.apple.com/kb/TS1448.

    What kind of glitches are you getting? Also, if there are any errors you are getting that come up over and over that are not on that list, what are they?

  • Mendy Grauman

    May 24, 2011 at 6:09 am

    I am getting a couple of error messages when i boot up the machine.
    something about an non secure startup item.
    There are 2 that i get everytime that i boot up.
    the one is for netvault, and the other is for Episode (a telestream product used for encoding)

    i have also been having glitches with my DVD drive. It does not seem to be writing discs in finder at all. Whenever i try i get an error telling me that there is too much data to fit onto the disc no matter how little data i try to burn. i thought it was just an issue with finder, but then yesterday i tried to burn a disc using DVD studio pro, and as soon as i inserted a new disc the software crashed,. it happened a few times. it looks like i might need to format my hard drive and start over, but i would really like to avoid this if i can.

  • Luke Woodward

    May 24, 2011 at 5:07 pm

    The start up items usually do that when the permissions for them have been changed. A Disk Utility Permissions Repair doesn’t always fix this, either. Sometimes when you get the message at start up there is a “Fix” button, but again, this doesn’t always work. The best way to fix it would be to pull the start up items and then run the installer for those applications again.

    The items themselves will likely be in /Library/StartupItems
    Other places to look would be /Library/LaunchAgents and /Library/LaunchDeamons. If the applications have an uninstaller, using that then reinstalling might be easier than digging out the pieces. If you do decide to go digging, I would start up with a Safe Boot first. This disables Startup and Login items, so it is “safer” to play with them in safe mode. Once you are done digging, restart, then reinstall the apps.

    As far as the DVD thing goes, does it happen in a new user account? If you don’t know, can you test it and post the results?

    Best,

    Luke

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy