Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums VEGAS Pro Interlacing problem

  • Interlacing problem

     John Rofrano updated 8 years, 10 months ago 2 Members · 9 Posts
  • Michael West

    December 18, 2012 at 6:00 am

    So I took a look at the result of a video I enhanced. Part of it looks very good and then there are moments when I see this:

    https://i49.tinypic.com/33muzop.png

    It looks like an interlacing issue. The source was on VHS and transferred going from VHS out using a composite cable to an S-VHS input in a Hauppaugue HVR-1600. I assume that the capture also captured the interlacing of the analog output. Prior to this I was using a Toshiba hard disc recorder that may have done a little better job as the interlacing effect doesn’t seem to be there as much.

    But looking at this screen shot, it looks like the letters are having interlacing problems but not the rest of the video, which seems to have the entire area filled in. I used Sony Vegas to deinterlace and chose “best” and Gaussian. I’m wondering what I might have done wrong here and hopefully I can improve upon the video.

    The other problem I have throughout is this issue:

    https://i48.tinypic.com/1zq4hg7.png

    I don’t know if that is exacerbating the interlacing issue. It looks like all of my tapes seem to suffer from the same issue. I think that on the TV it might not appear as bad since I’m sure part of the side area is cropped out the same way tracking on the bottom isn’t as visible. But there seems to be no way to correct this pincushion issue and I’m wondering if this will cause distortion in the images and result in making any deinterlacing look worse. All help is greatly appreciated.

  • John Rofrano

    December 18, 2012 at 8:21 pm

    [Michael West] “I used Sony Vegas to deinterlace and chose “best” and Gaussian.”

    Which deinterlace method did you use in your Project Properties? None, Blend Fields or Interpolate Fields?

    A screen shot of your Project Properties might help. Also a screen shot of Media Properties would help too (i.e., right-click the event with the video and select Properties and then show us the Media tab).

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

  • Michael West

    December 18, 2012 at 8:29 pm

    John – thanks. I used “blend”. I rarely use interpolate since it throws away too much data, IMHO, and I don’t think it would solve this issue.

  • John Rofrano

    December 18, 2012 at 9:04 pm

    [Michael West] “John – thanks. I used “blend”. I rarely use interpolate since it throws away too much data, IMHO, and I don’t think it would solve this issue.”

    I’m not looking to solve it. I’m trying to diagnose what’s causing it. If you don’t want my help that’s fine.

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

  • Michael West

    December 18, 2012 at 9:52 pm

    John – understood and probably provided too much info. Trying to think through the problem like yourself and think about what could be, see whether potentially tracing through my workflow might solve the problem, etc. So far this has me stumped, not sure why the video would look like this. Thanks much for your insight, as always.

  • John Rofrano

    December 18, 2012 at 10:23 pm

    [Michael West] “Trying to think through the problem like yourself and think about what could be, see whether potentially tracing through my workflow might solve the problem, etc”

    That’s why I asked for a screen shot of your media properties. I’m trying to trace your workflow and see where the problem is. It’s is either in your project properties, your media properties, or your display properties.

    BTW, are you taking your screenshots from the preview window or your secondary display? Because it’s perfectly normal to see these lines in the video preview for interlaced source. Try right-clicking on the video preview window and select Preview Device Preferences and make sure Apply deinterlace filter is checked. Then view your video using the Windows Secondary Display and see of the interlace combing goes away. If it does, there is nothing wrong with your project or the footage, that’s just what interlaced video looks like in the preview. It won’t look like that on TV.

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

  • Michael West

    December 19, 2012 at 4:09 am

    [John Rofrano] ” It’s is either in your project properties, your media properties, or your display properties.”

    FYI, the screen shots are of what was rendered and played back using GOM or VLC player in Windows 7. It’s not a screen shot of the preview window. It’s being played back on my computer monitor. I’ve got a GTX 560 ti 448 with a Dell 24″ monitor and I am 100% sure it’s not limited to interlaced playback like the TV is.

    Project Properties
    https://s11.postimage.org/o8fvjj243/2012_12_18_22h41_12.png

    Media Properties
    https://s8.postimage.org/3qzk9gx3p/2012_12_18_22h41_29.png
    (the above was changed to smart resample and rerendering made no difference)
    https://s10.postimage.org/i63y0b8kp/2012_12_18_22h41_35.png

    General for the clip states:
    Video: 01:03:09.419, 29.970 fps interlaced, 720x480x12, MPEG

    Render Settings
    https://s8.postimage.org/s1410uoph/2012_12_18_22h54_22.png
    https://s13.postimage.org/g6tw95nyv/2012_12_18_22h40_55.png

    I rerendered, setting the media properties on smart resample. The results are below, lots of combing:

    https://postimage.org/image/piu6upllf/

    PS – Many thanks on why the preview window looks terrible. Deinterlacing is off on the preview.

  • Michael West

    December 19, 2012 at 5:44 am

    I have no idea what I did. I turned on deinterlacing in the preview window and rerendered the video also having the GPU turned on. The video looks much better and without all that terrible combing. I have no idea what is different.

    I did notice a discrepancy between VLC player and other windows video players — VLC allows you to turn deinterlacing on and off (it was off.) Other players automatically try to deinterlace interlaced video – which is very interesting and I never knew that before. This means that previewing externally can provide misleading results unless you know for sure that your external video player isn’t deinterlacing your video on the fly.

  • John Rofrano

    December 19, 2012 at 1:29 pm

    [Michael West] “I did notice a discrepancy between VLC player and other windows video players — VLC allows you to turn deinterlacing on and off (it was off.) Other players automatically try to deinterlace interlaced video – which is very interesting and I never knew that before.”

    Yea, it’s really important that you understand what you are looking at. You should be using the Vegas Windows Secondary Monitor preview with deinterlace turned on to check if you have interlace problems. This works even if you don’t have a physical second display, it will just use your primary display. Your computer screen is not interlaced so you can’t trust it to check for interlace problems without software that will deinterlace for you.

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy