Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro H264 Mpeg-4 AVC files won’t work in Premiere!!

  • H264 Mpeg-4 AVC files won’t work in Premiere!!

     Andi Turner updated 4 months ago 2 Members · 3 Posts
  • Andi Turner

    January 21, 2022 at 4:32 pm

    Having real trouble with Premiere on a brand new Windows 10 HP Z8 workstation with a pretty decent spec.

    Every time I try to import an MP4 it brings it in as just an audio clip (as in it doesn’t even recognise that there is a video track), and if I import MXF camera files from a Sony FS7, it brings in a full clip but the video is black and I get “error retrieving frame” errors continuously.

    Have updated to the latest version with no success. Have completely reinstalled Windows, tried different drivers, basically everything and still can’t solve the problem. The files are all using the same codec – H264 Mpeg-4 AVC and I’ve tried importing files that were even made in Premiere on the same computer. The problem persists in Media Encoder and After Effects as well, yet the files play fine in Avid, VLC, QuickTime etc, as well as on the same version of Premiere on my Macbook Air and Mac Mini, and an almost identical Z8.

    Have had Adobe support look at it remotely, trying all the usual trouble shooting (clear cache, disable hardware acceleration, reinstall software, update drivers etc) but it’s clear that haven’t got a clue what the issue is (and every 40 mins cut me off so I have to start again).

    I’ve installed the 2019 version of Premiere, and the files work fine in that but it’s not a good workaround as exports are slower and I can’t exchange projects with colleagues on the newer versions. But 2020, 2021 and 2022 won’t play ball. Transcoding isn’t a viable solution either, as we’re talking Terabytes of rushes.

    Someone must be able to shed some insight on this??

    System Specs are:

    HP Z8 with Windows 10 Pro

    2x Intel Xeon Gold 20-Core CPU @ 3.10 GHz

    96GB RAM

    NVIDIA RTX A5000

  • Chris Wright

    January 21, 2022 at 6:38 pm

    You should check the default fourcc decoding. i believe both windows and premiere read the same fourcc and decide what video decoder to use. sometimes its missing or sometimes its the wrong one. I believe premiere uses vfw compatible codecs. All default fourcc codec tags are read as metadata and then the fourcc is compared against a list in windows registry to load a specific dynamic link library. For example: my fourcc code for Lagarith is VIDC.LAGS or just “LAGS” if reading the video with a fourcc editor. That registry file points to lagarith.dll

    all these values are stores in registry key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

    so what you should do is download a fourcc editor to views the fourcc tag of your video, then compare it in registry and in the working computer and see if they are identical.

  • Andi Turner

    January 24, 2022 at 11:54 am

    Thanks Chris, will give that a try…

Viewing 1 - 3 of 3 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy