Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X FCPX Crashing on Export

  • FCPX Crashing on Export

  • Aloyisius Oxbow

    April 20, 2020 at 12:07 am

    Hello! I’m using FCPX 10.3.4 on El Capitan (10.11.6). Suddenly, every video I try to export crashes immediately (I never get to the settings menu). If I try to export as a still image then it either just does nothing or sometimes gives an error saying it failed.

    I’ve tried absolutely everything I can think of and every suggestion I’ve found in online searches:

    – Deleting prefs
    – Uninstalling and reinstalling FCP
    – Making a new library
    – Moving my libraries to a different disk
    – Exporting to a different disk
    – Deleting render files, turning off background rendering
    – Switching to a different OSX user
    – Checking all disks (no errors, plenty of room)
    – Disabling/deleting QuickTime components
    – Deleting a couple new apps I’ve downloaded since the last time FCPX worked
    – Running various repair/maintenance/cleanup tools with Onyx
    – Using Digital Rebellion Pro Maintenance Tools (Crash Analyzer, all the cleanup tools, etc.)
    – Using Time Machine to revert back to old versions of my FCP libraries
    – Rebooting the computer, of course
    – Resetting PRAM
    – Unplugging everything except necessary drives and peripherals

    Many of these I’ve tried multiple times. Crash Analyzer says it’s a “Network Error”, though I’m not sure why a network is even needed to export a file? But I’ve tried checking and clearing all my network prefs anyway.

    What am I missing? What haven’t I tried? Does anyone have any idea what could be causing this? It’s not only on one project but ALL of them, which worked totally fine before.

  • Joe Marler

    April 20, 2020 at 12:19 pm

    This was apparently caused by /System/Library/PrivateFrameworks/MobileDevice.framework, which had been recently updated. Problem was apparently resolved by restoring a previous version using Time Machine.

  • Aloyisius Oxbow

    April 20, 2020 at 5:35 pm

    That’s correct, I hadn’t had a chance to post the update here yet so thank you for doing so!

  • Sunit Karia

    November 6, 2020 at 4:08 am

    Hi bro, i am having a nightmare trying to get final cut pro x to work, was working fine, then wouldnt export and just keeps crashing, ive done everything, even updated from el captain all the way to mosOS sierra to version 10.13.6 then everything in PCPX deleted files and all sorts, just nothing is working … HELP!

  • Joe Marler

    November 6, 2020 at 4:54 pm

    The most common cause of crashes on old version of FCPX are 3rd-party plugins or the above previously-mentioned iTunes update issue. Running the Chrome browser can also destabilize FCPX due to it mis-using the Mac VideoToolBox framework. For troubleshooting purposes, temporarily discontinue any use of Chrome or any browser based on Chrome such as Brave.

    Make sure you have plenty of free disk space on all drives, at least 20%. All drives should be only HFS+ (Mac OS Extended Journaled) or APFS, nothing else.

    If you have never run Disk Utility First Aid, run that on all drives. To run properly on the MacOS system drive requires first booting into recovery mode: https://support.apple.com/guide/disk-utility/repair-a-disk-dskutl1040/16.0/mac/10.13

    If your entire machine every hangs or crashes (not just FCPX) that is a system-layer problem which cannot be fixed at the application layer.

  • Patrick Donegan

    November 7, 2020 at 8:45 pm

    “nothing is working”

    Does that mean the App is not booting?

    Can you import media?

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy