Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X FCP X 10.0.1 – fix if your update doesn’t show in MacApp store

  • FCP X 10.0.1 – fix if your update doesn’t show in MacApp store

     Jeff Feaz updated 1 year, 8 months ago 10 Members · 15 Posts
  • T. Payton

    September 20, 2011 at 7:12 pm

    It looks like there might be some trouble with the Mac App store and recognizing updates. If can see the see the 10.0.1 product page, but it is not showing in updates then do this.

    1. Move your FCP X App to the trash. (it’s really okay)
    2. Goto the purchases tab in the Mac App Store and find Final Cut. The click install.

    That should do it. BTW. As far as I can tell, it won’t work if you goto the product page and try to “install” you need to use the purchase tab.

    ——
    T. Payton
    OneCreative, Albuquerque

  • Paul Figgiani

    September 20, 2011 at 7:24 pm

    Tim,

    Thanks. Worked for me as well …

    -paul.

  • Matthew Celia

    September 20, 2011 at 7:56 pm

    Yup, thats what I had to do. I had legacy FCP installed on the same drive – so maybe that was it?

    —————-
    FCP Guru
    http://www.fcpguru.com

  • Benjamin Reichman

    September 20, 2011 at 8:02 pm

    Thanks! That worked for me. I also have FCP 7 installed on the same drive; perhaps that is the cause of the issue.

  • Mark Morache

    September 20, 2011 at 8:26 pm

    Good work Tim.

    How did you come by this information?

    –> Mark

  • T. Payton

    September 20, 2011 at 8:36 pm

    [Mark Morache] “How did you come by this information?”

    Just a guess. 🙂 I’ve had a Mac since 1984. Perhaps I just “know” Apple bugs by now.

    Regarding the FCP 7, I don’t think that is the problem. It happened on a machine without FCP 7 installed. I have a feeling it has to do with some kind of receipt issue with the Mac App store. It’s still a little buggy.

    ——
    T. Payton
    OneCreative, Albuquerque

  • charles wren

    September 21, 2011 at 4:05 pm

    Moved it to the trash
    went to the app store
    says please remit and give another 299
    Just more apple annoyance

  • T. Payton

    September 21, 2011 at 4:08 pm

    Make sure you goto the purchases tab and then click “install” for FCP X. Don’t download from the product page itself.

    If that doesn’t work call Apple, they will help you out. 1-800-MY-APPLE

    ——
    T. Payton
    OneCreative, Albuquerque

  • Mitchell Milliron

    September 21, 2011 at 6:30 pm

    I’m in the process of trying this fix out. However, I can’t help but wonder, is this solution really downloading the “update delta”, or the entire app….again.

    I mention this because I’m waiting and see that there is 1.44GB of download. The App store lists FCPX as being 1.34GB. So this solution doesn’t seem like the update, rather, just re-downloading the updated version.

    In that case, it’s sort of a bummer. I’d love to know if someone actually had the update button and what size that was.

  • T. Payton

    September 21, 2011 at 6:49 pm

    As far as I know the delta update is Lion only.

    I’ve got FCP X on 5 machines. ([email protected], [email protected]) The update didn’t show up for any of them. The motion update did however. Of course we have a 20mb internet connection, so it only took about 20 minutes to download a fresh version.

    ——
    T. Payton
    OneCreative, Albuquerque

Viewing 1 - 10 of 15 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy