Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy FCP “Out of Memory” Error

  • FCP “Out of Memory” Error

  • John Tate

    June 9, 2011 at 12:13 pm

    I’ve been trying to render my projects and keep getting the error message “Out of Memory”. I’ve tried mulitple things to fix this, been on the phone with Apple FCP guys, trashed my preferences 37 times, etc etc.

    I’m working with AVCHD files as well as some GFX sent to me by the networks I produce TV shows for. My OLD PowerPC Mac had no issues with this whatsoever. Some other producers I know are having the same issue and we have similiar workflows.

    I cannot export my sequences either thru the Export tool or thru Compressor. Both fail everytime.

    I need help, deadlines are approaching and if I can’t output my sequences….it will not be good.

    John

  • André Engelhardt

    June 9, 2011 at 1:29 pm

    Hi John,

    I remember having this issue once because of a single corrupted graphics file and in another case because of a corrupted video. The only way I was able to find the culprit out of the 300 or so clips I had in the project was by adding them one after the other and trying to export.

    I’ve also had success fixing this problem once by trashing all my render files and creating a duplicate sequence to work from.

    Increase the auto save interval, max. undo’s etc. and start eliminating. It’s painful and time-intensive but as far as I’m aware the only way to get to a corrupted clip.

    Maybe someone out there knows of a tool that can batch check the integrity of clips and graphics though?

    Good luck!


    Audio Engineer, Sound Designer
    Video- and Photographer
    http://www.andreengelhardt.net

  • Michael Kammes

    June 9, 2011 at 1:51 pm

    Mostly what André said.

    Duplicate your sequence, and cut your sequence in half. Try an export? Does it work? Great! We know the problem is in the half you cut. Now, add in half of the half of the sequence you cut. Repeat. Do it until you find the culprit.

    Do you have any gfx above 3K or 4K, in terms of frame size? I’ve often seen that cause issues….FCP no likey high res gfx.

    ~Michael

    .: michael kammes mpse
    .: senior applications editor . post workflow consultant
    .: audio specialist . act fcp . acsr
    .: michaelkammes.com
    .: twitter: @michaelkammes
    .: facebook: /mkammes

    Hear me pontificate: Speaking Schedule .

  • John Tate

    June 9, 2011 at 1:58 pm

    Thanks Andre’

    Ok, so I need to trash my render files, not the cache? Also, before doing that make a duplicate sequence as a spare/work sequence?

    My autosave is at 5mins because FCP keeps crashing on me….repeatedly.

    I can increase that and lower my Undo actions. I have that at 50 because I mess up a lot!

    Thanks for the info. I truly appreciate your time!

    John

  • André Engelhardt

    June 9, 2011 at 2:10 pm

    Trash the cache for good measure too but also and definitely the render files FCP created, if you’re lucky that will already fix it.

    If not, Michael’s method is great to eliminate the offending clip or graphic.

    You can also duplicate the FCP project file in the Finder until you have eliminated the problem (just to be on the safe side, when I run into issues I create an exact duplicate copy of everything I’m working on and then try to nail the problem down, then fix it in the original and discard the duplicate but that’s just my silliness).

    Autosave and undo is all good, I just know that a lot of people have it still set at the standard FCP settings which can cause a lot of frustration.

    Crossing my fingers for you!

    André


    Audio Engineer, Sound Designer
    Video- and Photographer
    http://www.andreengelhardt.net

  • John Tate

    June 9, 2011 at 2:16 pm

    Andre’,

    I am 9mins away from seeing if it works in Compressor. We were experiencing some issues with our external hard drives, so I moved it to an internal drive on my Mac Pro. That fixed a lot of the crashing issues so I’m checking that first with an export to Compressor to see if it works. I’m just trying to get this first show out the door today. Deadline is next Wednesday.

    But I will try to delete all the render files as you suggested after this has finished whether it succeeds or fails. Hopefully that will fix it.

    Your idea sounds good, hope it works. Many thanks.

    John

  • Ben Holmes

    June 9, 2011 at 2:33 pm

    Whenever I get this issue (rarer than it used to be) I restore my project from a previous autosave where it wasn’t occuring – and redo my work to that point. In all the times this has happened, this has always fixed it.

    In my experience this has nothing to do with ‘memory’ – it’s corruption. Whether that be project, render or media. If it’s the last one (it never has been for me) I guess you’ll see the problem re-occur at the same point each time.

    Ben

    Edit Out Ltd
    —————————-
    FCP Editor/Trainer/System Consultant
    EVS/VT Supervisor for live broadcast
    RED camera transfer/post
    Independent Director/Producer

    https://www.blackmagic-design.com/community/communitydetails/?UserStoryId=8757

  • Don Walker

    June 9, 2011 at 2:58 pm

    If you are dealing with corrupt media, you might want to consider purchasing the FCS maintenance pack from Digital Rebellion. They have an app within this suite that finds the corrupt file quickly.
    https://www.digitalrebellion.com/fcsmaintenance/

    don walker
    texarkana, texas

    John 3:16

  • jeff fish

    July 13, 2011 at 5:38 pm

    large stills will also give the “out of memory” error.
    reduce the size to below 2000px

  • Trevor Ward

    August 24, 2011 at 11:38 pm

    This just pisses me off! I’m having this same issue. It’s only a 20 minute video. But it’s mostly photos, about 500 of them. Most aren’t that big, 10-18 MB, 5000×3500 pixels.

    I am at least able to run the thing through compressor, which takes FOREVER.

    Workarounds? Forget it. Why do I have to have work arounds? FCP should just work.

    -trevor ward
    Red Eye Film Co.
    http://www.redeyefilmco.com
    orlando, fl

Viewing 1 - 10 of 23 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy