Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects CS4 and Processor Compatibility

  • CS4 and Processor Compatibility

  • Scott Thomas

    October 8, 2008 at 7:56 pm

    I called Adobe earlier today about CS4 bundle upgrade pricing. The guy on the phone said that After Effects CS4 *would* run on a G5. I was very specific in mentioning that Adobe had announced that CS4 would drop PPC support. He then said that it was G4s or earlier that it would not run on. This kind of goes against Adobe’s “System Requirements” page and every other bit of news.

    Now I’ve got to call Adobe back and find a different person to ask. This can’t be right, can it?

  • david bogie

    October 8, 2008 at 8:49 pm

    What you might want to do is wait till it ships and let lots of other early adopters suffer through the first major bug fixes.

    Adobe sales people are, erm sales people. They don’t know anything about video or computers that make i except what their scripts tell them to say. Could have been a typo.

    bogiesan

    This is my standard sigfile so do not take it personally: “For crying out loud, read the freakin’ manual.”

  • Scott Thomas

    October 11, 2008 at 7:24 am

    I’ve not called Adobe back, but I’ve decided that the guy must have been talking about Photoshop instead of After Effects. The Adobe website seems to indicate that Photoshop CS4 will not work on a G4 or earlier.

Viewing 1 - 3 of 3 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy