Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Photoshop “Could not complete your request because of a program error.”

  • “Could not complete your request because of a program error.”

     John Ward updated 5 years, 4 months ago 22 Members · 24 Posts
  • Dester Wallaboo

    August 25, 2005 at 6:18 pm

    Preface: I have a vast amounts of experience in debugging software issues on computers.

    OK… this is REALLY bizarre….. about a week ago I got this error while trying to save a file under Photoshop CS. It happened once… then went away. The very next day… I got the same error while trying to open any (and I mean) any file in Photoshop… I’m talking new files or old files, JPEG’s, PNG’s, TIFF’s, etc. I deleted preferences, settings, all of that. Tried booting up without plugs installed, etc. All of the things one would typically go through to fix the problem. I even went so far as to remove every single Adobe application from my box (and all of their related support files) and reinstall everything. Exact same error. Then… intermittently… I could open or save files again… just to have it go back to the same problem as before. This was really bugging me. I then decided to try and run Photoshop that was sitting on another workstation via the network… exact same error. But even stranger than this is… that Photoshop that was running PERFECTLY previous to all of this… no longer works either!! It now shows up with the same error. Really, really bizarre.

    Anyone else have this issue?

  • Isabelle Green

    August 28, 2005 at 5:04 pm

    I started getting the same message yesterday when I tried to save some .psd files I had been working on. Couldn’t find a way to get around it and lost them. I replaced the Preferences file with a backup copy I keep on my desktop and all worked as it should until later in the day when I tried to “save as” a file and got the same message. I tried just “save” and that worked. I don’t know what is happening (or why), but hope I don’t have to reinstall Photoshop.

    Sounds like you’re really knowledgeable, so if you find a reason (or fix) for the problem, please let me know. I definitely don’t have knowledge about debugging, so need all the help I can get.

  • TerryL

    September 1, 2005 at 8:38 pm

    Did you try using a Save As and renaming the photos? I had a similar problem and could not save photos, but only one set from a particular camera. Others were fine. It’s not ideal but at least renaming the offending files in a Save As meant I could then use them as normal. They would open and save without problems. Also tried deleting preferences but did nothing.

  • Isabelle Green

    September 6, 2005 at 2:12 pm

    Thanks, Terry, for your response. I haven’t had a repeat of the problem, but if and when I do, I’ll try your suggestion.

    Cheers!

  • Craig White

    June 12, 2009 at 4:46 pm

    I’m not sure how current this posting is, but I thought I would write to maybe help a few people out who are having this problem. I have noticed that when I don’t have the proper fonts loaded in Photoshop CS3 for a particular file it will give me this error. Once I load the fonts the problem is solved. I use Suitcase for my font management. I was not sure which font was in the file that was causing the problem so I simply loaded all available fonts and voila! Problem solved. Hope this helps.

  • Greg Plummer

    June 30, 2009 at 2:22 am

    I have had the same thing happen, very spuratic. For 3 months everything worked great. Now for the last two days I have been trying so hard to work, but Photoshop continuously crashes with the error message “Could not complete your request because of a program error.” All I have to do is luanch the program and let it sit there and it crashes by itself with out me even moving the mouse… YIKES! Help! I’m calling Adobe tomorrow. One mor ething; I thought it would help if I uninstalled the creative suite 4 and re-install it… it didn’t help, its the same!!

  • Robin Koontz

    July 7, 2009 at 2:37 pm

    I had this problem too and found the solution/s here:
    https://kb2.adobe.com/cps/331/331627.html

    In my case, disconnecting my broadband modem did the trick. Weird.

    Good luck! I feel your pain when programs misbehave while we’re on a deadline.

    Robin

  • Gayle Steinmetz

    August 5, 2009 at 4:13 pm

    We are having this error at the present time in our business. Research found that the start up of Photoshop without the preferences corrects the problem only to have it reoccur periodically. Adobe customer service responded that Photoshop is not designed to perform across a server. If you have a server, move or copy your photo to your desktop. This is sad, considering most corporations use servers. However, try this and hope for the best.

  • michael kline

    August 28, 2009 at 4:19 pm

    I had to delete some Asian typefaces that Firefox had installed. After that, no more problems, and Photoshop ran much better as well. Mac OSX 10.5.7, Photoshop CS4. Not really bagging on Firefox, it’s great. Just watch those updates and what they install.

  • cris bucek

    December 17, 2009 at 7:31 pm

    Hello guys!
    After struggling for days with the same problems and even trying different versions of Photoshop I found the solution.
    The problem probably happened after a printer installation…
    Anyway, try the following steps:
    Go to your Control Panel
    Click on Printers
    – Find the Microsoft XPS Document Writer
    – Right click over it to open the menu and select “Set as Default Printer
    – Re-start your Photoshop. Problem sorted!
    Cheers,
    Cris

Viewing 1 - 10 of 24 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy