Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Compressor won’t function

  • Compressor won’t function

     Mandy Tsema updated 10 years ago 9 Members · 14 Posts
  • jason greene

    December 6, 2007 at 1:29 am

    When I open Compressor 3.0, the splash screen appears briefly, then disappears. The menu bar appears, and all seems normal. Except there is no batch window where I can drop a job. Under Window on the menu bar appears Show Inspector, History, Preview, Settings, Destinations. But there is no Batch window. Under Window/Layouts, there is a choice of two batch layouts and two standard ones. I’ve chosen each of them with no success. When choosing File/New, nothing happens. Ditto for choosing File Open or Open Recent. I have Leopard 10.5.1 and all software is up to date. Also, when choosing Apple/Force Quit, Compressor does not say “Not responding”. Please advise, thanks.

  • jason greene

    December 6, 2007 at 5:59 am

    I am still having problems, but am working on the troubleshooting provided in the below article. I’ve tried all but re-installing. One other thing, I noticed when I open Compressor, it does not create new Preferences after I delete the old ones.

  • jason greene

    December 6, 2007 at 11:24 am

    Ended up following instructions in previous post to the end. Uninstalled, then re-installed. Took over 3 hours. Appears to be working now.

  • Eric Nichols

    December 12, 2007 at 6:46 pm

    I am having the EXACT same issue… No batch window and no new preferences.

  • jason greene

    December 12, 2007 at 11:33 pm

    Eric, I ended up having to uninstall Compressor and Motion, then re-install them. It took about 3.5 hours. Let me know if you need the link for uninstall instructions. I never did find out the cause of the problem. It may have to do with a recent Leopard upgrade.

  • Tim Wilson II

    December 31, 2007 at 5:38 am

    I too am having this problem (I’m still in OSX Tiger 10.4.11): no batch window, no possibility of opening a new job, either by exporting directly from FCP, or via a QT reference movie. I had already been forced to reinstall Compressor when it seemed to crash regularly, and that was a pain. Is anyone succeeding without having to do the complete re-install?

  • Misha Mazor

    January 10, 2008 at 6:30 am

    Uninstalling (with above link directions), software upgrading and then restarting did the trick. Make sure to go up to WINDOW->LAYOUTS and select a view.


  • Chris Bizzocchi

    March 11, 2008 at 10:48 pm

    My basic setup is dual 2 Ghz G5 tower, 3gb ram, with FCP studio 2 installed …

    Had this same Compressor problem which I recently discovered is had by many:
    ie. Compressor is working fine … then suddenly FCP can’t access it when trying to export to compressor … trying to open it directly gives a stuck “about menu” … and there’s no ability to start a new job or batch manually, with those menu functions grayed out …

    I tried many a re-install of FCP studio 2 elements and manual deletion of folder and preference elements with no success. in the end, the problem got worse and I couldn’t even open compressor without it immediately closing (with not even a crash dialog box opening up).

    I didn’t have time to do a wipe and re-install of everything on my system. So, I gave up and simply started importing full-res quicktime movie exports from FCP into DVD studio pro and let that do my dvd compression. All in all very annoying … what with the extra steps and storage demands of exporting, waiting,and then importing.

    Recently I tried to fix the problem again and seemed to have done it! Maybe this will help someone else …

    I deleted the following files and folders …

    — HD/Users/…/Library/Application Support/Compressor (entire folder)
    — HD/Users/…/Library/Preferences/
    — HD/Users/…/Library/Preferences/
    — HD/Library/Application Support/Compressor.framework (entire folder)

    I also deleted the Final Cut Pro (application) and Compressor (application).

    I did not bother deleting any other FCP preferences or folders, or any other FCP Studio 2 applications.

    Then, I re-installed from FCP Studio 2 disks, trying to only select Final Cut Pro and Compressor to be installed. I chose to not let Qmaster manage clusters at the onset of the installation process.

    I started up compressor and no luck at first … but then I did the latest updates for FCP and Compressor (3.0.2) and lo and behold Compressor finally started up again, no problem. I couldn’t believe it! I think the frameworks folder may have been the key, because I don’t recall trying to delete that folder before …

    All of this seemed extremely “ghost in the machine”y … many re-install attempts are fruitless and then finally months later it works??? Plus the problem itself seemed to come out of nowhere. IMHO, Compressor 2 and FCP 5 were a much better pair … version 3 added a lot of useless interface and tabbed job management to compressor and needlessly introduced a lot of instability in the process.

    Hope this maybe helps someone else!

  • Adam Schoales

    March 25, 2008 at 3:55 pm

    Well I am having the same troubles, and tried just uninstalling compressor… but looks like I may have to go ahead and use those long instructions…

    I’ve been having trouble with Soundtrack lately too – so perhaps I should just uninstall everything, in which case is there instructions for that too?

  • Chris Bizzocchi

    March 25, 2008 at 8:57 pm

    I don’t know about Soundtrack … sorry. I have a version installed from FCP Studio 1, but I didn’t re-install any new version from Studio 2 and I don’t really use the old one.

    If no one else has better advice, I would do a search for “soundtrack” in the finder and try to throw at anything that seems related to the application, especially files that appear somewhere in the “Application Support” folder in one of your Library folders.

    Good luck solving the problem!

    – chris –

Viewing 1 - 10 of 14 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy