Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Compressor 4.2 Framerate Conversion / Transcoding EXTREMELY Slow

  • Compressor 4.2 Framerate Conversion / Transcoding EXTREMELY Slow

  • Misha Davia

    June 10, 2015 at 11:09 pm

    Hi all,

    I just started using Compressor 4.2 as a standalone program. I upgraded from C3 hoping that I would see some dramatic speed improvements and am experiencing transcoding times that seem insanely slow – nearly as slow as with Compressor 3.

    I am transcoding Sony F55 MXF files to ProRes 422 HQ. I am also performing a frame rate conversion from 23.98 progressive to 29.97 interlaced (and using Best Quality – Motion Compensated retiming in Compressor to maintain the original clip duration). I know these settings are a bit more time-consuming than your garden variety transcode but it’s been EXTREMELY slow going. A 2 minute clip takes over 30 minutes to transcode. Is this normal??

    I’m running 1 additional instance of compressor in the cluster settings (that was the max that Compressor would allow for my iMac i7 processor). Running the additional instance doesn’t seem to make much difference in speed. When I look at Activity Monitor while Compressor is running it seems that 4 of my 8 virtual cores are running at 60-80%, the other 4 are barely working. Could I be putting my processor to more efficient use somehow?

    Any tips would be MUCH appreciated. I have to use Compressor for this job as it is the only compression software I know of that will perform retiming when converting frame rates but the amount of time it’s taking is debilitating for my workflow. Thanks!

    -Misha

    Specs:
    iMac (27-inch, Mid 2011)
    3.4 GHz Intel Core i7
    16 GB 1333 MHz DDR3
    OSX 10.10.3 (Yosemite)
    AMD Radeon HD 6970M 1024 MB

  • Shane Ross

    June 11, 2015 at 12:02 am

    Way too slow. Use this workflow:

    23.98 to 29.97 via Compressor:

    1. Drop clips you want to convert into Compressor

    2. In Compressor, select your video then right click and choose NEW TARGET WITH SETTING > APPLE > FORMATS > QUICKTIME > APPLE PRORES 422 (HQ). Or pick whatever codec you like to work with.

    3. Click on that newly created compression setting to open it in the Inspector window. Click the Encoder tab. Click the Video: (Settings…) button. Make the frame rate 29.97. Check the interlaced box. Set it’s drop down menu to Bottom field first. Click OK.

    4. Click the Frame Controls tab. Set Frame Controls to On. Set Output Fields to Bottom first. Leave Deinterlace on Fast. Leave Adaptive Details checked. Leave Rate Conversion set to Fast. Leave the Set Duration to: on 100% and make sure it’s radio button is selected and NOT the “so source frames play at 29.97 fps” button.

    5. Make changes to the Filters or Geometry sections as needed. Those settings listed above are the ones critical to getting the proper 3:2 pulldown added.

    6. Submit the compression, then bring the resulting video back into Final Cut Pro. Place it in a 29.97 timeline and make sure you watch it on an NTSC monitor to verify that it looks good. If you step through it frame-by-frame you should see the familiar pattern of 2 split/interlaced frames followed by 3 whole frames. This is a very important step. I tried many solutions that looked OK playing back on the computer monitor, but looked terrible on the NTSC monitor.

    Shane
    Little Frog Post
    Read my blog, Little Frog in High Def

  • Misha Davia

    June 11, 2015 at 12:28 am

    Thanks Shane,

    My workflow was exactly the one you suggest, except that I have Upper First selected for field order. But that shouldn’t make a difference in the speed, right?

    I also don’t see a setting in this version of Compressor for the “Fast” deinterlace, or “Fast Rate Conversion.” Here is a screenshot of the Compressor Video Settings window: screenshot2015-06-10at5.35.07pm.png

    Thank you!

    Misha

  • Shane Ross

    June 11, 2015 at 1:40 am

    OOps…I didn’t fix that typo.

    Well then…it might just be that slow. The higer res the footage, the slower it goes.

    Shane
    Little Frog Post
    Read my blog, Little Frog in High Def

  • Ryan Holmes

    June 11, 2015 at 2:23 am

    Those times look about right given your systems specs (4 year old iMac) and that you’ve turned up Motion Estimation to Best Quality. Your options are to turn the motion estimation down to the default setting and/or purchase a beefier computer with more horsepower.

    Ryan Holmes
    http://www.ryanholmes.me
    @CutColorPost

  • John Rofrano

    June 12, 2015 at 5:06 am

    [Ryan Holmes] “Your options are to turn the motion estimation down to the default setting”

    +1

    I would use the default Fast setting which should be fine for the Telecine conversion you are doing. No need for motion compensation.

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

  • Misha Davia

    June 12, 2015 at 10:35 pm

    Thanks for the advice everyone!

    I will probably just go back to the default setting. On a couple of clips I ran I seemed to be sacrificing some quality with the lower setting (the image was more ghosty and the interlacing was more pronounced in pans, etc) than on the motion compensated setting… but I wasn’t doing a really proper test with two identical clips so perhaps that was simply due to difference in motion between the clips I looked at.

  • Daryl K Davis

    June 14, 2015 at 6:11 pm

    Why transcode to 29.97? I always finish my shows as they were shot at 23.976 and then output the final to whatever broadcast specs are required, whether NTSC or PAL. It’s called the universal mastering format.

    ————————-
    DK Davis / Editor/ Post Super
    ————————-

  • Misha Davia

    June 14, 2015 at 10:21 pm

    Why indeed. That’s the first question I asked when I came on as AE. The workflow doesn’t make sense and has caused numerous problems all down the line. However, as I was brought on mid-show this is the workflow I have to deal with at least until we wrap post on the current episode. Right now my focus is on creating master source files that are as high quality and problem-free as possible…

  • John Rofrano

    June 15, 2015 at 12:14 pm

    [Daryl K Davis] “Why transcode to 29.97? I always finish my shows as they were shot at 23.976 and then output the final to whatever broadcast specs are required, whether NTSC or PAL.”

    It sounds like that’s exactly what they are doing. The show is in 23.976 and now it’s time to deliver in NTSC broadcast which is 29.97. It makes perfect sense. Telecine is a well understood algorithm and there should be no problems adding telecine in compressor. I’m surprised that compressor has a setting for Reverse Telecine and not Telecine it self. Perhaps it does this without asking? I’ll have to to test and see.

    ~jr

    http://www.johnrofrano.com
    http://www.vasst.com

Viewing 1 - 10 of 13 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy