Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D Cinema 4D (R19) won’t launch on my Mac

  • Xavier Bonet

    December 6, 2019 at 4:46 pm

    Hey, thanks, Brian! You’ve helped me out in the past with some C4D-related conundrums, so I’m very pleased I was able to give a little back! ????

    …So this is how I managed to bungle it up today.

  • Xavier Bonet

    December 6, 2019 at 4:59 pm

    Actually, I’m not 100% sure I know what I mean, as those observations weren’t mine, but rather the other sources I linked. But it’s my understanding that it’s not a hardware issue, but rather a software/system error. What I understand is that C4D is trying to gain access to memory but is failing or is being blocked for some reason. Another source (which I didn’t think I should quote without looking further into it) recommended to either whitelist the app:

    “Put in an exception for google the app in gatekeeper:”
    sudo spctl --add /Path/To/

    Or to disable Gatekeeper (at least to see if there’s any change):

    “Looks like disabling gatekeeper all together seems to work.”

    As you mention, Maxon recommended 10.14 but it’s very likely that between .14 and .14.6 tweaked stuff around that has played havoc with C4D. Because we already know Maxon has (absurdly?) relied on private (and very much change-prone) system frameworks for C4D to function, it would’t surprise me at all to learn in a couple of weeks that someone found out it was one such system file that was either modified, moved or even supressed that is causing your issues. All this is actually the reason why I personally am still stuck on 10.12.6… ????

    …So this is how I managed to bungle it up today.

  • Ian Davies

    December 7, 2019 at 3:59 pm

    Ok, so progress for me of sorts…

    I just installed a fresh copy of Mojave 10.14.6 on an external USB drive and booted from it…
    Then I installed C4D R19 and let it update… C4D launched and ran fine.
    Then I let Software Update do its thing (Safari update and security update)… C4D launched and ran fine…
    Then I launched iTunes and connected my phone, let it run the phone connection update… C4D launched and ran fine…

    Soooo… I have a fully patched, fully up to date installation of Mojave, and a fully functional copy of C4D R19. Yay, I guess?

    I don’t understand the problem or how it happened, which is annoying, but the main point is that I have a route to a working production machine again, and is the perfect excuse to switch my boot drive to the SSD I’ve been promising myself ????

    Thanks for all your input Xavier, and others, it really is very much appreciated!!

  • Xavier Bonet

    December 7, 2019 at 8:28 pm

    Yay! Great to hear that, Ian! I’m, glad you won’t be between a rock and a hard place come the next project.

    I guess we’re never going to get an explanation from Maxon as to why these things are happening. I for one am DREADING having to update anything on my Mac… But the time is coming when I’ll have to. ????

    …So this is how I managed to bungle it up today.

  • Andrea Cuervo

    December 28, 2019 at 1:38 am

    Hey guys!

    I have a problem with macOS Mojave after updating the version of my iTunes I connected my iPhone X and it asked me to update, I did & then suddenly the ALT key of the viewport inside C4D-R20 stopped working, I try in the adobe and works perfectly without problems so I thought it was the c4d file, I was working on so I tried to restart open close and create a new one but unfortunately, it didn’t work, is quite weird because I have the option to move in the viewport with the 1,2 keys but it’s not possible to use ATL key, unfortunately, I don’t have how to recover the previous version of my iTunes, I didn’t save the backup in TimeMachine, I would like to know what I should do I have Mojave Version, I’m not sure if it works with the MobileDevice.framework version from Xavier Bonet that is running on macOS Sierra 10.12.6 because I assume that the file to download that you left in the description just works in macOS Sierra,

    Sorry guys but I don’t know much about these issues, however, I do have a question,

    Is it safe to follow the process from Xavier Bonet or do you have any idea where I can download MobileDevice.framework for macOS Mojave?

    I would really appreciate your help or if you have any suggestion for me would be amazing!

    Thank you so much ☺


  • Xavier Bonet

    January 13, 2020 at 12:39 pm

    Hi, Andrea!
    I have no idea whether this framework has changed (or exists as such) in Mojave, as I am still preferring Sierra.
    Moreover, your issue is considerably different to mine (and any other I’ve seen so far in this thread), so I couldn’t say if even the same process will help you out.
    That being said, I shouldn’t think there should be any (permanent) issues with at least trying it out. What I would do is copy the framework you have to your desktop instead of deleting it; then, I would put the “clean” framework from my Sierra machine.
    Considering I ran my computer with that file deleted from the folder and had no issues, I would say that worst-case scenario: putting a Sierra framework in place might impact how your computer connects to your mobile devices and, if that happens, you can just pop the old one back in place.
    Not-so-worst-case scenario: it won’t fix your issue.
    Best-case scenario: it will! ????
    Good luck with your issue! Hope you can solve it soon!

    …So this is how I managed to bungle it up today.

  • Andrea Cuervo

    January 13, 2020 at 1:16 pm

    Hi Xavier,

    Unfortunately, I had no choice, so I restore the macOS to Mojave in its stable version 10.14.6 without performing the update in iTunes because when I performed the iTunes update that my iPhone X automatically requested the C4D viewport stopped working, the truth is I have no idea why, but now I know that it is not very safe to do an update in macOS,
    I think part of the problem is iTunes, I do not know why anyway thank you very much for trying to help me,


  • Esa Ruoho

    April 29, 2020 at 5:46 am

    Thank you for your taking the time to write your solution out. I hit upon this issue today, but with different apps – spent a lot of fun times searching various forums for solutions.

    Many other places have had discussions about this.

    People have had trouble with Ableton Live, Audacity, GarageBand, and custom-made 32-bit apps.

    I had issues with Renoise and SampleManager. VST plugins wouldn’t load anymore either.

    Your solution fixed the issue. I’ll keep a MobileDevice.framework on my iCloud Drive, zipped up for this eventuality. It is going to happen again, I feel like it will for sure happen.

    Thank you again.

  • Daniel Hermann Collini

    November 2, 2020 at 4:14 pm

    hey man! i see this post is already older so not sure you are seeing this. I had exactly the same problem with Ableton Live, a music program. You are a life saver! Thank you so much, usually I never post on blogs or threads but this was really to much of a help that you’ve figured this out and generously shared with everyone how to work around! hands down!!

  • Jean Bombeur

    October 24, 2021 at 4:43 pm

    Hi Xavier Bonnet,
    Big THANKS for solving the problem! 😀
    C4D R18 on macOS 10.11 El Capitan – same problem when connecting an Ipad in OS15.
    As a precaution, and while I was in “roots” I replaced the 3 files
    DeviceLink.framework and of course

    MobileDevice.framework saved from Time Machine before “bad”connection


    Everything worked perfectly!

    NB: do not forget to empty the trash of the 3 “bad” files while you are in”roots”!😉

Page 4 of 5

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy