Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Cinema 4D (R19) won’t launch on my Mac

  • Cinema 4D (R19) won’t launch on my Mac

     Esa Ruoho updated 4 months, 3 weeks ago 13 Members · 39 Posts
  • Xavier Bonet

    September 25, 2019 at 10:00 pm

    So, this has just happened… all of a sudden and in the middle of a project. I closed up everything, shutdown my MBPro and left for a couple of hours for lunch. I came back in the evening and now when I click the C4D it just give one bounce with the little grey circle below it and no more. I can’t launch it nor can I actually launch its installer in order to fix or reinstall the software.

    I have never before had such issues with C4D or any other software for that matter. Obviously I’ve changed nothing in my system, especially not since this morning: no updates, installed nothing else, etc.

    I’ve since tried everything: deleting the contents of my Cache, Launch Agents, Saved Application State, Launch Daemons, etc., folders; I’ve reset the System Management Controller; I’ve reset the NVRAM; I’ve launched in Recovery Mode and ran First Aid on my drives… I even followed the only online recommendation I found that somewhat describes a similar issue and I deleted the Mesa folder located in resources/libs/osx… All to no avail.

    I’m mid-project and now I have a launching issue that I don’t seem to find that anyone else online has had and I don’t know what to do. Any input will be extremely appreciated!

    P.S. As I said, I’m running R19. I Specifically had R19.024 installed last time I checked, but I do remember installing updates a while back; however, as you can imagine I can’t even see what my specific version is, as it doesn’t allow me to load anything. And the MacOS I’m running is Sierra 10.12.6.

  • Brian Jones

    September 25, 2019 at 10:57 pm

    ah interesting, me too. Mac at work that I have everything from R20 back to R10.5 installed on. Yesterday suddenly R20 wouldn’t launch. I had a bit of time today and R16- R20 won’t launch and R10.5 – R15 will launch. I’m not working on anything so I haven’t done any investigation other than that.
    At home (PC, switched) R21 sometimes won’t start but will after a reboot but R19, R20 start no problem.
    On the Mac (old Mac Pro early 2008 so OSX 10.11.6 is the latest possible) since it’s 5 separate versions that won’t start it can’t be a reinstall… the only thing I can think of is I did the update to iOS 13 on the phone the night before and when I plugged it in to the Mac yesterday it needed to do an update so the iPhone would be able to connect….
    Did you have to do a small install to get the new iPhone OS to connect?

  • Xavier Bonet

    September 25, 2019 at 11:04 pm

    As a matter of fact, yesterday I had to update my iPhone by connecting it to my Mac. I hadn’t thought of that because C4D was working fine today; but the truth is last night I didn’t shutdown my Mac, only put it in Sleep mode… So I think C4D the first time I exited C4D was today. Which could explain why (if the issue actually is, as you say, from the iPhone update) it not launching occurred only just now.

    BTW, this is what I’m finding in the Console as I try to launch:

    default 00:55:00.150705 +0200 kernel [CINEMA 4D pid:796 mux-aware] starting, non-mux-aware app count 0, switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle
    default 00:55:00.231767 +0200 kernel [CINEMA 4D pid 796 mux-aware] exiting, non-mux-aware app count 0, runtime: 0:00:00.081

    Don’t know if that can help find the issue.

    I too tried to launch C4D on my PC (which is only my rendering machine) and there was no issue there. So it’s only limited to my Mac and the fact that you mention you too had to update your phone (added to the fact that I NEVER update my phone using my MBPro, and I believe this is the first time I’ve done that) makes me think that’s the common variable…

  • Brian Jones

    September 26, 2019 at 12:00 am

    I would send that into Maxon support, it doesn’t mean anything to me but it may well mean something to them.

  • Xavier Bonet

    September 26, 2019 at 1:10 am

    I think the issue lies here:

    WARNING: Could not load dll. Error code: dlopen(/Applications/MAXON/Cinema 4D R19/corelibs/c4dplugin.xlib, 6): Symbol not found: _xpc_file_transfer_create_with_path
    Referenced from: /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice
    Expected in: /usr/lib/libSystem.B.dylib
    in /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice. (file:///Applications/MAXON/Cinema 4D R19/corelibs/c4dplugin.xlib) [osx_dll.cpp(89)] [general.cpp(266)]

    After several hours’ research… ????… I think I’ve pinpointed the issue: apparently it has to do with the fact I was prompted to update iTunes when I was trying to update my iPhone and that resulted in a corruption of the MobileDevice Unix Executable file in System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/. At least that’s the most plausible explanation I found online. However, I can’t actually solve it, as the steps everyone says one should follow include deleting these files and my Mac won’t allow me to do so, as it says they’re needed for the OS to work properly… So that gets me nowhere. I’ve tried reinstalling iTunes, even downgrading (it didn’t let me) but nothing has changed: C4D still won’t open at all.

  • Sam Treadway

    September 26, 2019 at 1:58 am

    This has happened to me a few times in the past for a variety of reasons.
    Usually it’s a corrupt Cinema 4D.prf file or the executable bit on the C4D executable file was flipped during a restore from the backup server.
    You can run this in terminal to make sure the executable bit is set:


    sudo chmod -x "/Applications/[***C4D intall directory***]/Cinema 4D.app/Contents/MacOS/Cinema 4D"

    If that doesn’t work and you want to tamper with the problematic OS core files, you can mount the system as read/write for the current session temporarily and then change the file name with these terminal commands:


    sudo mount -uw /; cd /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/; sudo mv MobileDevice MobileDevice.bak

  • Xavier Bonet

    September 26, 2019 at 9:43 am

    Hi. Thanks for your input.

    That first option seems to have actually made things worse… It now directly says “The application ‘Cinema 4D’ can’t be opened’, and the Cinema 4D.app/Contents/MacOS/Cinema 4D executable file is now no longer an executable, and when it opens (now in TextEdit) it displays gobbledygook instead of opening up in Terminal and displaying the processes… I’m really out of my depth here, so I don’t know if I can revert this or if there’s another step I’m missing…

    On the other hand, the second option has the same result as trying to change the permissions through Get info, it tells me “Operation not permitted”… For some reason my Mac just doesn’t want to allow me to either delete that framework or give myself permission to do so. My account does have Administrator privileges, so I don’t know what’s going on.

    I’ve also tried finally installing R20 (I was putting it off because I had no time to install it and migrate everything… but now I’m stalled anyway) and the result is the same as trying to re-install R19: I click the installer, it bounces an icon once on the dock, and then it fizzes out, doing nothing. So I must assume it too tries to use that corrupt framework. (Plus, this just proves to me that it has nothing to do with the C4D executable, as the same thing happens with both the R19 and R20 installation executables, too.)

  • Xavier Bonet

    September 26, 2019 at 9:52 am

    Ok. I got it back to being a Unix Executable File after some research online on how to manage that:
    sudo chmod +x "/Applications/MAXON/Cinema 4D R19/Cinema 4D.app/Contents/MacOS/Cinema 4D"
    (It seems pretty obvious now ????)

    So now the only thing I have to find out is how to deal with the MobileDevice.framework if my Mac won’t allow me to change it, move it or delete it! But it seems to work right outta the box for everyone else, so I can’t find any info on that…

  • Sam Treadway

    September 26, 2019 at 3:05 pm

    Sorry about that. I now see I typed the wrong flag on the change mode command. Glad you were able to fix it.

    Here are some more things to test that I always recommend when troubleshooting:
    1. Double-click that executable directly “/Applications/MAXON/Cinema 4D R19/Cinema 4D.app/Contents/MacOS/Cinema 4D”
    This will launch a terminal window and spit out all the debug info you need.
    Look for any signs at the end when it halts other than the message about the MobileDevice package.

    2. Create a new user profile on the Mac and login and go through the initial setup stuff.
    Immediately try to start up C4D. If it works as expected then you know something in your main user profile is the cause.
    If it still doesn’t work, then it is either the application install or the OS.
    In that case, rule out the application first by deleting every trace of it in:
    /Applications
    ~/Library/Preferences/c4d19_####### files
    ~/Library/Preferences/MAXON

    3. Try to delete the problem file again (for testing purposes as temp solution)
    You will probably have to disable system integrity protection if not already.
    First, I’m assuming you’ve performed first aid on the disk from within system recovery?
    Do that by shutting down, then powering up and holding down command-R for a while.
    In system recovery open up disk utility and run first aid and see if it is able to detect a problem.
    If it comes back clean then you can try to move or rename the file after disabling system integrity protection and then following the steps from earlier.
    While still in system recovery, launch the terminal and type in the command: csrutil disable
    After pressing return you should get a confirmation that it will take effect after reboot.
    Do that and boot up normally.

    If you are able to move or rename the file, then in terminal you can reenable SIP with: csrutil enable
    After you reboot, system integrity protection will force the system files back to their original state which should hopefully fix it (if that is truly the problem).

  • Brian Jones

    September 26, 2019 at 3:06 pm

    I just got this response from Maxon Support

    this looks like a problem with the operating system. We have been informed that this can be the result of an macOS security update that occurs after adding an iphone to link to the machine.

    The known work around for this is currently to upgrade your operating system to 10.14. I am not aware of any others, but a reinstallation of the current operating system may also fix the problem.

Viewing 1 - 10 of 39 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can. Our Privacy policy | GDPR Policy