Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D Cinema 4D (R19) won’t launch on my Mac

  • Xavier Bonet

    September 26, 2019 at 5:11 pm

    Hi, guys! I’m so thrilled to be able to come back and say that finally I managed to resolve the issue! And even more thrilled that I wasn’t forced to upgrade OS, as I haven’t had time to thoroughly research the consequences of Mojave or Catalina…

    Anyway, I thank you all very much for your input! It’s been a very tense couple of days but all’s well that ends well, I guess. This is what finally worked for me:

    I had already tried some of the things you recommended and then tried the ones I hadn’t but to no avail. In the end, the fix was getting rid of the offending framework, but with a twist. I’ll explain in detail:

    Last night, when I opened the executable directly I got the Terminal window with the list of precesses, and everything was fine except for the error I mentioned in a previous post, which pointed toward the MobileDevie.framework. There were no signs at the end; the process simply stopped and exited, but there was no other mention of anything weird. So I had to assume this was the issue.

    As I pointed out, after extensive research my conclusion was that there had been a change that had occurred when I tried to upgrade the iOS on my iPhone, which had forced me to also upgrade iTunes and, as Maxon have pointed out to @Brian Jones, do a security update. Based on all this and thanks to @Brian Jones’ post on what Maxon had told him I was 99% sure the only way to fix the issue was to get rid of that framework or substitute it with that of my other MBPro which had had no such upgrade or update.

    However, the issue was that my Mac simply wouldn’t allow me to rename, swap or delete the framework. Thanks to @Sam Treadway’s guide in point 3 on how to get my Mac to grant me control in order to get rid of these files, I was able to do just that. However, I found that just renaming (or getting rid of) the actual MobileDevice executable wasn’t enough, as rebooting didn’t create a new one and then the error just changed to not being able to find the executable instead of not being able to find a symbol within it. So I got rid of the entire MobileDevice.framework (i.e. the file that’s in the PrivateFrameworks folder) and I brought in the MobileDevice.framework from my other computer that had had no upgrade or update, as I said.

    And that did the trick!

    So, to recap, step by step: How to get C4D to work again if you have updated iTunes etc.?

    1) Go into /Applications/MAXON/Cinema 4D R19/Cinema and open the Cinema 4D executable. This will open it up in a Terminal window and make sure the problem is in fact something to do with the MobileDevice.framework.

    2) Get the entire MobileDevice.framework from another Mac (that’s running the same OS, and hasn’t been updated or that can run C4D without a problem) or from your TimeMachine backup made before updating. You can find it in /System/Library/PrivateFrameworks/

    3) Shutdown your Mac and turn it back on while pressing the CMD+R keys on your integrated keyboard. When the Apple logo appears you can release the keys. This will open Recovery Mode.

    4) Recovery Mode will prompt you to choose your preferred language: do so. Then go to the top bar, go to Utilities > Terminal.

    5) In the Terminal window type: “csrutil disable” (without the quotation marks) and press Return.

    6) A confirmation will appear: “Successfully disabled System Integrity Protection. Please restart the machine for the changes to take effect.” Do so: restart your computer and let the OS load normally.

    7) Now you can into you /System/Library/PrivateFrameworks/ and move out or erase the MobileDevice.framework and in its place paste the MobileDevice.framework you retrieved from the working computer or OS backup

    8) Restart your computer and go back into Recovery Mode, open up the Terminal and type: “csrutil enable” (without the quotation marks) and press Return. This will re-enable System Integrity Protection.

    9) Restart and let the OS load as usual and ???? you should now be able to launch C4D once again!

    10) If everything goes according, permanently erase the old framework you deleted or moved out of its place and don’t update iTunes or run security updates until you are ready to upgrade your entire OS—or at least without having a working copy of MobileDevice.framework at hand and being prepared to repeat these steps to save your life!

    Having said all this, I must admit I’m somewhat disappointed at Maxon that they’ve made their software dependant on a Private framework, which is supposed to be “private” and for Apple’s use, which means that any change to it will possibly make their software unusable, as it surely did in this case. I still don’t understand why C4D needs to have anything to do with the Mobile Device framework… but perhaps all I’m doing is showing how little I know about the matter.

    Anyway, once again thanks a million for your help, guys! And I hope this post might help out someone else and spare him/her several headaches!

  • Xavier Bonet

    September 26, 2019 at 8:34 pm

    Hello, @Tim Reynolds. In my last post above you’ll find step-by-step detailed instructions to solving this issue. And considering the security update is culprit in your case as well, in theory you should be able to solve it just as I did, and have no further trouble. I didn’t restore from Time Machine but I guess it should restore the MobileDevice.framework to one that plays well with C4D.

    If you guys have problems getting a “good” copy of the framework perhaps I can upload here the one I used which worked for me. I’ll need to check and see if that’s allowed.

    Good luck!

    …So this is how I managed to bungle it up today.

  • Eros Gaggiola

    September 27, 2019 at 7:34 am

    Good morning guys … I read with regret that you also had this problem … I unfortunately do not have time machine activated so I can not recover the file to replace … and as maxon says I can not reinstall 10.14 because having a mac pro early 2009 is not compatible … it is a big problem this!
    Then yesterday panicked I deleted the entire folder itunes and I hope that this does not create more problems!!!
    If you have other solutions I would be happy to read them…

  • Xavier Bonet

    September 27, 2019 at 4:40 pm

    Hi, Eros! Do you have access to any other Mac running the same or a similar OS? Perhaps a friend’s?If you do, you can get the file you need to substitute. You don’t need to get rid of the entire iTunes folder.

    If you haven’t already, check out the step-by-step instructions to solve this issue I posted in my previous-to-last post above.

    Hope you can solve this soon, too!

    …So this is how I managed to bungle it up today.

  • Mike Compas

    October 1, 2019 at 12:09 am

    I just may have found an alternate end process to solve this problem: reinstall a previous version of iTunes.

    Just as noted in Xavier’s message above, you most likely will need to disable SIP via Recovery Mode. This is important because you’ll need to manually delete the MobileDevice.framework file in order to replace it with an older version. Simply reinstalling iTunes (12.8.2) without first deleting the framework will not suffice, since installer packages will not overwrite certain files if a newer version is already present.

    Manually restoring the MobileDevice.framework file from a backup may not be sufficient if the backup is not recent. It’s my guess, but there may or may not be compatibility issues with the framework file (if it’s too old) and the iTunes version is newer. In my specific case, my last backup is from almost two years ago, so manually replacing the framework file was not an option for me, despite STILL being on Sierra (10.2.6) for eGPU reasons.

    Lastly, to note, the older framework file that works is listed as version 988.222.1 (created Jan. 10, 2019), and the offending version that breaks Cinema 4D is version 1190.9.1 (created Aug. 29, 2019). You can check the version numbers via Get Info in the Finder.

    Nonetheless, backup your machine regularly for your safety and sanity! Thank you all for your solutions and bringing this to light.

    You can download older versions of iTunes from Apple’s Support page:

  • Ziggy Deutz

    October 2, 2019 at 1:26 pm

    Thank you so much for your explanation! I have only one problem, I have no back up or another osx system where I can get the MobileDevice.framework file. You where saying that you perhaps can give your file. Do you think that is possible?

  • Jake Steffes

    October 6, 2019 at 7:39 pm

    Hi Xavier, I ended up on your post while troubleshooting Logic Pro not loading customized plugins, with the same root error pointing to MobileDevice.framework. Completely different application, but your troubleshooting step-by-step helped me solve the problem. Many many thanks!

  • Xavier Bonet

    October 7, 2019 at 12:10 am

    Hi, Jake! I’m very glad you were able to solve your issue as well!
    And thank you very much for letting me know you found the troubleshoot useful, you’re very kind! I often benefit from the knowledge of others here at Creative Cow but there are so many knowledgeable people around, and then the stuff I do is usually so specific and niche, that it’s not often I get to chime in and return the favor! So I’m very glad something good came of it!

    …So this is how I managed to bungle it up today.

  • Xavier Bonet

    October 7, 2019 at 12:19 am

    Sorry for the delay! I’ve been traveling shooting material for the last week or so, so I haven’t kept up to date online. You’ve probably solved this by now but, for what it’s worth, to you or anyone else, here goes the working framework file:

    Hope this helps!

    P.S. I’ve had to compress it because, otherwise, the CC uploader wouldn’t let me select the file. I hope that doesn’t mean these kinds of files aren’t allowed on CC, only project files.

    …So this is how I managed to bungle it up today.

  • J Hussar

    October 10, 2019 at 4:34 pm

    Had the same issue when I ran that little updater for iTunes for ios13.

    Was the definite cause and effect – not sure who is at fault, I had the error in the console having to do with the “code signature” – so, did Apple somehow depreciate C4D, or was C4D code signature bad and just waiting to break?

    I luckily keep a clone of my drive and replaced 3 frameworks in the System/Library/PrivateFrameworks. I replace the following with version from May 25th (I’m on El capitan BTW)


    These were the ones ‘updated’ by the lousy little installer from Apple.

    All works again – but will it be broken again?

Page 2 of 5

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy