Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X Beach Ball when trying to open a specific library

  • Beach Ball when trying to open a specific library

  • Jack Lewis

    January 27, 2022 at 3:13 pm

    Hi all,

    A project (a podcast with probably 8 audio tracks) I’ve been working on for about three months) has started giving me problems. On the second “final” output (of course it happens at the end) froze last night. After about an hour, I did a force quit and went to bed to attack fresh this morning. Today, when trying to open (first just buy opening FCPX) I again got the beach ball and no action. I forced quit (again). opened FCPX with Opt+Cmd held to clear preferences, and tried to open by clicking the icon on the external drive. Again, no joy. I tested to see if I could open other libraries, and I can. Even a library shared on the same external drive.

    I then tried to go to an earlier backup version stored on the computer hard drive, and again, beach ball. It was working fine until about 7pm last night so a little confused why a backup version won’t load.

    Am a bit of a noob on file storage, etc., honestly. I generally plug in the external for a project and get to work.

    I’ve seen one fix as trying to find a problem with a media file in the library’s media file, but am not even sure where to access that.

    Anyone have any ideas for noob with a problem here?

    Thanks,

    Jack

  • Roger Sherman

    January 27, 2022 at 3:38 pm

    Apple has a very helpful FCPX team: 866.752.7753

    Good luck and let us know what the fix was please.

  • Jeremy Garchow

    January 27, 2022 at 4:15 pm

    With FCPX open, and with all libraries closed (so open a “good” library and then choose File > Close Library) choose File > Open Library > From Backup, and then choose a version of your “bad” library that worked, which is probably the one right before it stopped working.

  • Jack Lewis

    January 27, 2022 at 4:31 pm

    Thanks, Jeremy. No luck. Was able to open several libraries (though most with missing media because I don’t have the drives connected). But when trying to open an earlier version of this one (though “backup” was grayed out) via open library>locate>movies>final cut back up>podcast) ANY version (even tried one from a month ago) immediately goes to beach ball and not responding requiring a force quit. I’m starting to get really nervous.

  • T. Payton

    January 27, 2022 at 6:02 pm

    I’ve seen this before. Likely bad media, but could be something else. However, here is a troubleshooting article on frame.io blog. Start with #7, “Not being able to open a Library or even a Library backup. Inability to render a section. Share fails midway.”

    How to recognize and fix 11 common problems in Final Cut Pro X

  • Jack Lewis

    January 27, 2022 at 6:43 pm

    Thanks, T. and all. After doing some hunting around (and it may well be in the article T. posted), I found a solution for my case. Deleting “currentversion.flexolibrary” and “settings.plist”, likely with a combination of wiping prefs on a restart. Took a while to “verify” the program, but finally opened. Whew. Thanks again and hope this solution works for anyone else coming across this.

    Jack

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy