Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Atmosphere pass obscured by transparent object

  • Atmosphere pass obscured by transparent object

     Ihab Ali updated 5 years, 9 months ago 4 Members · 8 Posts
  • Kevin Dazet

    November 21, 2013 at 8:20 pm

    Hi all,

    I’m rendering out an atmosphere pass so that I can isolate some pyrocluster clouds. In the middle of one of these clouds is a plane whose texture (a photo of an object with masked out background) has the alpha channel enabled. The scene renders the way I want it in my rgba pass, but the atmosphere pass is black in the areas where the plane should actually be transparent. This means the clouds that are behind the plane, even in the masked-out areas of my photo, aren’t visible.

    Does anybody know if there’s a way around this? I don’t understand why the camera can see the atmosphere where I expect to see it, but the actual atmosphere pass behaves differently. Is there a tag I need to throw on my plane object?


  • Manuel F. Rugeles

    November 29, 2014 at 8:19 pm

    Hello, I just have the very same problem, did you figured out a workaraound for this?

    Manuel F. Rugeles
    Editing and Motion Graphics

  • Kevin Dazet

    November 29, 2014 at 8:34 pm

    Unfortunately, I didn’t. I think my workaround was to trace my image in Illustrator, then import and extrude the resulting spline and assign my texture to it. That way I didn’t have to worry about the alpha channel. Unfortunately this is really cumbersome. I wish there were an easier fix.

  • Manuel F. Rugeles

    November 29, 2014 at 9:43 pm

    Oh ok, thanks for the answer. In my case I think I’m going to add to the render an object buffer for the object with transparency thats obscuring my pyrocluster matrix. Then render again just a pass of the post effects atmosphere for the pyrocluster whitout the transparent object visible. And then use that to do the compositing.

    Manuel F. Rugeles
    Editing and Motion Graphics

  • Nikita Solodukhin

    September 8, 2015 at 5:47 pm

    I know that this is super late, but I believe you can add a compositing tag to the object being ignored and uncheck “Seen by transparency” to fix your issue.

  • Ihab Ali

    September 9, 2015 at 4:15 pm

    Hi Nikita, are you saying the object with alpha should have a compositing tag with “seen by transparency” unchecked? I just tried that and I’m still getting occlusion by the entire surface of the object rather than just the transparency.

  • Nikita Solodukhin

    September 9, 2015 at 4:23 pm

    That tag should go on the object that is being occluded, not the object with alpha.

  • Ihab Ali

    September 9, 2015 at 4:30 pm

    I just tried that now, I added the tag to the TFD container that generates the atmosphere pass occluded by the object containing the alpha channel…same thing, the entire object(with alpha) still occludes the atmosphere pass rather than just the parts that are not transparent

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy