Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro X APTS Mounted Volumes Not Showing In Event Library

  • APTS Mounted Volumes Not Showing In Event Library

    Posted by Gerry Fraiberg on April 26, 2012 at 2:43 am

    Now you see it, now you don’t.

    I have just bought the digital version of Final Cut Pro X Advanced Editing (APTS) and downloaded the Lesson Files. When I mount one of the three Sparse Images, it shows in the finder. However, FCP X does not see the mounted drive in Event Library. Nor does it see the mounted drive for APTS Final Cut Pro X – by Diana Weynand. Prior to upgrading the OS to Lion, and FCP X to 10.0.4, it worked fine.

    I am using Event Manager, and tried several times with both training programs to no avail.

    I repaired disk permissions, downloaded Digital Rebellion’s Preference Manager and trashed preferences then restarted FCP X, Compressor and Motion.

    When I first started FCP X after mounting the volume, I got a warning message that the volume is downloaded from the internet, and did I want to proceed. I clicked yes, but it’s not visible.

    I don’t think that my user profile is corrupt, as I did some troubleshooting with Apple support a week after installing the upgrade to 10.0.4 and the Upgrade Available showed up again in the App Store. We created a test user profile, and the issue was there as well. I had to download FCP X, Motion and Compressor again to clear the message.

    Any ideas, suggestions?

    Gerry

    Mac Pro – Early 2009
    Processor 2.66 GHz Quad-Core Intel Xeon
    Memory 8 GB 1066 MHz DDR3 ECC
    Graphics ATI Radeon HD 4870 512 MB
    Software Mac OS X Lion 10.7.3 (11D50)

    Craig Richard replied 10 years, 9 months ago 6 Members · 15 Replies
  • 15 Replies
  • Jari Innanen

    April 26, 2012 at 5:25 am

    I changed the permissions manually to read write on the sparseimage itself. Now once mounted FCP X sees them Ok.

    Apple Certified Associate, FCP X

  • Marcus Samuel-gaskin

    April 26, 2012 at 9:44 am

    I think i ended up copying the contents of the sparse image to a new folder on my media drive. I had trouble too. Try that.

  • Gerry Fraiberg

    April 26, 2012 at 11:45 am

    The permissions were already set to Read/Write for the sparse images, which are stored in a folder on my second drive (Mac Pro).

    As for copying the files to a folder, that seems like a good suggestion. However previously FCP X saw the mounted drive in the Event Library.

    Something has changed the way FCP X sees mounted drives in the upgrade to Lion and 10.0.4. The question is how to fix it.

    Any other suggestions?

  • Jari Innanen

    April 26, 2012 at 6:18 pm

    I used “Apply to enclosed items…” -command as well. That seemed to do the trick.

    Apple Certified Associate, FCP X

  • Gerry Fraiberg

    April 26, 2012 at 7:19 pm

    [Jari Innanen] “I used “Apply to enclosed items…” -command as well. That seemed to do the trick.”

    Where are you making this change “Apply to enclosed items”? I don’t see this in Sharing & Permissions on the Info pane. Also, the previous Advanced Pro Training Series FCP X was seen in FCP X, but now it’s not. What changed is the OS and the software – upgrade to Lion and to 10.0.4 I suspect either some bug in the OS or the new 10.0.4

  • Jari Innanen

    April 26, 2012 at 8:20 pm

    It’s under the cogwheel in the info pane.

  • Gerry Fraiberg

    April 26, 2012 at 9:07 pm

    Thanks, but it still does not work. FCP X 10.0.4 is still not seeing mounted disks from sparse images.

  • Donn Lawler

    April 29, 2012 at 2:20 am

    Gerry-
    Thanks for posting this. I’m having the same trouble and thought I was going nuts! Can not, for the love of Pete, figure out what’s going on with the application and the updated files. I’m on my third download of the files now, email sent to Peachpit and waiting for reply and the one thing I’m looking forward to trying is moving the files from the .sparseimage to another folder, as suggested by Marcus… these small, quirky bugs that crop up each update are starting to wear thin. Any-ro, I have a feeling there will be more as the days go on and more and more users start upgrading the files… Could not have happened at a worse time!!

  • Gerry Fraiberg

    April 29, 2012 at 3:51 pm

    Donn,

    You’re welcome. It appears to be a bug in 10.0.4. And until it’s fixed, the only way to work with the Lesson files is to drag them to the appropriate folders. This is also confirmed by Mark Spencer, one of the co-authors of Advanced Editing Techniques. I use Event Manager to move events around once they’re in folders. It’s a $5 app, worth every cent.

    The forums are a great place to learn and share information.

    Gerry

  • Donn Lawler

    April 29, 2012 at 6:17 pm

    Many Thanks for the recommendation for Event Manager X!! What a GREAT app! Are you using a dedicated drive for the files? I’m not working on a MacPro but I do have an SSD drive that runs via USB 2.0 and was thinking about putting the files on this as FCP X seems to see those drives without a problem… just curious about performance, if you have any thoughts on it. I’m using a 27″ iMac with the 2.93 GHz i7 Intel chip and occasionally a MacBook Pro when I’m out and about. I sure did like the “cleanliness” if the sparse image the files once offered…

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy