Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy apple prores 422 problem

  • apple prores 422 problem

  • raju bhai

    March 25, 2013 at 3:28 pm

    Hi! I posted this question before. But didn’t get it resolved yet. I imagine somebody here though must know the problem i am facing or has probably experienced it before.

    I edited most of my video that was shot on Canon 5d without first transcoding the clips. So halfway through the edit, I decided to transcode the clips to apple prores 422. Then I changed the sequence settings to reflect Apple prores 422 and reconnected all the clips on my timeline to their corresponding prores files.
    But the problem I am having now is that between alot of the clips on the timeline a 1-frame black gap has been introduced. Has anyone else experienced this or know why this would happen?

    Also, my source clips, the raw data, are all in 23.98 frame rate, and so are my sequence settings. So I don’t think it could be a frame rate issue.

    PLEASE HELP!!!

    PS: After transcoding the files, i reconnected them by selecting all the clips on my timeline at once and hitting reconnect, that’s the only way it seems to do a batch connect rather than one at a time, which is very time consuming.

  • Ryan Holmes

    March 25, 2013 at 3:46 pm

    Are the transcoded ProRes files at the same frame rate – 23.98? You’ll need to look directly at the newly created Quicktime files and verify that you transcoded correctly.

    Ryan Holmes
    http://www.ryanholmes.me
    vimeo.com/ryanholmes

  • raju bhai

    March 25, 2013 at 4:59 pm

    yes i checked and the transcoded files are all at the same 23.98 frame rate.

    The only difference between the original raw files and the prores files besides the originals being h.264 is that the data rate on the originals are smaller mbits/sec while the PRORES files are bigger mbits/sec. I don’t know what the data rate means, but perhaps that is normal? Each clip by the way has a different data rate.

    PLease let mw know what else I can check to see why the single blank frame insertions between clips on the timeline is happening, thanks.

  • Anna Ingenthron

    March 25, 2013 at 9:17 pm

    My guess is it couldn’t make frame-accurate edits on your initial sequence because it was h264 (too compressed for fcp 7) so it did its best guess. Then when you brought in the prores footage (ideal for fcp 7) it was able to find the correct frame and playback at the correct framerate, which lead to junk frames throughout your edit. Depending on what this looks like, you should just be able to extend your clips over these or close those gaps to achieve the same total running time.

    I would recommend removing the h264 clips from your project if you haven’t already, and any sequences which may be corrupt as a result of those clips. Importing h264 footage into an fcp project can cause problems down the line, even if it’s not used.

    You may want to even put your most recent edit onto a fresh sequence. First drag one of your prores clips onto the sequence and match the settings. Then delete that clip and copy your edit onto it. That way you know you’re moving forward with the correct settings matching your footage.

    The difference in data rates is correct/normal. H264 is more compressed (less information) which is why its data rate is so much lower than Prores.

  • raju bhai

    March 25, 2013 at 10:52 pm

    yeah i think you may be right, thanks.
    I’m not sure how i am going to do this. i spent several months editing this with the clips as h.264. I don’t want to have to recut this whole thing again. It definitely looks far better with apple prores.
    If i create a new fresh sequence, how do i import my old timeline into it? In other words, the h.264 timeline is perfect. But now the apple prores timeline is messed up with the gaps inbetween. When i delete the few h.264 clips from the prores timeline, the gaps still remain.
    Any ideas?

  • Anna Ingenthron

    March 25, 2013 at 11:34 pm

    I’m not really sure what you’re asking. You don’t need to recut if you just relinked your clips to the prores footage (which should have the same filenames and lengths as the h264s). If you overcut your sequence with the prores clips, you need to remove ALL h264 footage from your project. It really shouldn’t be in any sequence or even in your browser. Even render files created from rendering h264 footage can be corrupted.

    Once it’s relinked, you have your cut sequence already there. Then you select all those prores clips on that cut sequence, and copy them over to a prores sequence that has never had an h264 clip on it. There’s your new master sequence with your cut on it. If the total running time is what you need it to be, but you have the gaps, you need to extend each clip over your one-frame gaps. If the total running time doesn’t matter, or is too long, you can close each gap.

  • Rafael Amador

    March 26, 2013 at 4:57 am

    Try changing your original sequence codec by Prores and set “RENDER ALL YUV IN HIGH PRECISION”.
    Otherwise the rendering will be done in 8bRGB.
    rafael

  • raju bhai

    March 26, 2013 at 4:26 pm

    well, the problem with the 1 frame gaps is that this is a music video and it needs to sync perfectly with the audio track. Also, the in and out points on each clip are very precise and alot of thought and time went into it, so if i have to change the in an out points of each clip on the timeline, if even by one frame, it changes the edit.

    I was hoping there would be a way that i wouldn’t have to close the gaps, that if i just remove any trace of h264 clips in the timeline as well as browser and rectified the settings the right way, then the gaps would disappear and i wouldn’t have to go in and close them manually and thereby mess with the edit.

  • Joseph Owens

    March 26, 2013 at 4:57 pm

    Yes, but you were editing with a Long-GOP codec, which was being interpolated on-the-fly, whereas you are now dealing with an intra codec where every frame is distinct. You should be able to simply close the gaps by stretching the in or out point of each clip, keeping your cut points consistent. Other posters are correct that this phenomenon usually occurs with frame-rate differences on a Final Cut timeline, but it will also occur with Long-GOP formats –XDCam is also another major offender, especially with round trip workflows with a color grade application in the middle. You should check (possibly with an original timeline QT/baked or self contained) where the frame drift actually occurs. You might find that everything is a frame advanced, for example, even if the cut points are accurate.

    jPo

    “I always pass on free advice — its never of any use to me” Oscar Wilde.

  • raju bhai

    March 26, 2013 at 9:49 pm

    OK i checked the properties of every clip on the timeline and there are about 4 clips with a 25 fps vid rate!
    The rest are all 23.98. So i can delete the offending clips and import the corresponding prores files and place them where those clips were. I will have to re-select the edit points but for just 4 clips, that won’t be so hard. But then i will probably still have the gaps in my video and have to extend each clip a frame. But if i instead start with my old timeline where everything is h264 and i delete just these 4 clips and then reconnect the remaining clips to their coressponding prores files, is it possible that i won’t get any gaps?
    Please let me know.

    Also, i’m not sure if i have the best sequence settings for apple prores edit. My setting currently are:
    1920 x 1080 (as are the original raw files)
    aspect ratio: HDTV 1080i (16:9)
    pixel aspect ratio: square
    field dominance: none
    editing timebase: 23.98 (the original raw files are all 23.98)

    video processing: Render in 8-bit YUV

Viewing 1 - 10 of 13 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy