Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Media Encoder AME CC2014 (bad quality h264 compressions when compared with Compressor)

  • AME CC2014 (bad quality h264 compressions when compared with Compressor)

  • Bryce Hoover

    March 31, 2015 at 3:37 pm

    I’m finding that I can not get Compressor quality h264 compressions with AME using the same settings.
    I’ve posted something similar on Adobe’s forums and haven’t heard a peep.

    Here’s my latest example:

    AME encoded

    Compressor encoded

    Specs for encode using Compressor:
    h.264 (.mov)
    restrict data rate to 5000kbps
    compressor quality: high
    encoding: Best Quality (multi-pass)
    Frame controls: on
    Resize filter: best
    Output Fields: Progressive
    Deinterlace: Better
    Dimensions (output) 1280×720

    Specs for encode using AME:
    h.264 (.mov)
    limit data rate to 5000kbps
    quality: 80
    Depth: 24 bit
    Field Order: Progressive
    Frame Rate: 29.97
    (output) 1280×720
    UNCHECKED render at Maximum Depth

    Quality does not improve one bit if I check the maximums with AME.
    In these examples, I did enlarge the QT player and the helicopter footage was bad quality to begin with.
    Neither of these cause the disparagement in quality as seen above.

    I’m not looking for a work around, i have that with Compressor.
    I know AME is faster; faster at putting out garbage.

    What I’m looking for:
    1) suggestions on how I might tweak my AME settings to get similar results to what I get with Compressor
    2) are others experiencing the same problem?
    3) recognition from Adobe that they have a problem with AME (doubtful)

  • Ryan Holmes

    March 31, 2015 at 6:56 pm

    AME is only a computer program and will only do what you tell it to. No more, no less. I don’t think Adobe “has a problem with AME.” The software works fine…so let’s see if we can’t manipulate your settings to get a better overall product.

    Why do you have quality set to “80” with AME? Of course it would come out softer if you tell it do anything below 100.

    What’s you’re keyframe rate set to? Typically it’s half your frame rate.

    Are you doing CBR or VBR? If VBR 1-pass or 2-pass? If overall file size is a non-issue then go with CBR as it’ll use all 5mbps to encode the picture. If you need to keep your overall file size down go with a VBR. 2-pass will take longer but typically comes out better looking than 1-pass.

    Also, is there a reason you’re using a Quicktime wrapper with the h.264 codec? Just curious. Have you tried using the h.264 codec in a mp4 wrapper? That will also provide you with more setting to tweak the output of your file.

    Ryan Holmes

  • Bryce Hoover

    March 31, 2015 at 7:06 pm

    “80” with AME – the Compressor settings I use have the quality set at High which looks to be 80%.
    Keyframe rate – unchecked, does that mean automatic?
    AME doesn’t give me an option for VBR or CBR with a .mov wrapper.
    .mov vs. mp4 – trying to keep things apples to apples.

    I believe I’ve told AME to do exactly what I want, as Compressor seems to understand and be able to perform what I’ve asked it to do.

    I’ll use your suggestions and see if it helps. I’ll report back what I find.
    Thanks for the suggestions!


  • Bryce Hoover

    March 31, 2015 at 7:58 pm

    Changing from Quicktime to H.264 (mp4) seems to have made a difference.
    I created an H.264 preset, Profile: Main, Level: 5.0, [email protected], 2-pass, Target: 5, Max: 6, Key Frame Distance: 15.
    Quality seems to be as good as Compressor’s QT h264.
    What I’ve noticed is the last frame of the .mp4 isn’t full black, but is with the Quicktime version.
    QT player says it’s got 300 frames (:30 spot) but the last frame is not black with the .mp4.
    I’ve encoded 2 different files and got the same result. I need the file to end in full black.
    Any idea what causes the QT to have full black but the .mp4 to not?


  • Ryan Holmes

    March 31, 2015 at 8:03 pm

    Glad that it’s coming out better. I’m thinking the h.264 mov file is a general non-standard way to display h.264 content, and Quicktime will restrict the options you can encode with, as you notice. When comparing h.264 mp4’s I’ve not noticed a big game in quality between Compressor, AME, Squeeze, or Telestream. They all do a comparable job on the footage provided the specs are done well.

    If I had to guess as to your latest problem, I’d assume QT as the culprit. It’s a notoriously bad way to preview and playback files (gamma issues, pulldown problems, etc). I would check it in some other players to verify (MPEG Streamclip, VLC, Cineplay) or bring it back into Premiere and see if it’s showing up there as not completely fading out. If so, you can add a frame or two of black to the end of your spot in your NLE of choice before exporting out.

    Ryan Holmes

  • Bryce Hoover

    March 31, 2015 at 8:17 pm

    I’ve confirmed that the .mp4 files do have black as the last frame, so that’s good.

    I guess working in the Mac world for so long, I’ve never had issues with reading or creating h264 QT files but always seem to have issues with .mp4 files (creating them at the same quality).

    Thanks for your help!


  • Daniel Fletcher

    April 7, 2015 at 4:43 am

    i find that doubling the target bit rate and using that for max is helpful for maintaining quality h264 compressions. thats admiddatly going a bit overboard but its a good place to start. when you are going for small file size VBR is your friend, just pump up the max bitrate and it will sort it out for you based on your target.

  • Bryce Hoover

    April 13, 2015 at 2:10 pm

    I had a pretty major issue this weekend with MP4 files that reminded me why I have attempted to avoid them in the past.
    I created 25 looping animations, most had lengths of 1:27 and a few that were 5:09.
    I sent the animations straight from AE to AME for compression as h264 .mp4 files with settings:
    VBR 2-pass, 8Mbit target 20Mbit max, key frame distance 15, profile: main, level 5.0, no audio.

    These animations were loaded into presentation software ProPresenter. I first loaded them on my MacBook Pro 17″ and noticed they skipped and didn’t start like they should. ProPresenter seemed to hang when transitioning between files. My MacBook has more than enough ram and VRAM to handle everything I through at it. The final play out was through a MacPro tower with a 1.5GB video card and 8GB of RAM.
    Playback through the MacPro was much worse and nearly locked up the software (lots of pinwheels).

    At the last minute, literally, I took the .mp4 files, through them into Compressor (Compressor didn’t like the .mp4s very much either), and created h.264 .mov files, matching my AME settings as much as possible. These files played as expected, without skipping and did not cause any hangs in either my MacBook Pro or the MacPro. Playback was smooth as silk, seamless.

    I’ve found that h.264 encoded .mp4 files seem to be more problematic than the .mov versions.
    I’ve noticed less than seamless playback using the QT 7 player and VLC player (on Mac).
    I’m in a complete Mac environment for both full-time work and my own side work (OS 10.8+)
    I’m confident that the problems I experienced with the .mp4 files were not related to ProPresenter, the version of Mac OS, or the hardware on either system.
    Is there something to the .mp4 wrapper that Mac/QT dependent software doesn’t like?
    If there’s something I can do to make the .mp4 files I create in AME playback identical to the .mov versions from Compressor, I’d REALLY like to learn what to do. This weekend’s experience was a painful reminder of why I have avoided AME for h.264 files.

    I was initially excited that I could go straight from AE to AME and make the files I needed without going to an intermediate (i.e. ProRes LT). Thought that would save me time and drive space. In the end though, I would have been better off exporting out of AE as ProRes LT and using Compressor to make my h.264 .mov files.


Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy