Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Blackmagic Design 7D PAL 1080i/25P Black Screen in Intensity

  • 7D PAL 1080i/25P Black Screen in Intensity

    Posted by Anmol Mishra on March 28, 2010 at 12:16 pm

    This problem has come up in a few threads. Essentially, BM Intensity Pro shows a black screen AKA no signal when the 7D is set to PAL 25P 1080i.
    Someone suggested that the 7D outputs HDCP.
    That is simply incorrect, as the NTSC signal can be viewed and recorded with Intensity.

    Why is the PAL signal such a problem ?
    Would someone at Blackmagic care to test the Intensity with the PAL 25P / 1080i signal from a 7D ?

    Before someone comments that their 7D only does NTSC, please check your settings as ALL 7D’s do NTSC and PAL. ALL 7D’s allow for 24P, 25P and 30P at 1080i and 50P/60P at 720P.

    Anmol Mishra replied 14 years, 1 month ago 2 Members · 3 Replies
  • 3 Replies
  • Callum Mclay

    March 28, 2010 at 9:49 pm

    Hi Anmol

    I am a little confused by the outputs you mention from the camera, a video signal cannot be “24p, 25p or 30 at 1080i”, as these are progressive formats, and 1080i is an interlaced format. The signal will either be progressive or interlaced.

    The Intensity Pro only supports capture of SD interlaced video, so for PAL and NTSC this is 576i and 480i respectively.

    In HD, Intensity Pro supports capture of 1080i50/59.95/60, 1080p24 and 720p50/59.94/60.

    If you are outputting at SD 576p or HD 1080p25 from the camera, then Intensity Pro does not currently support these video formats, which is why you see no video input on the Intensity Pro.

    Callum McLay
    Technical Support Manager
    Blackmagic Design EMEA

  • Anmol Mishra

    March 30, 2010 at 1:24 am

    Hi Callum. Thanks for the reply.
    The 7D outputs 25P as a 1080i/50i signal.
    It output 24P and 30P as a 1080i/60i signal.
    At least from my understanding.

    When I set the 7D to NTSC – Intensity Pro can “see” the signal.
    When I set the 7D to PAL – no dice. Just a black window..

    I am not the first person to notice this issue..
    Please see..

    https://forums.creativecow.net/thread/124/873245#873245
    https://www.cinema5d.com/viewtopic.php?f=64&t=8870&p=87493&hilit=blackmagic+7d#p87493
    https://www.cinema5d.com/viewtopic.php?f=24&t=7692&p=54997

    Some explanations are :-
    1. So it looks like the camera’s monitoring output AKA HDMI is only capable of doing interlaced NTSC.
    2. Camera outputs using HDCP.

    I can confirm that 2. is wrong as the NTSC signal works..

    As for 1. I can neither confirm or deny this – but this seems a bug, and Canon is unaware of such a bug.

  • Anmol Mishra

    April 3, 2010 at 2:54 pm

    bump..
    Its easy to confirm this issue at Blackmagic. Someone just need to connect a 7D with the PAL switch in the menu to an Intensity card.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy