Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects 3D Pre Comp blurry in parent comp

  • 3D Pre Comp blurry in parent comp

     Michael Szalapski updated 2 years ago 3 Members · 7 Posts
  • Mark Wilde

    September 21, 2020 at 8:45 am

    Hi all

    I’m working on a composition, inside the parent composition is a precomp containing all the 3d lights/ material options etc. `The 3D objects are shapes created in AE taken from original AI vectors.

    When I export the parent compositon the 3D precomp inside loses sharpness. When I export the pre comp on its own, all is ok.

    The pre comp hasn’t been scaled up in the parent, so I’ve not switched collapse transformations on (and of course, when I do this now, the sky falls in and the precomp loses its entire 3D character!)

    I have used a camera within the precomp, and at one stage the 3D object moves quite far back away from the camera in the 3D space. Could it be a depth of field issue?

    Does anyone know whats causing this?

  • Eric Santiago

    September 21, 2020 at 12:05 pm

    Can you provide a sample of the vector/project?

    Try swapping the vector with a shape/solid of similar size then see how that fares.

  • Michael Szalapski

    September 21, 2020 at 2:16 pm

    Screenshots, as Eric says, would be helpful to see.

    You’re concerned about depth of field possibly being the issue, is depth of field turned on in the camera?

  • Mark Wilde

    September 21, 2020 at 7:42 pm

    Thanks guys.

    I’ve attached a screenshot. The first is the pre comp, and the second is the parent. Realise its enlarged to 400% as its a small image but it still shows the difference in quality.

    Depth of field is off.

    Thanks

  • Michael Szalapski

    September 23, 2020 at 2:30 am

    It looks like it’s moved slightly and the colors are different as well. What’s going on in the main comp to change the look of the precomp?

  • Mark Wilde

    September 23, 2020 at 10:13 am

    I think I may have changed the positioning slightly in the parent comp. ignore BG colours I added the background (created in Particular) into the parent comp. The BG in the precomp is just a colour I selected when i created the composition originally.

    The colour change on the actual logo is a mystery thought. I assumed it was because all the lighting etc is set up in the pre comp?

  • Michael Szalapski

    September 25, 2020 at 4:02 pm

    I’m curious about collapse transformations “making the sky fall in” and having everything “lose its 3d character” that you mentioned in your first post. That shouldn’t happen. If you have a comp in your parent comp, it should still work. In fact, layers in the precomp should be able to interact with layers in your parent comp.

    Have you tried rerendering the precomp to see if that changes things? That would let you know if the issue has to do with the layer setup/3d-ness/etc. in your precomp or if something is happening in your main comp to cause it.

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy