Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe After Effects 3D lights and no shadow….hair loss imminent

  • 3D lights and no shadow….hair loss imminent

    Posted by Hamish Boyd on August 15, 2007 at 4:11 am

    OK…
    I know 3D, I understand lights. I have another light and text in my comp happily throwing shadows. I know that the 2nd problem light, the subject AND the layer that is receiving the shadow need to be switched to cast shadows or accept shadows.
    Got it.
    I have checked my angles more times than I care for.

    but still no shadow.
    This is obviously something small but really I’m at a loss now.

    What other variable is there?
    Again, as I understand it there are 3 different parameters that need to be set to see shadow. The light, the subject and the object getting the shadow, but what else can determine whether a shadow is seen?

    Thankyou….

    Jp Pelc replied 10 years, 1 month ago 5 Members · 8 Replies
  • 8 Replies
  • Hamish Boyd

    August 15, 2007 at 4:18 am

    ok this just gets weirder…

    I have positioned some text behind the text that is supposed to throw shadow…

    Still no shadow BUT

    when I move the text behind it and as it is previewing while I move it in low res I see the shadow. Once I stop moving it, the shadow goes.

    what the?????

  • Sam Moulton

    August 15, 2007 at 4:22 am

    possible openGL errors. Try turning openGL off

  • Hamish Boyd

    August 15, 2007 at 4:54 am

    Thanks for your response.

    doesn’t seem to help me.
    but I may have done it wrong.

    I went to preferences and unticked “enable open GL”

    Is that all there is to do?

    The thing is that there is another light and other text in the same comp happily throwing shadows.

  • Hamish Boyd

    August 15, 2007 at 5:32 am

    AHAAAAAAAA!!!!!!!

    Righto I’ll post the reason for anyone who digs this up later.

    It turns out that a 2d layer was below it in the timeline.
    I didn’t know that could effect it. But I guess it does.

    So those in a pickle over silly shadows. Don’t have a 2D layer between object and background (in your timeline that is)

  • Mike Clasby

    August 15, 2007 at 6:47 am

    Good to know.

  • Jeremy Mayhew

    June 23, 2010 at 6:36 am

    I’m having the same problem, only your solution didn’t work for me. I don’t have any 2D layers in my comp. This is really driving me mad! All shadows have just disappeared! Anyone else experience this? Any more ideas?

  • Jp Pelc

    May 28, 2014 at 4:18 pm

    THANK. YOU.

  • Jp Pelc

    May 28, 2014 at 4:26 pm

    I know this post was years ago, but for anyone potentially seeing this thread with the same issues, try moving any 3D nulls to the top of the layer order (or perhaps just under any 2D layers?) I read somewhere else that this fixed the problem for someone

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy