Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe After Effects 1/2 Res Takes 8 min to Render, Full Res Takes 3 Hours…

  • 1/2 Res Takes 8 min to Render, Full Res Takes 3 Hours…

  • Mark Walczak

    April 9, 2009 at 10:45 pm


    As stated in my subject, I’m having some problems with render times. Now, unfortunately I can’t be too descriptive about my project, but I can tell you a few things. For one, there are a lot of particles in the scene – probably about 10,000 on screen at once (but only for 1-3 second spurts). Also, the whole video is about 85 seconds long. I am trying to render 720×405, but my render times at that resolution are in excess of 3 hours on a new Mac Pro (with Nucleo). When rendered at half that size, the render (with just AE, no Nucleo) takes about 8 minutes. I don’t have any crazy effects going on – some noise, a few glows and RSMB…pretty standard stuff. Anyone have any ideas as to what could be causing this issue? Again, I wish I could be more descriptive, but I can’t. Any and all suggestions would help greatly!


    What makes you explode?

  • Darby Edelen

    April 10, 2009 at 12:12 am

    Have you tried turning RSMB off and rendering? Then maybe re-importing and applying RSMB if you really need it? Results might be slightly less awesome, but I’m guessing a lot faster.

    Darby Edelen

  • Brian Charles

    April 10, 2009 at 12:44 am

    With so little detail I can only make a guess at the cause of the problem. I know that in many cicumstances Nucleo can actually slow down a render.

    When you render with Nucleo are all cores utilizing your RAM? You can check this using Activity Monitor. If the cores aren’t going above 50%, try rendering without Nucleo.

    In my experience only certain types of renders benefit from Nucleo. Your particle system and heavy motion blur may not.

    Good luck.

    I assume you are not using CS4 since Nucleo doesn’t work with it yet.

  • Darby Edelen

    April 10, 2009 at 12:49 am

    Yes, not using Nucleo would have been my other suggestion, but I didn’t want to slip into my rabid Nucleo bashing on the forum again 🙂

    Darby Edelen

  • Mark Walczak

    April 10, 2009 at 1:06 am

    Thanks guys – I’ll look into this tomorrow. Yes, I’m using CS3. I’d love to use multiprocessing but fear the color bar errors that I’ve gotten in the past – any suggestions there?

    What makes you explode?

  • Darby Edelen

    April 10, 2009 at 4:55 am

    [Mark Walczak] “color bar errors that I’ve gotten in the past – any suggestions there?”

    What are you referring to exactly?

    Darby Edelen

  • Jan Sherlink

    April 10, 2009 at 8:53 am

    [Mark Walczak] “but fear the color bar errors”

    The last CS3 update fixed that with me.
    installed it ?



  • Mark Walczak

    April 10, 2009 at 1:46 pm

    There (at least at one time) is a known issue with multiprocessing where AE will spit out color bars for certain elements ( Unfortunately, I have ran Adobe Updater, and there are no updates at this time.

    Jan – Is there a particular update that fixed this? Is there any way to make sure I have it installed? I know Adobe Updater isn’t perfect, and would just like to make sure that I have things configured properly.

    I’m going to do some test renders today, and will be sure to post my progress.

    Thanks everyone!

    What makes you explode?

  • Kevin Camp

    April 10, 2009 at 7:13 pm

    i haven’t seen any problems with cs3 (mac) and multiprocessing since the 8.0.2 update.

    since you are using rsmb, i assume you have it applied to footage layers… try pre-composing those layers and pre-rendering them.

    also, there are effects that will disable multiprocessing in ae (i’m not sure how nucleo handles those)… but particle playground, the cc time effect (widetime, time blend) and the auto-color correcting effects (auto-levels, auto-curves, etc) are some of the bundled effects that will disable multiprocessing. not sure if something like that may be effecting your render…

    one other thing… when you say half-res render, do you mean a render from the render queue, or a ram preview at half-res. if it is a half-res ram preview, the preview may render faster due to preview settings that are disabled, like motion blur and frame blending… for the render, by default, those would be enabled and that could cause a significant increase in render time vs preview rendering. if opengl is enable for previews, this too might lead to faster previewing.

    lastly, if disk caching is enabled, you can get a performance hit if the disk cache is on the same drive bus as your media and renders are set to… when you are rendering at half res, each rendered frame and cached frame is 1/4 the size as the full frame, and if they are going to the same drive (or drive bus) this could be creating a data bottleneck, resulting in slower performance.

    you should be able to test this by running the activity monitor (mac) or task manager (windows) during the render. check to see what the background processes that nucleo is running are doing (or if you use cs3’s mp, check ae’s. if the cpu numbers aren’t getting above 50% or so, then it’s likely that you have a data bottleneck.

    Kevin Camp
    Senior Designer

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy