Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D Xpresso random integer node problem

  • Xpresso random integer node problem

    Posted by Sebastien Mercier on December 22, 2018 at 10:19 am

    Hi
    I have problem with “random integer” nodes.
    I m looking to get every 10 frames a diferrent value out of them.
    1rst random node need to output a real between 10 to 20 every 10 sec
    2nd random node need to output a Time(in frames) between 1 to 5 every 10 sec as well.

    So before those random integer node i have a python node who output a boolean
    every 10 frames it switch ON (it s working)
    then out of that im trying to enable/desable random integer nodes but python output won’t drive random integer nodes at all.
    Here my scene file.
    Any help ?

    Brian Jones replied 3 months ago 3 Members · 3 Replies
  • 3 Replies
  • Brian Jones

    December 22, 2018 at 11:28 pm

    it’s not the python going into the Random Integer XGroup that’s a problem, I replaced the python with a Math/Modulo 10 and a Compare (doing the same thing) but the same results. I don’t know why the random integer doesn’t pass values through, it sure looks simple when it’s unpacked.

    12974_randomtest.c4d.zip

  • Dagur Maunason

    March 12, 2024 at 12:26 pm

    Hi! I would love to have a look at this solution, but the file doesn’t seem to exist anymore on the CC servers. Any chance you can share it again somehow? It would be deeply appreciated!

  • Brian Jones

    March 13, 2024 at 12:08 am

    Sorry, my version is not anywhere I can find it.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy