Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Storage & Archiving Weird problem adding 6th client to SAN

  • Weird problem adding 6th client to SAN

  • Francois Stark

    September 1, 2005 at 12:59 pm

    Hi

    We are trying to add a 6th client to our SAN and it is not acting like the other 5 clients. We are running an ADTX fibre box, with three G5’s on os X.3.8 and two G4’s on X.3.4, running flawlessly. All clients are using Apple-branded LSI dual 2gbit fibre cards; two G5’s are running dual link and the others are all single link. Longest fibre cable up to now was 35m. All systems connected to a Qlogic 5200 fibre switch.

    Our sixth client is a G4/ 1.2GHz single CPU running a 80m fibre cable, and we tried os X.3.4 and X.3.8, all with the same results. The new client “sees” only one port on the ADTX box through the switch. The LUn’s are spread out over all 4 ports on the ADTX array, so each client needs to “see” all four ports on the ADTX array to mount the LU’s properly. All 5 other clients work the same, except, it must be said that the first two G4’s had a similar problem when they were on os X.3.9, which we solved by going back to os X.3.4. It seems Apple did something to the LSI Fibrechannel drivers around os X.3.5 and left it broken on all G4 machines.

    The problem is that the new client does not “see” all the ports on the ADTX array. If I bypass the 5200 switch, and plug the new client direct into the ADTX array, it sees all LU’s of that port. I tried two ports on the array, and the G4 “sees” all LU’s correct. But once back on the switch, it “sees” only one ADTX port’s LU’s. The switch should enable it to see all 4 ADTX ports.

    So I though the problem must be on the switch. I found one difference between the new client’s port on the switch and the other clients’: the operational type of the port was set to FL (Fibre Loop), and not to F. So I tried moving the new client to a different port on the switch, and the operation type on this port also changed to FL. That was last night. All other clients was set to type F. I though I found the cause of the problem.

    This morning when I came in, the port’s operational type had changed to F (Fabric), but after several reboots, the new client still only sees one port on the ADTX’s LU’s.

    So now I’m stuck. Any ideas?

    Regards
    Francois

  • Francois Stark

    September 6, 2005 at 5:41 pm

    I have so many oprions to try, but no time… I can swop machines to test optical cables and qlogic switch; I can swop fibre cards between working machines and the bum seat; I can try a dual G4 in the same seat; but I don’t have time!

    About a month after we installed the SAN we started getting so busy – we have seven edit suites running full time now – four FCP’s and three AVID’s. All busy. Three Pro Tools as well. The SAN has opened up the possibility of much larger jobs, and it’s paying off.

    But I’m still stuck on this sixth seat – the machine just won;t see hte LU’s properly.

    Regards
    Francois

  • Floh Peters

    September 6, 2005 at 6:31 pm

    I have a somewhat similar problem with a qLogic 5200 switch and some G4/G5 systems connected to some XServe RAIDs. Most of the time all systems see all LUNs, but ~every 3rd or 4th startup one of the systems does not recognize one channel of the XServe RAID. I

  • Francois Stark

    September 7, 2005 at 5:02 am

    Floh

    What fibre cards are you running?

    Francois

  • Floh Peters

    September 7, 2005 at 6:07 am

    [Francois Stark] “What fibre cards are you running?”

    ATTO 3300 and Celerity 22HX. Some dual-channel, some single channel. The system or port that causes the problems is a single-channel host.

  • Francois Stark

    September 7, 2005 at 7:31 pm

    Thanks. I’m on all Apple-branded LSI fibre cards – with Apple writing the drivers. I suspect that’s the cause of my woes.

    Unfortunately Other cards are much more expensive – the Qlogic dual 3gbit card is almost four times as much…

    Regards
    Francois

  • Floh Peters

    September 7, 2005 at 7:44 pm

    [Francois Stark] “I’m on all Apple-branded LSI fibre cards – with Apple writing the drivers. I suspect that’s the cause of my woes.”

    As I said, the same problem is happening with ATTO cards also.

  • Francois Stark

    September 13, 2005 at 7:40 pm

    Well, I went and bought a new G5 to bolster our offering. Also thought – I need to get rid of the single CPU G4 since that is giving the LU problem. I swopped the fibre card from the G4 to the G5 and the same fault appeared there – in a G5 where I have another fibre card working yesterday!

    So I inspected the fibre cards more closely: The faulty card is a LSI7202P with no heatsink, and the working card (I checked two working cards – they are the same) is a LSI 7202XP – with a heat sink on the main IC. Must be a new model. I think my dealer somehow sold me an old version, since the faulty fibre card was bought last, about three months ago, seperate from the other five cards.

    I’ll have a serious word with him tomorrow…

    Regards
    Francois

  • Francois Stark

    September 24, 2005 at 7:08 pm

    Yep, the dealer apologised and still took 10 days to replace the card…

    So the new card works fine. In a G4 with os X.3.8. Good.

    Thanks for listening!
    Francois

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy