Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Telestream weird playback speed

  • weird playback speed

    Posted by Paul Rogati on August 31, 2009 at 3:16 pm

    I have a new configuration – using a G5 Power Mac (2x2GHz, 4GB RAM, running OS 10.5.8), a AJA Kona LH input card ingesting component video and analog audio.

    While recording, everything seems fine – video and audio are monitoring normally. But when I play back the recorded file (H.264) the audio is a chipmunk with the video playing normal speed.

    I downgraded the Kona drivers from 6.0.3 to 5.1. Now the playback (in QT Player) seems to be the reverse, with fast video playback and normal audio, but playback is inconsistent with replays.

    Anyone know what might be going on? – Paul

    Paul Rogati replied 14 years, 4 months ago 4 Members · 20 Replies
  • 20 Replies
  • Paul Rogati

    August 31, 2009 at 3:49 pm

    I’m thinking it might be a Kona issue rather than a Wirecast issue: I installed QuickTime Broadcaster to see if the behavior was any different. It isn’t. Thanks. – Paul

  • Craig Seeman

    August 31, 2009 at 4:08 pm

    It may well be the Kona card. Can you try a camera with firewire input?
    Please post complete setup specs including all versions of software and hardware. Make sure you’re using Wirecast 3.5.4.

  • Paul Collins

    September 10, 2009 at 5:06 pm

    With H.264 streams and recordings, whether Wirecast or QT Broadcaster, there seem to be audio settings that cause problems like this. Try different sample and bit rates! I’m still trying to find the rhyme or reason for this, but certain rates have caused severe audio sync and speed problems (and loss of audio for some but not all streaming viewers).

    Web/cablecasting: https://ashlandtv20.com
    Software Development: https://www.gracion.com

  • Paul Rogati

    September 10, 2009 at 6:27 pm

    Thanks for the post Paul. I was beginning to think I was creating unique problems. One thing I discovered is that the weird audio speed shows up on the record Mac (in this case with the AJA card), but will play fine on another Mac. I’m thinking that implicates the Kona, but I have issues like you mention with other configurations. I have a handful of Wirecast system setups – some straight Firewire in, one using a Blackmagic card, and one with an AJA Kona LH. I am about to embark on adding HDV to two new setups (oh joy!). – Paul

  • Craig Seeman

    September 10, 2009 at 6:52 pm

    Paul,
    Let me know ASAP when you find which settings cause this in Wirecast and test in QTB with the same settings. They’re both using Apple’s codecs so it may be reproducible in both.

  • Paul Collins

    September 10, 2009 at 9:35 pm

    I’ll check later when I have time. You’d think if simply using certain encoding settings caused these problems, we already have heard about it. Maybe it only happens with slower frame rates (such as 10 and 15 FPS, which I use)–I think someone else mentioned this in connection with a slow rate.

    Web/cablecasting: https://ashlandtv20.com
    Software Development: https://www.gracion.com

  • Craig Seeman

    September 16, 2009 at 6:08 pm

    Maybe this is a sample rate issue.

    Check to see what sample rate you’re recording with Wirecast.
    Test with 32kHz, 44.1kHz, 48kHz and see if the results differ.

    If Quicktime Broadcaster shows the issue and the file playback changes from system to system and the Kona is impacting it, I’m thinking it might be system vs file sample rate.

  • Paul Collins

    September 21, 2009 at 5:16 pm

    I did a brief test streaming 15 FPS video with MPEG-4 audio 48kbps/24kHz sampling, mono. Opened the stream in QuickTime Player 7.6.4 and the audio was chipmunked (sounded like 2x speed). On a hunch, I changed to stereo audio and then the audio was correct. Could be a coincidence, but interesting.

    Web/cablecasting: https://ashlandtv20.com
    Software Development: https://www.gracion.com

  • Craig Seeman

    September 21, 2009 at 5:31 pm

    I think someone also mentioned that mono results in chipmunk but stereo is OK.
    I’m wondering if there’s another correlate.
    Can you try doing the same thing at 30fps using the same sample and bit rate and tell me what happens?

  • Paul Collins

    September 22, 2009 at 3:59 pm

    Craig, 30 FPS didn’t make any difference. I could make chipmunk sound mode (approx. 2x audio playback speed) come and go by switching between mono and stereo with other settings the same. So I guess there’s a bug with mono mode in either the AAC encoder (MPEG-4 audio setting) or decoder in QuickTime.

    Web/cablecasting: https://ashlandtv20.com
    Software Development: https://www.gracion.com

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy