Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Viewport Navigation – rotation controls seem off

  • Viewport Navigation – rotation controls seem off

  • Mostyn Rowley

    September 23, 2019 at 11:25 am

    Is there a way to reset the rotational controls in c4d?

    I’ve done something which seems to have effected the horizontal rotation somewhat.

    Hard to explain exactly how it has changed, but it feels as if the rotation is now ‘curvy’ rather than smooth (if that’s even a thing). Before, when i rotated the view, i would be able to rotate around an object fairly horizontally without having much effect on the vertical axis whereas now, any horiz. rotation ends up with my whole model on a tilt which i would’ve never previously have been able to do.

    I’ve tried a few different tips i’ve seen online:

    cameras > navigation > cursor mode (already active)
    shift + v – zero rotation (no change)

    I’m hoping a c4d guru might be able to make sense of my terribly explained problem.
    Any suggestions would be greatly appreciated – its driving me mad!!!!

  • Mostyn Rowley

    September 23, 2019 at 1:53 pm

    One additional point that may help someone trying to decipher what i’m complaining about…

    If you press shift + v, which brings up the ‘view menu’ then you select the 3D camera & go to its co-ordinates on the right hand side, zero’ing the ‘B’ axis levels out the viewport, correcting the ’tilt’ i mentioned above.

    Now, this used to be a constant – my viewport seemed to never have this ’tilt’ which now occurs whenever you rotate the perspective view.

    Hope that helps explain my predicament a little further.

    Thanks

  • Aris Melachroinos

    March 21, 2021 at 12:12 pm

    I have the same issue. Did you manage to find a solution?

  • Aris Melachroinos

    March 21, 2021 at 12:21 pm

    Nevermind, I found the cause.
    I had enabled the setting: Settings -> Navigation -> Trackball Rotation
    Turning that feature off fixed the issue.

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy