Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums VEGAS Pro Vegas 12 – MTS / M2TS file = sound, no picture or video

  • Vegas 12 – MTS / M2TS file = sound, no picture or video

     Jane Kong updated 6 years, 7 months ago 3 Members · 5 Posts
  • Michael West

    January 5, 2015 at 2:03 am

    So I’ve seen this happen before here and I have fixed it before but don’t know where to start. I’m using a Sony video camera which creates Sony made mts or m2ts files (it labels them as mts). When I drag and drop them into Vegas, all I can see are the audio tracks but not the video. And it’s not as if Vegas is the only app that has this problem. When Vegas has a problem so do other video converters, such as Xilisoft, etc. Oddly enough, Handbrake has no problem converting the mts file into something else.

    I saw advice here or on the Sony site to remove the codec pack that you may have installed from k-lite or other places. At the time that’s exactly what was the fix. But I’m once again plagued by this problem and not sure how to get myself back to the point where only the codec for mts files that Vegas uses is in effect or installed with any other impediment uninstalled or inactive. Hoping others here can lead this horse to the water. Thanks in advance.

  • Dave Osbun

    January 5, 2015 at 4:48 pm

    Have you tried uninstalling/reinstalling Vegas? Have you installed any software/patches/add-ons that could have affected the video codecs since you last uninstalled k-lite?

  • Michael West

    January 7, 2015 at 2:13 am

    Thanks Dave – no, I haven’t done anything that I could surmise which would cause that to happen. I just recall Windows updates and unrelated software. If reinstalling is the only solution, I’ll get to it. But like all software which requires activation, I get nervous reinstalling software, not being sure when and if my installs will be used up. In the past Sony has been very good (which Adobe has been the most brutal to deal with for me, by far.) I’ll let you know how it goes.

  • Michael West

    January 7, 2015 at 8:30 pm

    Reinstalling did the trick. In addition, my Vegas Pro was already registered so that wasn’t removed from my hard disk.

  • Jane Kong

    March 6, 2015 at 7:54 am

    I have the same problem , but reinstall with no luck , so I turn to some third-app to help. Though almost everyone said that you cannot trust the thrid app but sometimes it do did the trick.

Viewing 1 - 5 of 5 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy