Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects using keyboard to control mouse buttons

  • using keyboard to control mouse buttons

  • Ohad Marbach

    January 6, 2019 at 2:25 pm

    I use software to control mouse clicks because my hands hurt from over clicking and the keyboard is easier for me to click. so I use neatmouse or autohotkeys and usually assign f9 and f10 as they are usually free. both work fine with premiere and with browsing but none work with after effects. maybe ae approaches the keyboard differently that premiere?

    another solution I use is controlling the clicks with the phone but all the phone apps that does this and actually work have small virtual buttons and it is very easy to miss the click.

    I already tried finding a mouse that is both silent and easy to click but no success yet.

  • Jeff Kay

    January 7, 2019 at 4:09 pm

    F9 and F10 are by default bound inside of AE. If you have not already, try removing those keybinds (keybinds shortcut ctrl+alt+’). Also make sure that your keyrebinding software is set to work when AE has focus, I know that at least autohotkey has the option for it to be enabled or not (or have multiple profiles) depending on which window is in focus.

    I use a trackball for ergonomic issues and so far that has worked out well for me (since itself, it is treated as a mouse). Though this is not a solution to your issue.

  • Ohad Marbach

    January 7, 2019 at 11:45 pm

    I tried unbinding f7 and f8 but it didn’t do the trick.

    make sure that your keyrebinding software is set to work when AE has focus, I know that at least autohotkey has the option for it to be enabled or not (or have multiple profiles) depending on which window is in focus

    How do you do this with autohotkey?
    what do I need to add to the script? for now I use just
    f7::LButton
    f8::RButton

    after effects is not the only program I have trouble with this. Avid media composer and Cubase too..

  • Ohad Marbach

    January 8, 2019 at 12:06 am

    Solution!!!

    open autohotkey / neatmouse as administrator!! Thats it!!!

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy