Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Using a voronoi fracture on a custom model

  • Using a voronoi fracture on a custom model

     Andy Kiernan updated 1 month, 2 weeks ago 2 Members · 4 Posts
  • Andy Bryan

    June 30, 2022 at 3:46 pm

    Hi all. I’m using C4D r25. I’ve created a basic castle model out of cubes and cylinders, using the polygon extrude tools to create a basic shape.

    I’m now trying to create a ruin effect using the voronoi fracture object. I’ve added rigid body tag to the fracture object and a collider tag to a small sphere. Upped the point amount in the point generator to 400, and change the trigger to “on collision” in the rigid body tag. I then animated the sphere to hit a small section of the castle. But when I animate it, it goes bananas. As though the castle is made of paper. See the attached picture of before the sphere hits and just afters. Everything flies apart.

    Works fine on a simple object like a cube. What’s going on. Is there any way I can get a more realistic effect?

    Thanks in advance.

  • Andy Kiernan

    July 1, 2022 at 8:10 am

    maybe check scene scale, dynamics need proper scale. is hollow object checked on in the voronoi fracture object? if so turn off. is there any intersecting geometry in the original model?

  • Andy Bryan

    July 1, 2022 at 10:29 am

    Thanks Andy.

    You were spot on with the scene scale. Thanks for your help.

    😃

  • Andy Kiernan

    July 1, 2022 at 11:26 am

    great stuff!

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy