Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple OS X Unable to delete partition

  • Unable to delete partition

    Posted by Anna Norton on August 12, 2020 at 4:51 pm

    I am running 10.13.6 and purchased a new 3T WD external hard drive. When I first tried to use it, it only showed just over 801G. I discovered it had a partition and the remaining space was free. However, when I tried to delete the partition using Disk Utility, I got an error message. This led me on a search and then to Terminal. I tried a variety of steps and eventually ended up adding a new partition of 3.1KB instead of merging the first two as I was trying to do.

    Now Terminal shows: (image also attached)
    diskutil list
    /dev/disk0 (internal, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *500.1 GB disk0
    1: EFI EFI 209.7 MB disk0s1
    2: Apple_HFS Macintosh HD 499.2 GB disk0s2
    3: Apple_Boot Recovery HD 650.0 MB disk0s3

    /dev/disk1 (external, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *3.0 TB disk1
    1: EFI EFI 209.7 MB disk1s1
    2: Apple_HFS 3.1 KB disk1s2
    3: Apple_HFS still broken 801.2 GB disk1s3

    Can anyone please list the correct steps and language/verbiage that I can use in Terminal to get the full 3T of space that should be there (or alternate steps through some other process/application)? I have never put any files on the drive, and began this process by formatting Extended Journaled. Thanks so much for any advise!

    John Rofrano replied 3 years, 9 months ago 3 Members · 10 Replies
  • 10 Replies
  • John Rofrano

    August 12, 2020 at 6:54 pm

    Let’s understand what the error message you got in Disk Utility because you should not need to use cryptic terminal commands to do this.

    All you need to do is open Disk Utility. Select the disk and press the Erase icon. That’s it! It should prompt you to erase and create a new single partition.

    ~jr

    http://www.johnrofrano.com
    http://www.vasstsoftware.com

  • Anna Norton

    August 14, 2020 at 12:45 pm

    Currently in Disk Utility, in the left column under External, the drive shows up with 640.8 MBUsed and 80.58 GB free. There is also a second item under External called disk1s2, but it is grayed out. When I click Erase, rename, format Mac OS Extended (Journaled), it works, but still only shows 800.59 GB of free space. The remainder of the 3T is still partitioned out and not accessible.

    So, then I go to Partition, select that 2.2 TB free space, click the – button to delete that partition, click Apply, click Partition and get: “Running operation 1 of 1: Remove “–“… An internal error has occurred and the disk for one of the specified operations could not be found. This may be a temporary issue, try again. Operation failed…” This has consistently been the same error message with the exception of one time when it ran successfully until operation 8 or 9 and then failed.

    Thank you so much for your help!

  • Patrick Sheppard

    August 14, 2020 at 1:49 pm

    [anna norton] “When I click Erase, rename, format Mac OS Extended (Journaled), it works, but still only shows 800.59 GB of free space.”

    Exactly what are you selecting prior to clicking Erase? The hard drive? Or the volume on the hard drive?

    The hard drive is the item in the left column that must be selected before clicking Erase. Erasing a volume will only affect the volume, not the entire hard drive.

    Here’s an example:

    Notice that the hard drive with the long name and alpha numeric characters is the item selected. This is what must be erased in order to regain the rest of the hard drive space. (The item below that is the volume on the hard drive, with the name “Macintosh HD”.)

  • John Rofrano

    August 15, 2020 at 11:22 pm

    As Patrick illustrated with the picture in his post, you need to select the entire drive not any one partition. Erasing the drive will create a new single partition using all of the space on the drive.

    ~jr

    http://www.johnrofrano.com
    http://www.vasstsoftware.com

  • Anna Norton

    August 16, 2020 at 12:49 pm

    When erasing, I click on the hard drive in the left column. It is only when I try to delete the partition that I click on the specific partition to be removed.

  • John Rofrano

    August 16, 2020 at 2:29 pm

    To erase the entire disk and repartition as one partition you must select the actual device and not any partition.

    Like this:


    That will erase the entire drive leaving only a single partition.

    ~jr

    http://www.johnrofrano.com
    http://www.vasstsoftware.com

  • Anna Norton

    August 17, 2020 at 12:57 pm

    That is exactly what I have been doing. (Again, I have only been selecting the partition when trying to delete the partition. (This is not an option when erasing. The only option when erasing is to select the drive in the left column and then click erase.) Erasing still does not return the full space to the disk (which is why I have then gone to try to delete the partition).

    You can see in the photo that the drive “2020” is selected. You can also see the grayed out “disk1s2”. This “disk1s2” happened at some point when I made an error in Terminal. Prior to that however, there was only the one drive showing up under External, but even then, Erase still did not return the full 3T to the disk.

    What am I missing?

    Also, the grayed out “disk1s2” cannot be erased and presents the error message: “The chosen size is not valid for the chosen file system. Operation failed…”

    Thanks again for your help!

  • John Rofrano

    August 18, 2020 at 1:44 am

    [anna norton] “What am I missing?”

    You are missing the Devices. Let me explain… ?

    You know they say, “A picture is worth a thousand words”

    Apple, in it’s infinite quest for making computers easy to use, have made them too simplistic. The default for Disk Utility use to be to show Devices. Now, apparently, the default is to only show Volumes.

    This is evident from your screen capture. Those are Volumes not Devices.


    So you are not selecting the devices because the devices are HIDDEN!!! (What was Apple thinking???) This is why it’s not working.

    The fix is to change your view. Open the menu in the upper left and select Show All Devices. Now the devices will be shown on the left.


    Now Erase should work as we previously described.

    ~jr

    http://www.johnrofrano.com
    http://www.vasstsoftware.com

  • Anna Norton

    August 18, 2020 at 1:09 pm

    Wow… that makes me feel very slow. I can’t thank you enough for the info and patience!!! It worked!

  • John Rofrano

    August 19, 2020 at 9:49 pm

    [anna norton] “It worked!”

    Way to GO! I’m glad that worked out for you. I learned something myself because I didn’t realize that Apple had hidden the devices until I researched the problem for you. So we both learned something.

    Take care! ?

    ~jr

    http://www.johnrofrano.com
    http://www.vasstsoftware.com

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy