Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe After Effects Trapcode Particle to appear when only on white colour

  • Trapcode Particle to appear when only on white colour

    Posted by Ian Ellerby on February 24, 2023 at 1:41 pm

    Hi

    About 8 years ago I created a project where I got Trapcode star particles to appear only when they were over a light colour, in this case moving light grey morse code text on black background. See jpeg. If you look closely the stars only appear over the morse code. I have to work on the project again, and of course as Trapcode has been updated, my settings have been lost.

    I cannot remember how I achieved that then. <font face=”inherit”>I’ve tried almost every conceivable solution in current edition, the whole gambit of modes etc, I dont think I was into expressions then, but I’m failing to replicate this again, I’m in </font>despair!<font face=”inherit”> </font>

    Can anyone shed light on how I may be able to do this in current edition of Particular please?

    I would be very grateful!

    Thanks in advance

    Ian

    Ian Ellerby replied 11 months ago 2 Members · 3 Replies
  • 3 Replies
  • Michael Szalapski

    February 24, 2023 at 9:32 pm

    When you migrate your Particular setup, it doesn’t work? If that’s the case, file a ticket with Maxon – they’re actively trying to fix migration issues.

    That said, this should be fairly easy to do with using that same texture as a layer emitter.

  • Ian Ellerby

    February 28, 2023 at 9:45 am

    Thank you Michael for you reply

    I will file a ticket to Maxon.

    Your advice about using the same texture as layer emitter unfortunately only partially worked, the particle stars are appearing in the ‘relative’ area of the white morse code now, but not staring birth on the white area, see jpeg, so I need to find that reason.

    Thank you again

    Ian

  • Ian Ellerby

    March 29, 2023 at 11:29 am

    Hi

    Eventually found the solution to making particles only appear on the white areas directly, courtesy of post by Doug Y, thanks Doug!

    https://support.maxon.net/hc/en-us/articles/115011090208-Particualr-Why-are-particles-appearing-outside-of-my-Light-Layer-Source-

    – Set the ‘Emitter Size Z’ parameter to 0.

    Thanks Creative Cow!

    Ian

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy