Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro Legacy Snow Leopard update disabled mprg2 playback in Quicktime 7?

  • Snow Leopard update disabled mprg2 playback in Quicktime 7?

    Posted by Tom Matthies on July 8, 2012 at 6:39 am

    I finally updated my otherwise very reliable system to Snow Leopard tonight and have lost my ability to play back mpeg2 encoded files. Since I do a lot of spots for broadcast that go out as HD mpeg2 files, this isn’t good. A Quick Google lead me to Apple that would sell me a Quicktime component that will allow me to play back the files. Since I can still export from Quicktime 7, I’m assuming that the application is still Quicktime “Pro”.
    Any ideas where my mpeg play back components went to?


    Tom Matthies replied 11 years, 10 months ago 3 Members · 6 Replies
  • 6 Replies
  • Tom Matthies

    July 8, 2012 at 7:02 am

    I reinstalled the mpeg Quicktime Component from my original Final Cut Studio 3 disk installer and I now have video play back in Quicktime player 7.6 but no audio with mpeg files. This seems to be a common problem going from Leopard to Snow Leopard. Since it took me this long to up grade this system, surely this problem has veen worked out?


  • Phil Balsdon

    July 8, 2012 at 9:52 am

    This sounds just like an issue I had with mpeg2 HDV files recorded on a Firestore DR-100.

    You might like to check this

    It solved the problem for me, but you have to drop each individual file separately onto the app icon. The fix is pretty much instant and permanent.

    Cinematographer, Steadicam Operator, Final Cut Pro Post Production.

  • Scott Sheriff

    July 8, 2012 at 6:28 pm

    [Tom Matthies] “I finally updated my otherwise very reliable system to Snow Leopard tonight and have lost my ability to play back mpeg2 encoded files”

    When you say that, do you mean that you used the SL disc to update your OS, or you updated your system by doing a clean install?
    Never update FCS or the OS when you’re running FCS. Always do a clean install, preferably on a fresh disc. Then you will have your old system on disc to use in an emergency, and also have access to files on the old disc.
    Had you manually installed the SL 10.6.2 update you might have been OK. Using the automatic software update and going past 10.6.2 as you found, out breaks your mpeg2 component. This has been well documented in this and other forums. This can be fixed if you need a higher version for some reason, just go find the missing mpeg2 component folders from your old system, and move them to the new system. If you didn’t clone your drive, or do a clean install on fresh disc and don’t have the old system files you might try a reinstall of FCS.
    If you have gone the update route, and are having problems but eventually get it worked out, you might consider starting over with a clean install soon. Odds are that there are corrupt/duplicate files from doing this that might cause random lockups/beachball just when you need your system the most. Be sure to trash your prefs and do a permissions repair too. If your FCS installation is temperamental, you might try some of the Digital Rebellion tools. The real, sure fire answer is the meticulas clean install. Everything else is a band-aid.
    FWIW I’ve been running FCS on SL, since the day it came out, and it’s rock solid. I decided to freeze my system at 10.6.2 because no other software I run needs a higher version, and I don’t need app store access built into the OS.

    Always clone your system before doing any type of OS or FCS update no matter how trivial.
    When moving up to a new version of OS and running FCS, always do a clean install.
    Search the forums before updating FCS or the OS.
    Snow Leopard breaks mpeg2 component after 10.6.2, stop there or get these files from a previous (working) install.
    Snow Leopard doesn’t install QT 7 automatically, instead it installs QT 10.0. QT 7 is on the SL disc, it just has to be manually installed. Or you can just drag your QT 7 over from your cloned drive.

    Scott Sheriff

    “If you think it’s expensive to hire a professional to do the job, wait until you hire an amateur.” —Red Adair

  • Tom Matthies

    July 8, 2012 at 10:54 pm

    Hi Scott.
    I did clone my boot disk before doing the upgrade. No, I didn’t do a clean install since this particular machine is a “Swiss Army” machine doing duties including editing, graphics, word processing and MANY other functions. It would have taken a huge amount of time to reinstall and reauthorize all of the other applications if starting from scratch. The dock on this machine has so many icons for applications that the individual icons are so tiny as to be difficult to read. Sometimes a clean install, although the right way to do it, just isn’t practical. I’m paying for the shortcut now. After installing the OS, I repaired permissions and then did a software update through Apple. Unfortunately, it updated all the way through 10.6.8 with one massive 2.3 Gb update so I didn’t have the option to stop at 10.6.2. This is why I waited so long to update-to avoid these stupic issues. The old system running under Leopard was rock solid. No issues at all. I installed a new Radeon 5770 video card yesterday and apparently the only place to get drivers for it is to install Snow Leopard and then upgrade it. After the initial install of SN, the drivers for the video card were still not there. It ran only a single monitor in a default, fail safe configuration. Only after upgrading the OS to 10.6.8 did the drivers get installed correctly and now the card is functioning normally with all three monitor ports enabled. I needed the upgraded card since my older OEM card was having problems handling some 10-bit effects and timeline and having problems displaying OpenGL enabled software properly. I do have to admit, the display is much zippier now and the Open GL effects in Boris are finally working correctly.

    It get around the mpeg play back issues, I reinstalled the mpeg components from my original FCP studio disk. While the video is playing fine now, the audio is still missing. I tried to delete the audio preferences and then do a restart. It works for some systems, but didn’t work in my case. Although Quicktime cannot play mpeg files properly, VLC works fine so I can still check files before sending them out. It’s just kind of inconvenient. Also, mpeg StreamClip is broken. Can’t do some things that worked fine before.
    Even after a clean install, a number of people still had this same problem. It seems to be kind of hit and miss on who is effected. You mentioned pulling the missing/corrupt components from a backup disk? I do have a clone of the working configuration before the Snow Leopard upgrade. Do you have an ideal which components, if copied from the clone could help solve this mess? I can accept that this was a known issue with upgrading, but SL has been around quite a while now and I still can’t find any reliable solutions by Googling the problem. Lot’s of people have had the issue, but no one seems to definitively know what is causing it or how to fix it. Seems a little strange after all this time that SL has been out.

    Anyone get this fixed yet? Let me know.


  • Scott Sheriff

    July 9, 2012 at 6:23 pm

    Go here and read this:
    Scroll down to the Snow Leopard and mpeg2 component.

    On the clean install issue of reinstalling other apps, welcome to our world. LOL!
    Everyone faces this issue, but cutting corners is a train wreck waiting to happen. Don’t talk yourself into cutting corners if you use your machine for business. If you keep your plugins, updates, drivers, apps and serial numbers organized, a clean install should just be an afternoon project.
    The good news is 95% of all apps besides FCS can simply be dragged to the new drive from the clone (or original if you use a fresh drive), without having to reinstall. A few may ask for a ser#. Keep a PDF list of all your ser#, so you can just copy/paste. I have a couple of apps that have to be ‘authorized’, but they worked after a drag from the clone and inputting the ser#. YMMV on that. After you clone your drive, go get all the new drivers and updates you will need and put them in a folder on the clone drive and then it should be pretty straight forward.
    Another tip is to image all you apps to a separate drive and use those disc images to install, which will reduce future install time. This is especially true of FCS since the many discs can be reduced to one operation from a much faster source. It takes some time to do images, but it’s something you can do in your spare time.
    Hope the info on the Squared 5 page gets you back in biz.

    Scott Sheriff

    “If you think it’s expensive to hire a professional to do the job, wait until you hire an amateur.” —Red Adair

  • Tom Matthies

    July 10, 2012 at 1:37 am

    Thanks Scott.
    I’ll probably go back and reinstall everything to a clean drive when I have a few days extra. Final Cut and a few related apps are working fine and I have a number of projects to try and get out the door quickly. If things were totally messed up, I would have just installed the cloned drive back in the computer and reverted back to Leopard. I knew it was going to be fun, finding and installing updated drivers, revised software and such. Other than a few quirky problems, it’s actually working fairly well so far. At least I haven’t found too many issues yet. One weird one is even after updating to 4.4, Disk Warrior is just not working correctly. It’s taking forever to find the disks mounted on the machine and has caused a number of kernel panics while in use. Updated all of the drivers for my eSATA and SCSI enclosures tonight. I’ll see how it behaves after that.
    The old Leopard install was soooo reliable. Sigh…


We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy