Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe InDesign Shortcut to “apply italic” randomly breaking on InDesign

  • Shortcut to “apply italic” randomly breaking on InDesign

    Posted by Igor Freitas on May 17, 2023 at 2:25 pm

    I’ve changed the hotkey for “apply italics” to selected text to F2. For some reason, on some documents, that just stops working, even if I revert the shortcut to the default Shift+Control+I. I use the same fonts, same styles, same everything. Even if I create a new text box with basic paragraph and no character styles, F2 doesn’t work. Once it breaks, it does not come back. If I create a new document, it works again (on that new document only).

    I also have F1 for bold, which never fails (I press once, bold is applied. I press again, bold is removed) and F3 for sentence case, which also never broke on me. Italics is the only one that constantly breaks, on several different documents, for no apparent reason, after working normally for some time.

    It gets weirder. If I manually apply italics to text, then press F2, the program can recognize it and remove the italics. But then if I press F2 again, it won’t apply italics no matter what.

    Any tips on what may be causing this?

    Oscar Polanco replied 8 months, 2 weeks ago 2 Members · 1 Reply
  • 1 Reply
  • Oscar Polanco

    October 5, 2023 at 7:54 pm

    Hi Igor,

    This seems to be a font-related issue, not a hotkey or functionality issue. Sometimes, there are some instances of fonts (especially default system fonts like Minion, Times, Myriad… which have different versions on each system like Apple, Adobe…), and sometimes this affects also when you make the indesign package. My recommendation would be to try in a different document or try to use a different version of Minion.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy