Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Storage & Archiving SanMP, FCP5 and a whole lot of headache

  • SanMP, FCP5 and a whole lot of headache

    Posted by Fillip on September 28, 2005 at 11:31 am

    SanMP, FCP5 and a whole lot of headache


    I have just upgraded to FCP 5, and thus also to 10.3.9 and all of a sudden I am unable to connect to my SAN MP drives. I’ve checked and rechecked my connections, that my card is seated properly, my drivers properly installed. Most bizarre of all, I have another identical (cloned) system which is connecting and working fine.

    The system is:
    Dual G5 2.5
    4 GB RAM
    ATTO Celerity FC22XH
    OSX 10.3.9

    Anyone have any troubleshooting ideas I might try? Many thanks in advance…


    Francois Stark replied 17 years, 11 months ago 5 Members · 17 Replies
  • 17 Replies
  • Christopher Tay

    September 28, 2005 at 4:11 pm

    How are your two systems connected to the storage ? Is it direct or through a switch ?

    Which storage are you using ?

    Is the other cloned system also using the ATTO Celerity ?


  • Nate Cooper

    September 28, 2005 at 4:32 pm


    There are a couple of key things to check here. First launch Disk Utility (Applications > Utilities). This will show you if the volumes are presented to the OS or not. If they are presented to the OS, then install SANmp Admin, log into the Admin application and see if you see the drives in there. If you do, double check your user name and password, and try logging in through the client application again. Don’t forget to go to for the latest versions of software.

    More often then not though, when you can’t log into SANmp, the OS just doesn’t see the disks. If the OS doesn’t see disks then SANmp has nothing to log into. If you do not see your FC disks in Disk Utility then you the OS is not connected to the storage and you need to start checking your connections/hardware.

    Here is a list of things to check if that is the case
    1. Is the card getting a link?
    2. Is the switch (if you are using one) getting a link? Is it linking to the card and the storage?
    3. Have you tried a different port on your switch (if you are using one)? Espcecially good to try the port which you know sees the storage.
    4. Is there any zoning in the switch?
    5. Is your RAID controller a dual channel RAID controller? Apple changed how LUNs are seen by the OS quite a bit between 10.3.4 and 10.3.6, were you upgrading from one of these OS’s and have you asked your storage vender about compatibility?
    6. Have you checked the FC cable?

    This should make it clear wether there is a software or hardware problem, and will give you a few things to check out if it is a hardware problem. If however it is a software issue, drop me a line and I’ll make sure it is resolved.

    Nate Cooper

  • Fillip

    September 28, 2005 at 5:39 pm

    Thanks for the tips guys. To answer your questions:

    I am using a switch to connect to my storage, 2xInfotrend 16 bay unit RAID

    The other cloned system is using the exact same ATTO celerity card (I even exchanged the cards between the two to make sure my card wasn’t at fault, but it works on the ‘working’ system).

    My disks don’t show up on disk utility, but I am getting a green link light on my card, and on my switch (from system to switch and switch to storage).

    I’ve tried exchaning an FC cable from the system that works (to a different, functional switcher port) to my non-working system, to no avail.

    My RAID controller is a Dual Channel one (I’m pretty certain), and although by elimination that would then seem to be the problem, my other system has the same spec and is working smoothly…

    Thanks again guys. The solidarity is very welcome.


  • Fillip

    September 28, 2005 at 6:21 pm

    I’ve just sorted out my system by connecting it with a different cable setup. It now reads storage like a dream!

    Thanks for all the troubleshooting help–now I can get back to work.



  • Francois Stark

    September 29, 2005 at 8:10 pm

    So: os X.3.9 and FCP 5 is happy with sanMP?

    Have you investigated the transition to Tiger with this setup? It seems you have to set up your drive array’s LU mapping differently depending on your fibre channel HBA’s.

    Luckily I’m running all apple hba’s. I don’t know how you will handle it if you’re running mixed hba’s, since one hba’s LU mapping will not work for the other type…


  • Christopher Tay

    September 30, 2005 at 5:27 am


    How are you mapping your LUNs for your ADTX on 10.3.9 ? I’ve tried with an Apple and an ATTO Celerity dual channel HBA and what I find is that if I map the LUNs to isolate them from the individual FC ports on the ADTX RAID controller, LUN 1 generally will not show up. If I don’t map anything, which means all the LUNs are unmapped, then LUN 0 and 1 (I only have two LUNs created) will show up on the desktop.

    I get the same behaviour in Tiger as well.

    Is this what you are seeing too ?


  • Francois Stark

    October 1, 2005 at 7:38 pm

    Hi Chrispy

    I have not gone over to tiger yet. I have one installation that runs FCP 5 on os X.3.9 by cheating: I’m booting a G4 1.25DP on it’s own internal os X.3.9 partition, which is still running FCP 4.5. Then I just run FCP 5 from a firewire drive, where it was installed on a tiger partition! It works! I can actually switch between FCP 4.5 and FCP 5 without rebooting, both using the SAN as media storage! This machine uses the Kona LS card, and it can do a multicam cut between 7 layers of DV footage in real time – on a G4 in FCP 5!

    It can still see my standard LU mapping which all the other os X.3.8 machines can see. I have 17 LU’s on the ADTX, and can send you a email with a screencapture with the LU mapping when I’m back at work on Monday. I also had to run another trick to get the G4 to see the ADTX box at all on anything over os X.3.4 – email me if you need more info on that.

    Back to your question:
    I have to say that I think every type of HBA has it’s own set of drivers, and for each of those you might need a different setup of your LU mapping.

    As I said, I’m on all apple HBA’s, and using those on os X.3 I have found I need to adhere to two rules:
    1. LU 0 must be mapped to every port on the ADTX box. If LU 0 is not “visible” on a port, none of the other LU’s on that port will be visible to the clients.
    2. Each internal LU in the ADTX box must be mapped to only one port. If you map one LU to two ports, those two ports will show up the same LU twice on the desktop, since the client sees both ports through the fibre switch, and thus sees the same LU twice.

    Of course, these rules could only apply to the combination of os X.3, Apple HBA’s and an ADTX LH series drive array. Change any one of them and you could need different LU mapping to work.

    My preliminary tests with Tiger ont he ADTX box did not work properly, but that was about three months ago. I have since received a new firmware for the ADTX box for use with tiger. Bruce from ADTX support has also told me that I need to map all LU’s to all fibre ports for use with tiger (once again, he also specified that this is what is needed for the apple HBA – other HBA’s need different mapping).

    Since that will cause chaos on our current installations by breaking my “rule 2” above, I have no option but to wait until I can ungrade all my machines to tiger at once. That’s going to be difficult, since I have two G4’s and four G5’s in a mixed hardware SAN. I will have to test all these cominations seperately before committing.

    So it seems I can not really help you since I’m running different HBA’s.


  • Bart Harrison

    October 17, 2005 at 2:16 pm

    Hi Guys,

    I am gradually moving my ADTX/SanMP clients over to Tiger without problems (so far) using the new Astera Tiger drivers. As we all know any HBA running Apple based driver/libraries seems to have problems with a “complex” FibreChannel deployment (LUN masking, etc.). Since XServe Raid is a “simple” FibreChannel device no such problems manifest themselves using that array.

    I know they cost more, but I REALLY like Astera HBA’s. We had to wait for the Tiger drivers as Astera doesn’t use the built-in Apple libraries (they write it from scratch), but now it looks like “smooth sailing”.


    – – – – – – – – – – – – –
    Bart Harrison
    MPA – The HD Suite

    America’s VAR
    TurnKey Editing Systems, Storage Area Networks
    HD Consulting, Production & Post, Exhibition & Distribution

  • Francois Stark

    October 18, 2005 at 7:07 am

    Hi Bart

    Am I mistaken? I seem to remember that they stopped making the asera cards. Are they still available? What about support – are they still updating the drivers?


  • Bart Harrison

    October 18, 2005 at 2:25 pm

    Hi Francois,

    There was a rumor many months ago that they were going to stop making the Astera HBA’s. Although widespread, the rumor fortunately wasn’t true. There are Astera cards available (I get them from ADTX) and the new Tiger drivers work fine. Despite reports of it’s death Astera is alive an well !


    – – – – – – – – – – – – –
    Bart Harrison
    MPA – The HD Suite

    America’s VAR
    TurnKey Editing Systems, Storage Area Networks
    HD Consulting, Production & Post, Exhibition & Distribution

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy