Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums DaVinci Resolve Resolve 17.4 (Free) upgrade – unable to install

  • Resolve 17.4 (Free) upgrade – unable to install

     Jose Gomez updated 3 weeks ago 4 Members · 8 Posts
  • Michael Reed

    October 26, 2021 at 1:28 am

    It tells me I need to verify the location exists, and won’t install.

    I have always just used the default paths etc for the installation so am confused as to what to do next.

    I’d very much appreciate some guidance.

    Thanks

  • Michael Reed

    October 29, 2021 at 5:11 am

    Anyone?

  • Michael Reed

    October 29, 2021 at 9:07 am

    I tried with 17.4.1 executable – no luck.

    Backed up database and uninstalled Resolve and all other BlackMagic products.

    Tried a fresh install of 17.4.1 but I get the SAME error and cannot install it at all.

    So now I don’t even has resolve on my system, which makes me unhappy.

    Maybe someone can look at their install and see if there is an installation log file please?

  • Jon Zanone

    October 29, 2021 at 11:27 am

    You’re positive you have admin rights to the drive? That’s the first thing I’d check.

  • Michael Reed

    October 29, 2021 at 11:33 am

    Well it’s my home pc so yeah that shouldn’t be an issue and never has been in the past.

    There is only one user account on the PC and that’s mine 🙂

    I also tried right click ‘run as administrator’ – same result as always.



    I have been trying various things and attempted to install previous versions of resolve (for which I still have the install files) and they are not working either.


    So it is a general Resolve issue, not specifically a version 17.4 issue.

    Hopefully that will help when it comes to narrowing down possible causes and remedies.

  • Tristan Summers

    October 29, 2021 at 12:52 pm

    I had to install. Uninstall. Reinstall and restart before resolve studio would open a project when i updated to 17.3 and 17.4.

    I copied the .exe from the zip to the desktop and extracted/installed getting there.

  • Michael Reed

    October 31, 2021 at 7:36 am

    Yep – doesn’t work sadly.


  • Jose Gomez

    November 11, 2021 at 7:08 pm

    I am positive you have admin rights to the drive

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy