Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro Legacy Registering QT Pro in FCP5?

  • Registering QT Pro in FCP5?

    Posted by Tom Matthies on May 21, 2005 at 4:36 am

    OK, brain fart time. It’s getting late.
    Just got FCP 5 today, installed it(quite a marathon!) and I’m trying to register QT Pro. Tried the usual ways, entering “Quicktime Pro” for user and the FCP serial number, but it won’t accept it. If I just enter the default into, with the serial field noted as “automatic”, still doesn’t want to work.
    It’s late and I’ve been sitting at one keyboard or another since 8am this morning. Guess I’m just pooped out. Go figure.

    OK, what’s the trick…step by bloody step?

    Thanks and I’ll read all the clever and painfully obvious answers in the morning when I’m fresh.
    G’nite all.
    Tom

    Bret Williams replied 19 years ago 5 Members · 8 Replies
  • 8 Replies
  • Kerry Brown

    May 21, 2005 at 4:51 am

    If you already QT7 installed it updated to Pro automatically.

    KB

  • Bret Williams

    May 21, 2005 at 5:12 am

    I don’t have 5 yet, but you misspelled QuickTime. Should be a capital T.

  • Kerry Brown

    May 21, 2005 at 5:54 am

    Sorry, I’ll do better next Time.

    KB

  • T. J. shank

    May 21, 2005 at 6:00 am

    I installed FCStudio a day or two ago, and since then all the QT Pro controls work (not greyed out). Seems like Pro was activated when I installed Studio.

    tjs

  • Bob Vick

    May 21, 2005 at 1:35 pm

    Not sure about FCP5, but in earlier versions you didn’t enter the FCP number but you had a separate, different QT number to enter to activate QT Pro. Maybe you are entering the wrong number??

    b

    Bob Vick sr promo guy @ ch3 wwmt tv, kalamazoo, mi

  • Bob Vick

    May 21, 2005 at 1:39 pm

    Read the post below about the procedure. I think you must load in QT 7 first then FCP 5. No separate number needed.

    b

    Bob Vick sr promo guy @ ch3 wwmt tv, kalamazoo, mi

  • Tom Matthies

    May 21, 2005 at 3:50 pm

    Lo and behold (I know how to behold, but I’m not too sure about the lo-ing part), when I started up this morning to check the multitudes of clever answers to this post…QT Pro was working. In my tired stupor last night, after editing all day and into the evening and THEN deciding to install the entire studio bundle on my new computer…did I even think to do a restart on the computer afterwards. Nope. That would have made too much sense.
    I guess that’s all it took. All the greyed out features seem to be available now. Duh.
    FWIW, the install went flawlessly. I installed on a new G5 that had not previously had FCP installed. It just asked for the old FCP4 serial number and then it took off. About an hour and a half later, it was done. Repaired permissions and called it a day.
    I’ve launched each application and so far, so good. Everything seems to run, at least at the root level.
    We’ll see how the rest of it goes as I transfer stuff over from the old G4 in the next couple of days, but so far, no problems at all. Yay!
    Thanks for the help!
    Tom

  • Bret Williams

    May 22, 2005 at 2:08 am

    Wasn’t talking to you. In the past, if you didn’t type it in as a capital T, it didn’t work.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy