Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D R20 export fails OS X Ventura 13.6

  • R20 export fails OS X Ventura 13.6

    Posted by Chris Neale on February 26, 2024 at 2:53 am

    Hi! I’m new here… hope someone can help as I’m stumped! I’ve had C4D R20 running fine for years but ever since updating to Ventura I can no longer export files successfully. When I try to export to .stl one of two things happen: a) the export process appears to execute normally, but no exported file is saved anywhere. B) The export process executes then an application error alert appears; when you click ‘OK’… C4D crashes. However, I just tried running the app as administrator and did actually manage to export and save a .stl file one time only… before once again returning to the results already described. No body else on the internet seems to have had this problem and Maxon support doesn’t seem to know either. Can anybody suggest what on Earth this could be… why would it work one time, only to fail over and again after that?

    Brie Clayton replied 3 months, 2 weeks ago 3 Members · 10 Replies
  • 10 Replies
  • Kouraib Abdmalek

    February 26, 2024 at 8:39 am

    Hi Chris,

    Here’s what Maxon had to say about this issue:

    Note 2 – It is no longer possible to install Cinema 4D R20 under macOS 13 Ventura. MacOS has introduced higher security restrictions for older programs, that prevent the installer from running, especially if you use an Apple Silicon system.

    If you have your previous Cinema 4D installed on an older macOS already, you may be able to copy and paste the entire MAXON Folder from the old Applications folder of the old macOS to the new macOS.

    We cannot guarantee the stability of older software, working on new hardware architecture than it was designed for.”

    As you can see, it seems that the matter is related to a fundamental problem, so you can only get around this by installing a newer version of Maxon or by downgrading to an older version of the Mac. You can also convert your files to Stl or other extensions via Internet websites.

    I hope this is useful to you.

  • Chris Neale

    February 26, 2024 at 12:41 pm

    Thanks for your reply but I’m inclined not to give up so easily on this when the application works in every other aspect apart from exporting a file. I have both R19 and R20 installed on another internal HD when I launch those applications the same problem occurs, so I don’t believe all three copies have been corrupted. It would appear something in OS 13.6 is interfering only with the export process… surely if it can be identified, there must be a way around it? The same applies to exporting to other file formats… mostly it fails but occasionally it succeeds. Surely if it was a generic OS compatibility problem, other users would be experiencing the same problem… anyone else?

  • Kouraib Abdmalek

    February 27, 2024 at 9:35 am
  • Chris Neale

    February 27, 2024 at 12:12 pm

    Thanks buddy, where am I likely to find one… sorry (I know nothing about scripts).

  • Kouraib Abdmalek

    February 28, 2024 at 8:41 am

    Please let me know first if the script I sent you worked well with Fbx and Obj. Then we will try to find the Stl script. I think we will only have to change the extension number in the script. For example, Fbx corresponds to number “13” and Obj number “14”. If we make sure that the script worked well, then it remains to find the number that corresponds to the Stl extension and put it there

    Thanks!

  • Chris Neale

    February 28, 2024 at 2:39 pm

    Hi Kouraib… unfortunately, when you try to export as .obj the script exports a .dxf file.

    When you try .fbx nothing happens at all.

    Regards

    Chris

  • Kouraib Abdmalek

    February 29, 2024 at 9:03 am

    This is a good start, now in the script that exports to dxf, change the number here

    c4d.CallCommand(60000,13) 

    from 1 to 20 and you will get another extension every time, and some of them will not produce anything until you get the extension you are looking for. The reason is that the coding related to the extensions changes from one version to another. For example, the number 10 in the old versions was for Fbx, but in R23 it became 13, and so on.

    good luck!

  • Chris Neale

    February 29, 2024 at 2:35 pm

    Thanks buddy… these work. Just out of interest can you tell me how you make the icons you included as .tif files?

    C4D R20

    Export as OBJ = 6

    Export as FBX = 7

    Export as STL = 8

    Export as 3DS = 9

    For anyone else who knows nothing about how to write a Python script for Mac with TextEdit go here: https://www.cs.utexas.edu/~mitra/csSummer2019/cs313/start.html (Says not found but the url works).

  • Kouraib Abdmalek

    March 1, 2024 at 1:45 pm

    Good news! I’m glad to hear that it worked for you, you could make a similar icon using Paint, I have made one for the STL for you, as for complex icons you may need Photoshop or other photo editing programs that work with layers, below a link for an article that explains all of that.

    https://www.wikihow.com/Create-a-Windows-Icon

  • Brie Clayton

    March 1, 2024 at 3:13 pm

    Thank you for solving this, Kouraib!

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy