Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Creative Community Conversations QuickTime and MP4 audio sync

  • QuickTime and MP4 audio sync

  • Oliver Peters

    May 2, 2021 at 10:42 pm

    I’m not sure if anyone’s noticed this, too, but lately audio sync is horrible with H.264 MP4 files playing in QuickTime player and VLC. The same files are fine in Switch. I can upload those files to Frame and the playback from Frame’s player is also fine. This is on Catalina Macs. I haven’t tested this too much with Big Sur, but it wouldn’t surprise me if it happens there, too. These are typically files created via Premiere Pro direct exports or through Adobe Media Encoder. Thoughts?

  • Michael Gissing

    May 2, 2021 at 11:08 pm

    I’m not having any issues with those files from Resolve into VLC on Windows or Linux at 24 or 25fps. Pr can do weird things with variable frame rates? Maybe they have a metadata bug in Pr/ Media Encoder.

  • Oliver Peters

    May 3, 2021 at 12:45 am

    Thanks. I’ll have to test a few different encoders.

  • Scott Thomas

    May 5, 2021 at 9:32 pm

    I’ve not tried it yet, but Adam Plouff’s Battle Axe has a new compression tool, Anubis.

    https://www.battleaxe.co/anubis

  • Michael Gissing

    May 6, 2021 at 3:53 am

    I also use Shutter Encoder for some background renders while I keep going in Resolve. They also have a Linux version which I run on my laptop.
    https://www.shutterencoder.com/en/#downloads

  • Mark Suszko

    May 7, 2021 at 1:59 pm

    I can never figure out where sync problems like this originate. When I make stuff for youtube and facebook, I’m making mp4 files and they play with proper synch locally. Watching them stream on my facebook feed, they almost always look like the lip synch is off to me.

  • Joe Marler

    May 9, 2021 at 1:28 pm

    I don’t see any sync problems on Catalina or Big Sur on my iMac Pro for Premiere-encoded H264 files viewed in Quicktime. I just tested a 4k/23.98 ProRes 422 file from a Sony A7RIII and Ninja V, imported to Premiere 15.1.0, exported as 4k/23.98 H264, and it played in sync on Quicktime and VLC.

    If using an external monitor with audio separate from the monitor, there is a theoretical problem due to video processing delays in the monitor (esp. TV-type monitors). Sometimes this can vary randomly with scene type, as the monitor has fluctuating video processing latency. If the monitor is driven by external video hardware (Blackmagic, AJA, etc) that is another possible source. One way to test that is use local playback on an iMac or similar computer and no external or wireless audio.

    If a file containing a slate clap (or hand clap) is imported to Premiere, FCP or any other NLE, the audio waveform should line up with the clap. If it lines up but there’s an audible sync problem when played back, that implies an A/V delay problem during playback. Usually that happens as video latency (IOW audio leads video). Observing whether video is late or audio is late can be a clue about possible causes. It can also be a clue to observe whether the mis-sync is constant or varies over the program.

    If it appears mis-synced during local playback but in sync after upload and during streaming playback, maybe that’s because the streaming file has been re-encoded and is lower resolution? What if that re-encoded streaming file is downloaded and played back in Quicktime?

    Are the problem files originally camera files with constant frame rate, or are they captured and encoded with variable frame rate?

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy